LAN to LAN routing when Windows 2003 Server is not the default gateway

I have already searched through the knowledge base an cannot find an exact answer to what I am trying to achieve.  Please point me in the right direction if an answer is currently posted.

I have a network impairment generator that I am configuring for VoIP testing purpose. (Shundra Cloud)

I have configured a windows 2003 server box with 2 NIC cards and have installed the Shundra software.

Phase one is to just get routing working between two subnets.

My existing network consists of a Cisco Catalyst 3560 that is performing routing functions, internet access and is the default gateway. (DG: /24)

I have patched the windows 2003 box into this network and have assigned a static IP address ( /24)
I have configured the second NIC card with an IP address of (

There is a PC connected through a linsys switch with a static IP address of  I can ping to the Internal interface of the Windows box ( from But that is a far as I can get.

I can ping to the default gateway ( or to the PC from the Windows box.

I have tried enabling RRAS with LAN-to-LAN routing with no success and I have turned on IP forwarding via the tcpip registry key.

Do I need to add static routes on the Cisco Switch or do I need to add them in Windows RRAS?
This is the routing table on the windows box acting as a router:

Microsoft Windows [Version 5.2.3790]
(C) Copyright 1985-2003 Microsoft Corp.

C:\Documents and Settings\Administrator>route print

IPv4 Route Table
Interface List
0x1 ........................... MS TCP Loopback interface
0x10003 ...00 04 75 f7 8a c7 ...... 3Com EtherLink XL 10/100 PCI For Complete P
 Management NIC (3C905C-TX) - SHUNRA\Cloud WAN Emulator Miniport
0x10004 ...00 b0 d0 c1 e7 d0 ...... 3Com 3C920 Integrated Fast Ethernet Control
er (3C905C-TX Compatible) - SHUNRA\Cloud WAN Emulator Miniport
Active Routes:
Network Destination        Netmask                   Gateway                 Interface         Metric                                          1                      1                              1                  1              20                           20          20                                   1                            20                1         1
Persistent Routes:

Who is Participating?
kyleb84Connect With a Mentor Commented:

Change that route in the pix to say:

ip route 192.168.254.X

(I'm guessing your C3560 has a 192.168.254.X ip address that allows it to connect to the PIX? If so replace the above X with the rest of that IP, else can you let me know if the PIX has a 192.168.30.X IP?)

Should work then :)

Your routing table of the Windows Router looks fine....

Make sure your 3560 has this route:
- ip route

And your PC has got a default route or a specific route to the 30.0 network (Use one):
- route add mask
- route add mask

After confirming that, try:
- ping from, and then vice-versa.
- Make sure Windows Firewall is disabled on the Windows Router, and the box.

Look forward to hearing your progress...
Sorry that Ping test mentioned above should be:

Ping from (The Client PC), not 2.1 (The Windows Router), and vice-versa.
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

ipblueAuthor Commented:
Thanks for the advice. Adding the static route on the c3560 corrected the ping in both directions. When I try to add either the specific or default route onto the PC I get a bad argument statement. I have tried to add this on both the PC and the windows server acting as the router.

The problem that i am having now is that I cannot reach the internet. (I need to do so for licensing purposes)

Cannot access the internet from the Windows Router or the PC?

The PC must have a default route, since the command failed just go to:

Control Panel->Network Connections->(Right Click on your LAN Adaptor)->Properties->
- Scroll down to find "Internet Protocol (TCP/IP)", select it, hit properties.
- Select "Use the following address"
- Add your ip address
- Subnet Mask
- Default Gateway

Select "Use the following DNS server address"
(Enter in your network's DNS server, or your ISP's one)


On your Windows Router, do the same, but right click on the interface that connects to the Cisco switch, not the one that goes to the PC.

Do the same thing for it:

DNS: (As per your network, or your ISP's recommended DNS servers)


If your Default Gateway (Cisco) does NAT etc... then it'll work!

Else if you have another internet modem/router behind that Cisco 3560 you'll have to add routes back to the network via the Cisco switch...

Let me know how you go!
ipblueAuthor Commented:
I should re-phrase my issue:

I cannot access the internal interface of my PIX from the PC or Windows box acting as a router.
I already had the default gateway and DNS server as specified.

I can not access the internal interface of my pic 515e firewall. The IP address is /24.

All of my other networks have no problem reaching this interface. The ony difference is the router that is connecting the network to the network is not the default router.

Topology goes:

PC -> Windows Server(router) -> c3560 -> Pix 515E -> Intern
I  added a route as follows on the PIX: route inside 1

ipblueAuthor Commented:
Sorry about this never being closed out.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.