How to find the SMTP settings on Exchange 2003

Hello
we have an exchange 2003 server and our website uses forms to send email invites. These email invites goes to the website hosting SMTP server and i would like to change that to our internal exchange server to process these web mailing.

I put in the Public IP address for exchange and it sends out email invites only internally and doesnt send out emails to outside like hotmail or gmail.

Please advise.
rdvargheseAsked:
Who is Participating?
 
gupnitConnect With a Mentor Commented:
Hi,
Your first screenshot...smtp-relay.JPG should look like the one I have attached here and the list should have IP Address of the Webserver Server
Hope this helps
Thanks
Nitin

SMTP-Allow.bmp
0
 
gupnitCommented:
Hi,
Use the Internal IP Address of the Exchange 2003 Server for the WebServer to use as SMTP Server
Also, in Exchange SMTP Virtual Server make sure that the Websever is allowed.
  • Go to ESM-> Administrative Groups-> Locate your Server(FE Server if you have one)
    Protocols->SMTP-> Default SMTP Virtual Server
  • Right Click Properties
  • Go to Access Tab-> Relay Restrictions-> Click on Relay
    Add your Internal Web servers IP Address here.
Hope this helps
Thanks
Nitin

 
0
 
rdvargheseAuthor Commented:
The web server is hosted by this third party company.
0
What Kind of Coding Program is Right for You?

There are many ways to learn to code these days. From coding bootcamps like Flatiron School to online courses to totally free beginner resources. The best way to learn to code depends on many factors, but the most important one is you. See what course is best for you.

 
gupnitCommented:
Oh I see....in that case instead of Internal IP Address, give Websver the External IP of Exchange server
Also in Exchange SMTP Virtual Server make sure that the PUblic IP Websever is allowed. Go to ESM-> Administrative Groups-> Locate your Server(FE Server if you have one)
Protocols->SMTP-> Default SMTP Virtual Server  Right Click Properties  Go to Access Tab-> Relay Restrictions-> Click on Relay
Add your Internal Web servers IP Address here.

0
 
rdvargheseAuthor Commented:
I tried putting the external IP - but it would send emails only within the company domain... it cannot send to yahoo or google.
0
 
rdvargheseAuthor Commented:
Basically The website is hosted by a thirdy party hosting company and we have an internal Exchange Server. The website used to send email invites using their own email servers (at the hosted company) and now they want us to use our own exchange server.
0
 
gupnitCommented:
It is ok....
Is you Exchange Server responsible for sending/receiving external mails. Or does it push the mails to a smart host/SMTP Server.
If it is doing the sending on its own, then what I said above will do the trick !
 
0
 
gupnitCommented:
Well Well, hope the SMTP Mail Address that you are using is same as others in the system.
0
 
rdvargheseAuthor Commented:
yes. The smtp mail address is the same. and Exchange can send or receive external emails... How do i find if its pushing to a smart host?
0
 
gupnitCommented:
How is SMTP Virtual Server confirgued..do u have a smart host configured on it !!
Also, is ur MX record pointing to Exchange Server IP, if yes then Exchnage is pushing out also directly
0
 
rdvargheseAuthor Commented:
mail.xyz.com    has IPAddress       61.10.64.64

then for any MX record pointing to the above address i have following
 
10  xyz.org.s6a1.psmtp.com.         61.10.5.10
20  xyz.org.s6a2.psmtp.com.         61.10.5.11
30  xyz.org.s6b1.psmtp.com.         61.10.5.13
40  xyz.org.s6b2.psmtp.com.         61.18.5.14

0
 
Dan ArseneauCommented:
Sounds like your trying to enable Relaying for this external web host.  Is that right?
0
 
rdvargheseAuthor Commented:
yes. Web server is external - Exchange Server is Internal. Website needs to send all email to Exchange Server.
0
 
rdvargheseAuthor Commented:
I am including some snaps of the settings
smtp-relay.JPG
Connectors.JPG
Intelligent-Message-Filter.JPG
0
 
Dan ArseneauCommented:
For the SMTP protocol, under Access, hit the Relay button and your website IP (source of SMTP) to the list there.  You will need a Connector to send the email back out.
You will need to allow the website IP, Port 25 through your firewall.  Port Forwarding would be secure enough.
0
 
Dan ArseneauCommented:
For the SMTP protocol, under Access, hit the Relay button and your website IP (source of SMTP) to the list there.  You will need a Connector to send the email back out.
You will need to allow the website IP, Port 25 through your firewall.  Port Forwarding would be secure enough.
0
 
rdvargheseAuthor Commented:
Dan:
why should i add a computer to the relay - when i already have "all except the list below"
selected?

Can you tell me more about how to create this connector to send the email back out?

0
 
rdvargheseAuthor Commented:
Also my exchange server can send emails outside (to yahoo / gmail) - do i still need to setup a connector?
0
 
Dan ArseneauCommented:
If you already have a 'front-end' server that is functional, then no you shouldn't have to do anything further.  The SMTP service just needs to know that your website is allowed to use it as a relay host.
0
 
Dan ArseneauCommented:
If you already have a 'front-end' server that is functional, then no you shouldn't have to do anything further.  The SMTP service just needs to know that your website is allowed to use it as a relay host.
0
 
Dan ArseneauCommented:
If you say that all is allowed, I would just check your firewall then.  

Every comment I put up is posting double...Seems to be happening when I use the link to this topic from my mail client.
0
 
Dan ArseneauCommented:
If you say that all is allowed, I would just check your firewall then.  

Every comment I put up is posting double...Seems to be happening when I use the link to this topic from my mail client.
0
 
rdvargheseAuthor Commented:

i checked the Firewall and it has port 25 open.
Please correct me if i am wrong:
so if i have an exchange server - can anyone from outside send their mailing requests to my exchange server - provided they know  two things:
1-My public IP and
2- Domain Credentials (a Username and password) provided by me.
 
0
 
gupnitCommented:
Hi,
Am back !!
See from your reply, it is clear that Front Server that has OWA hosted has the Public IP of  ( 61.10.64.64). But let me clarify that what you have sent me clearly states that your Frontend is not being used as Smart Host (sending/receiving mails).
Now, that your MX records show these entries, can you please confirm what IP did you give in the Webserver for Exchange server to route mails using that.
Also, one thing needs to be made clear, since your Server is not an open relay any outside webserver will need to be given explicit permission to use your messaging setup to send out mails.
Hope I am making sense, please elaborate on ur setup, else it will be diffcult
Thanks
Nitin
0
 
rdvargheseAuthor Commented:
Gupnit:
1 - Yes. Front end is not being used as smart host.
2- 61.10.5.10 is the ip address that i gave in the webserver to send mails to my exchange (i tried 61.10.64.64 and it didnt work) .. with 61.10.5.10 i was able to send emails within the exchange domain - and not outside.
3 - How can i give explicit permission for the outside webserver to use exchange to send out mails. ?
 
 
0
 
gupnitCommented:
Hi,
Now you got to confirm one more thing to me, before I give an exact solution.
If this 61.10.5.10 the Public IP of your Exchange Server (backend) oris this the IP Address of some other server
Thanks
Nitin
0
 
rdvargheseAuthor Commented:
Yes its the public ip of the exchange server.

0
 
gupnitCommented:
Hi,
It worked?
Thanks
Nitin
0
 
rdvargheseAuthor Commented:
Yes.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.