Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

configuring statip IP routing table using loopbak address

Posted on 2008-10-06
3
Medium Priority
?
799 Views
Last Modified: 2008-10-06
I'm preparing for CCNA certification and I just began playing around with routers in GNS3 simulator.  I'm creating a simple network using 2 routers connected by GigaEthernet cable.  I've configured each routers to have an IP address and a loopback address.  I'm tring to create a static IP routing table.  Following is the commands that I have used to configure the router(R1):

hostname R1
interface g1/0
ip address 192.168.1.1 255.255.255.0
no shutdown
interface loopback0
ip address 10.10.10.1 255.255.255.0
no shutdown

I configure router (R2) in the same way using loopback - 172.20.100.1 and IP - 192.168.1.2
I do the show command and everything is in place and I do the same for router R2.
The following is the command that I'm entering to create the static routing table for R1:
ip route 172.20.100.1 255.255.255.0 192.168.1.2

When I enter, I get an error "Inconsistent address and mask".  I tried reversing the loopback address and the IP address and I get the same error.  What am I missin?
Thank you in advance.

0
Comment
Question by:elly960
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 
LVL 43

Accepted Solution

by:
JFrederick29 earned 200 total points
ID: 22653564
Either enter this:

ip route 172.20.100.1 255.255.255.255 192.168.1.2

Or this:

ip route 172.20.100.0 255.255.255.0 192.168.1.2
0
 

Author Comment

by:elly960
ID: 22655972
it worked.  Thank you.  But I wish I understood why I have to configure it like that.  
0
 

Author Comment

by:elly960
ID: 22656318
JFrederick,
Can you please take a look at my other question "Configuring three routers with loopback address"?
Thank you so much for your help.

0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article is a guide to configure bridging on Cisco Routers.  This is something I never knew was possible until after making a few phone calls to Cisco.  Using bridging saved our company money by not requiring us to purchase a new switch.  Bridgi…
In the world of WAN, QoS is a pretty important topic for most, if not all, networks. Some WAN technologies have QoS mechanisms built in, but others, such as some L2 WAN's, don't have QoS control in the provider cloud.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses

636 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question