?
Solved

Configuring three routers with loopback address

Posted on 2008-10-06
24
Medium Priority
?
4,746 Views
Last Modified: 2012-05-05
I'm preparing for CCNA and working in GNS3 simulator.  I understand how to configure two routers now but having a hard time figuring out how to configure router 2 of this next configuration.  There are three routers in this simple network.  R1 is connected to R2 and R2 is connected to R3.  There isn't a direct connection from R1 to R3.  Following is the IP and Loopback addresses for the routers:

R1:
Loop - 10.10.10.1
IP - 192.168.1.1

R2:
Loop - 172.20.100.1
IP - 192.168.1.2
IP - 192.168.2.2

R3:
Loop - 172.16.100.1
IP - 192.168.2.1

R1 is connected to R2 via g1/0 (gigabitEthernet).
R2 is connected to R3 via R2's g2/0 and R3's g1/0.

I've configure the routers this way:

R1:
int g1/0
ip address 192.168.1.1 255.255.255.0
no shutdown
int loopback 0
ip address 10.10.10.1 255.255.255.0
no shutdown

R2:
int g1/0
ip address 192.168.1.2 255.255.255.0
no shutdown
ing g2/0
ip address 192.168.2.2
no shutdown
int loopback 0
ip address 172.20.100.1 255.255.255.0
no shutdown

R3:
int g1/0
ip address 192.168.2.1 255.255.255.0
no shutdown
int loopback 0
ip address 172.16.100.1 255.255.255.0
no shutdown

I'm trying to create a static routing table.  I can seem to get R1 talking to R3 and vise a versa.
This is how I created the routing trable on each routers:

R1:
ip route 172.20.100.1 255.255.255.255 192.168.1.2

R2:
ip route 10.10.10.1 255.255.255.255 192.168.1.1
ip route 172.16.100.1 255.255.255.255 192.168.2.1

R3:
ip route 172.20.100.1 255.255.255.255 192.168.2.2

What am I missing or what did I do wrong?
Thank you in advance.
0
Comment
Question by:elly960
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 9
  • 8
  • 5
  • +1
24 Comments
 
LVL 8

Expert Comment

by:sstone55423
ID: 22656109
You want to route the whole network, not just one IP:
R1:
ip route 172.20.100.0 255.255.255.0 192.168.1.2

R2:
ip route 10.10.10.0 255.255.255.0 192.168.1.1
ip route 172.16.100.0 255.255.255.0 192.168.2.1

R3:
ip route 172.20.100.0 255.255.255.0 192.168.2.2
0
 

Author Comment

by:elly960
ID: 22656268
It's still not working right.  
From R3 I can't ping R1 and I only get 80 percent success rate to R2:192.168.2.2.
From R2 I only get 80% success rate to R1:192.168.1.1.
From R2 to R3:192.168.2.1, I get 100% success rate.
From R1 to R2:192.168.1.2, I get 100% success rate.
I can't ping R3 from R1.
I'm still missing something.
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 22656399
Here you go...
 

R1:
ip route 172.16.100.0 255.255.255.0 192.168.1.2
ip route 172.20.100.0 255.255.255.0 192.168.1.2
 
R2:
ip route 10.10.10.0 255.255.255.0 192.168.1.1
ip route 172.16.100.0 255.255.255.0 192.168.2.1
 
R3:
ip route 10.10.10.0 255.255.255.0 192.168.2.2
ip route 172.20.100.0 255.255.255.0 192.168.2.2

Open in new window

0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
LVL 8

Expert Comment

by:MrJemson
ID: 22656603
Forget static routing!
Go with RIP!

All IPs will be contactable by all stations
R1:
 
router rip
 version 2
 network 192.168.1.0
 network 10.10.10.0
 
R2:
 
router rip
 version 2
 network 192.168.1.0
 network 192.168.2.0
 network 172.20.100.0
 
 
R3:
 
router rip
 version 2
 network 192.168.2.0
 network 172.16.100.0

Open in new window

0
 
LVL 8

Expert Comment

by:sstone55423
ID: 22657786

R1:
ip route 172.20.100.0 255.255.255.0 192.168.1.2

R2:
ip route 10.10.10.0 255.255.255.0 192.168.1.1
ip route 172.16.100.0 255.255.255.0 192.168.2.1

R3:
ip route 172.20.100.0 255.255.255.0 192.168.2.2
 
Well, I see you don't have static routes from R1 to R3 (ip route 172.16.100.0 255.255.255.0 192.168.1.2) or from R3 to R1 ( ip route 10.10.10.0 255.255.255.0 192.168.2.2) either.  Also, if you were not routing, you would get 0%, not 80%.
You don't want to use RIP, firstly because it does not meet the requirements of your assignment, which is to learn how static routes work, and also because RIP is too noisy with all three routers broadcasting packets with the full route table every 30 seconds.  On a small network setting up RIP instead of setting static routes is just wrong.
0
 
LVL 8

Expert Comment

by:MrJemson
ID: 22657904
The OP said nothing about the assignment specifically requiring static routes. In the real world any network large enough to span 5 subnets and 3 routers is definately a candidate for RIP. In my opinion setting up static routes on such a network is just bad practice as the administrative overhead in making network changer is far too great.
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 22659060
MrJemson,

For the original question:

"I'm preparing for CCNA and working in GNS3 simulator..."

"I'm trying to create a static routing table."

This is not a "real world" scenario. The asker wants to learn how to setup a static routes. Which is a CCNA task.

0
 

Author Comment

by:elly960
ID: 22659065
I tried every single suggestion above (except for the RIP V2, I'll try that at another time, I first want to get static routing going) but none of them got me communication from R1 to R3 and R3 to R1.  I don't know what else to try.  I think I got every way possible in the R1 and R3's routing table.  
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 22659096
Please post the configs from the three routers.
0
 
LVL 8

Expert Comment

by:sstone55423
ID: 22659465
Can you show us your three configs please?
0
 

Author Comment

by:elly960
ID: 22659532
R1:
int g1/0
ip address 192.168.1.1 255.255.255.0
no shutdown
int loopback 0
ip address 10.10.10.1 255.255.255.0
no shutdown

R2:
int g1/0
ip address 192.168.1.2 255.255.255.0
no shutdown
ing g2/0
ip address 192.168.2.2
no shutdown
int loopback 0
ip address 172.20.100.1 255.255.255.0
no shutdown

R3:
int g1/0
ip address 192.168.2.1 255.255.255.0
no shutdown
int loopback 0
ip address 172.16.100.1 255.255.255.0
no shutdown
0
 
LVL 8

Expert Comment

by:sstone55423
ID: 22659539
Where are the static routes and default gateway settings?
0
 

Author Comment

by:elly960
ID: 22659769
R1:
ip route 172.16.100.0 255.255.255.0 192.168.1.2
ip route 172.20.100.0 255.255.255.0 192.168.1.2
 
R2:
ip route 10.10.10.0 255.255.255.0 192.168.1.1
ip route 172.16.100.0 255.255.255.0 192.168.2.1
 
R3:
ip route 10.10.10.0 255.255.255.0 192.168.2.2
ip route 172.20.100.0 255.255.255.0 192.168.2.2
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 22660073
Please post the configs. The actual configs. You may have something in there that is affecting the routing table.
0
 

Author Comment

by:elly960
ID: 22660631
Attaching screen shots of the running-config files.
R1.doc
0
 
LVL 8

Expert Comment

by:sstone55423
ID: 22660681
I can't seem to open that file.  Is it just me?
0
 

Author Comment

by:elly960
ID: 22660736
I was able to open it after I uploaded it.
0
 

Author Comment

by:elly960
ID: 22660806
Here are the config files.
0
 

Author Comment

by:elly960
ID: 22660828
Attached are the NAVRAM files.  Please delete ".txt" and open in Wordpad.
c7200-R1-nvram.txt
c7200-R2-nvram.txt
c7200-R3-nvram.txt
0
 
LVL 8

Accepted Solution

by:
sstone55423 earned 500 total points
ID: 22660837
Okay, I was finally able to open the file.  
What is the output of a "ip route print" ?
On R1 add: ip route 192.168.2.0 255.255.255.0 192.168.1.2
And on R3 add: ip route 192.168.1.0 255.255.255.0 192.168.2.2
0
 
LVL 8

Expert Comment

by:sstone55423
ID: 22661605
Did that work for you?
0
 

Author Closing Comment

by:elly960
ID: 31503693
That did it.  I need to look at it again and make sure that I understand why I did what I did but it worked.  Thank you so much for help!!
0
 
LVL 8

Expert Comment

by:sstone55423
ID: 22662756
Super!  One thing that would have made for less static routing would have been to put default routes in each router also.
Good luck with your CCNA!
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 22663048
Something's screwy. It could be a glitch with the GNS3 software. In your case, you don't need the transient networks in the routing table to reach the loopback networks. You should have been able to reach the loopback networks without them.
0

Featured Post

Limited time offer using promo code EXPERTS30

Designed with a wealth of functionality and convenience, ATEN's new Thunderbolt™ 2 Sharing Switch takes your Thunderbolt setup to the next level. Now through September 15, 2017, Experts Exchange members get 30% off the US7220 on the ATEN USA eShop using promo code EXPERTS30.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

While it is possible to put two routes in place with the secondary having a higher metric, this may not always work. In the event of a failure that does not bring down the physical interface on the router the primary route is not removed. There is a…
The Cisco RV042 router is a popular small network interfacing device that is often used as an internet gateway. Network administrators need to get at the management interface to make settings, change passwords, etc. This access is generally done usi…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question