Solved

tcp_wrapper, Can I specify port number for /etc/hosts.allow

Posted on 2008-10-07
6
1,151 Views
Last Modified: 2013-12-27
I use TCP Wrapper to allow service install on solaris. Syntax for /etc/hosts.allow is daemon and ip to allow but my problem is I don't know what is daemon name. An application is not well know. Can I specify port number in /etc/hosts.allow?
0
Comment
Question by:anuratra
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
6 Comments
 
LVL 40

Assisted Solution

by:omarfarid
omarfarid earned 100 total points
ID: 22657435
please see link below for syntax:

http://www.squarebox.co.uk/cgi-squarebox/manServer/usr/share/man/man5/hosts.allow.5

I could not see any example showing that you can specify the port, but you can control the connecting IP source
0
 
LVL 40

Expert Comment

by:omarfarid
ID: 22657436
please see link below for syntax:

http://www.squarebox.co.uk/cgi-squarebox/manServer/usr/share/man/man5/hosts.allow.5

I could not see any example showing that you can specify the port, but you can control the connecting IP source
0
 

Author Comment

by:anuratra
ID: 22659293
My problem is I don't know daemon name. It is apache. I enter httpd , /PATH/httpd. They don'twork. Moreover another applications is not well known.
0
Enterprise Mobility and BYOD For Dummies

Like “For Dummies” books, you can read this in whatever order you choose and learn about mobility and BYOD; and how to put a competitive mobile infrastructure in place. Developed for SMBs and large enterprises alike, you will find helpful use cases, planning, and implementation.

 
LVL 40

Expert Comment

by:omarfarid
ID: 22660081
I think you can use ALL or unknown in the application field (if I remember correctly, you may check the link).
0
 

Author Comment

by:anuratra
ID: 22667201
If  I use "ALL" the other application won't block. I want to allow some applications.
0
 
LVL 22

Accepted Solution

by:
blu earned 400 total points
ID: 22668307
One key issue here is that not all daemons are compiled to use the TCP_Wrapper feature. The inetd daemon is, and thus can provide the service for all daemons that it starts (at least in nowait mode). You need to make sure that the daemons you want to control here are in fact tcp_wrapper capable.

Depending on you version of Solaris, you might want to use IPFilter instead.
0

Featured Post

SharePoint Admin?

Enable Your Employees To Focus On The Core With Intuitive Onscreen Guidance That is With You At The Moment of Need.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Short answer to this question: there is no effective WiFi manager in iOS devices as seen in Windows WiFi or Macbook OSx WiFi management, but this article will try and provide some amicable solutions to better suite your needs.
This program is used to assist in finding and resolving common problems with wireless connections.
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…
Michael from AdRem Software explains how to view the most utilized and worst performing nodes in your network, by accessing the Top Charts view in NetCrunch network monitor (https://www.adremsoft.com/). Top Charts is a view in which you can set seve…
Suggested Courses

627 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question