Unable to Recreate Public Folders

hello,

I use double take for disaster recovery of our Exchange System, however, somethign went wrong somewhere (informative.. i know) that caused problems with the public folder system.

After trying to fix the issue it became apparent that the problems were causing too much chaos. I tried resetting the system folders (MS KB822444) but that didnt work.
I tried deleting the public folder tree, but the system wouldnt let me.
I tried deleting the public folder store, but the system wouldnt let me.
I removed the public folder store using ADSIEdit and recreated the public folder store + tree, no luck.

Now i'm stuck.

Has anyone got any ideas how i can recreate the public folder store?

Thanks
xyrtAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
Exchange_GeekConnect With a Mentor Commented:
I want to know if the Associated public folder tree is attached with your public folder store.

Please ensure that the steps are followed correctly in KB 926207
0
 
Exchange_GeekCommented:
First of all which version of Exchange are you using,
Secondly, what is the exact error you get when creating Public folders.
Thirdly, if you have deleted the public folder tree + public folder store (this is never the recommended step for troubleshooting by MS EVER) - does the mailbox store got associated with it ? - go to the properties and check if the mailbox store has its own pf store associated.
Lastly, please run Exchange Analyzer tool from MS Link www.exbpa.com - health check.

thanks - keep us posted,
0
 
xyrtAuthor Commented:
Hi,

Exchange RC2 SP2

Yeah, i know it's not the ideal solution but there was no alternative. Unfortunately it didnt turn out as planned. Oops

The mailbox store has the correct public folder store associated with it.
The exchange analyzer doesnt return any errors.

Ive attached a screenshot of the error i get when i click on "public folders" in ESM

Thanks
0
Get 10% Off Your First Squarespace Website

Ready to showcase your work, publish content or promote your business online? With Squarespace’s award-winning templates and 24/7 customer service, getting started is simple. Head to Squarespace.com and use offer code ‘EXPERTS’ to get 10% off your first purchase.

 
xyrtAuthor Commented:
Dont think the screenshot attached... attaching again
error.JPG
0
 
rakeshmiglaniCommented:
you might also want to check if the new tree that you have created is mapi or non-mapi
also check the DN of the tree via adsiedit.msc
does it state public folder or public folders in the DN?
per my understanding, the DN should state the name as public folder and not public folders.
to check whether the pf tree is mapi or non mapi you need to check the attribute called "msExchPFTreeType" in the properties of the pf tree via adsiedit.msc
if the value is 1 then it is mapi and if the value is 0 then it is non-mapi
if it is non-mapi then change it to mapi by changing the value.
let me know how it goes.
0
 
xyrtAuthor Commented:
Hi there

The public store is connected to the new and correct public tree.

I did make the Public Tree Mapi enabled by changing that attribute prior to asking this question.

Thanks
0
 
rakeshmiglaniCommented:
does the DN contain "public folder" or "public folders"? any errors in the app logs when you try to mount the store?
0
 
Exchange_GeekCommented:
What was the pftreetype set to 1 or 0 in adsiedit ?

0
 
xyrtAuthor Commented:
IIRC 1
0
 
Exchange_GeekCommented:
Are the PF stores in mounted / dismounted state
0
 
xyrtAuthor Commented:
mounted
0
 
Exchange_GeekConnect With a Mentor Commented:
If you have IE7 installed on the Exchange box - please uninstall it.
0
 
xyrtAuthor Commented:
OK, IE7 removal fixed the error box popup... however, it didnt fix the problem of the outlook users not being able to access the public folders.

The problem was, the public folder store had not correctly associated with the mailbox store. For some reason even though i had associated it it did not display in the mailbox properties as associated. Recreated the association and it worked.

Thanks Exchange_Geek
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.