?
Solved

Windows update services help needed

Posted on 2008-10-07
10
Medium Priority
?
597 Views
Last Modified: 2012-05-05
Hi I have installed windows update serices and configured group policy in the following way:

comp config > windows update >
config auto updates enables.
specify intranet update service location > http://computername
Enable client side targeting > computergroup1
auto update frequency

in wsus I have added a group called computergroup1,
what else do I need to do because my computer is not showing in wsus
thanks
0
Comment
Question by:Dan560
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
10 Comments
 
LVL 17

Expert Comment

by:Steve
ID: 22657658
Make sure you have configured all the required settings - there is another setting in Group policy, its above the specify intranet update location setting, its to actually specify update settings and if you look at the policy you will see it.

Also ensure that the website you use is not using an ssl certificate or if it is that it is correctly referenced - I recommend using http to get things working then consider https.

If you use HTTPS, the certificate for the site (i think) is a locally generated one and therefore not trusted by the pc's on the network, that means the connection will probably not be established properly.

The computers should appears in the WSUS console now and any other pc's you put in that OU will have the same settings applied.

Let me know if there's anything else you would like to know
0
 
LVL 2

Author Comment

by:Dan560
ID: 22657715
for the intranet update location setting i have just used http://mycomputername this doesnt look correct,
as in IIS it ses the wsus admin site is listening on 8530
0
 
LVL 39

Expert Comment

by:ChiefIT
ID: 22658110
http://servername:8530  (points your clients to go to port 8530)
http://servername  (points your clients to use port 80)
0
 [eBook] Windows Nano Server

Download this FREE eBook and learn all you need to get started with Windows Nano Server, including deployment options, remote management
and troubleshooting tips and tricks

 
LVL 2

Author Comment

by:Dan560
ID: 22658157
when I navigate through the web browser on that address I get
Some content or files on this webpage require a program that you don't have installed.  
0
 
LVL 39

Expert Comment

by:ChiefIT
ID: 22658269
OK Dan:

It looks like you need to change your GPO to http://servername:8530 and then go to the command prompt and type GPupdate /force.

Let me explain WSUS install a little bit.

If the WSUS is installed on a server that already has an existing web page on the default HTTP port of 80, WSUS will make provisions by using an alternative port (port 8530).
In this case, your GPO should look like this:
HTTP://servername:8530

If this server doesn't have another web site on it, WSUS will use the default HTTP Port of 80. In this case your GPO should look like this:
HTTP://servername  Or HTTP://servername:80
0
 
LVL 39

Expert Comment

by:ChiefIT
ID: 22658281
Once the GPO is fixed we can determine if you are missing anything by interfacing the clients with the server. There is a utility called WSUSclientdiag that we can use to diagnose the problems.
0
 
LVL 2

Author Comment

by:Dan560
ID: 22658357
I did that already, hhhmmm maybe I have setup the gpo wrong
I havent edited the Default domain policy
I have just created an OU called accounts and linked a GPO to that OU. This does not sound correct for some reason,do I have to edit a policy that links to the Default Domain?
0
 
LVL 2

Author Comment

by:Dan560
ID: 22660043
more info
ran a test

WSUS Client Diagnostics Tool
Checking Machine State
        Checking for admin rights to run tool . . . . . . . . . PASS
        Automatic Updates Service is running. . . . . . . . . . PASS
        Background Intelligent Transfer Service is running. . . PASS
        Wuaueng.dll version 7.2.6001.784. . . . . . . . . . . . PASS
                This version is WSUS 2.0
Checking AU Settings
        AU Option is 2 : Notify Prior to Download . . . . . . . PASS
                Option is from Control Panel
Checking Proxy Configuration
        Checking for winhttp local machine Proxy settings . . . PASS
                Winhttp local machine access type
                        <Direct Connection>
                Winhttp local machine Proxy. . . . . . . . . .  NONE
                Winhttp local machine ProxyBypass. . . . . . .  NONE
        Checking User IE Proxy settings . . . . . . . . . . . . PASS
                User IE Proxy. . . . . . . . . . . . . . . . .  NONE
                User IE ProxyByPass. . . . . . . . . . . . . .  NONE
                User IE AutoConfig URL Proxy . . . . . . . . .  NONE
                User IE AutoDetect
                AutoDetect not in use
Checking Connection to WSUS/SUS Server
WUStatusServer is not set through Policy
WUServer is not set through Policy
        UseWuServer is disabled . . . . . . . . . . . . . . . . FAIL
Press Enter to Complete
event logs show:

Self-update is not working. ID 13042 CAT=CLIENTS

No client computers have ever contacted the server.

The permissions on directory D:\WSUS are incorrect.
 
I have checked permissions but they look all correct :S
0
 
LVL 2

Author Comment

by:Dan560
ID: 22660051
found another!

Content file download failed. Reason: Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED)) Source File: /msdownload/update/v3-19990518/cabpool/windowsxp-kb842773-v2-x86-enu_1d3d2bc417bf9d881206ed238ad6a4a9c189cfb3.exe Destination File: d:\WSUS\WsusContent\B3\1D3D2BC417BF9D881206ED238AD6A4A9C189CFB3.exe.
0
 
LVL 39

Accepted Solution

by:
ChiefIT earned 2000 total points
ID: 22667051
"'I have just created an OU called accounts and linked a GPO to that OU. This does not sound correct for some reason,do I have to edit a policy that links to the Default Domain?""

This is correct. It is recommended by WSUS to not create a default domain policy for these GPOs. So, creating an OU and linking to the OU is the correct action.

It appears like you may have a permissions problem:
This link will help you verify your settings on the WSUS server. Make sure you follow up with the NTFS permissions, as well:
http://technet.microsoft.com/en-us/library/cc708545.aspx

0

Featured Post

On Demand Webinar - Networking for the Cloud Era

This webinar discusses:
-Common barriers companies experience when moving to the cloud
-How SD-WAN changes the way we look at networks
-Best practices customers should employ moving forward with cloud migration
-What happens behind the scenes of SteelConnect’s one-click button

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This may not be a text book method to resolve VSS backup issues but it seemed to have worked on few of the Windows 2003 servers we had issues while performing a Volume Shadow Copy backup. If you have issues while performing a shadow copy backup usin…
Recently, I had the need to build a standalone system to run a point-of-sale system. I’m running this on a low-voltage Atom processor, so I wanted a light-weight operating system, but still needed Windows. I chose to use Microsoft Windows Server 200…
In this video we outline the Physical Segments view of NetCrunch network monitor. By following this brief how-to video, you will be able to learn how NetCrunch visualizes your network, how granular is the information collected, as well as where to f…
Have you created a query with information for a calendar? ... and then, abra-cadabra, the calendar is done?! I am going to show you how to make that happen. Visualize your data!  ... really see it To use the code to create a calendar from a q…
Suggested Courses

777 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question