Solved

Failing to install Vista SP1 - error 0x80070002

Posted on 2008-10-07
27
8,274 Views
Last Modified: 2012-05-05
Whatever I do, I get this error 0x80070002. I tried downloading SP1 (Windows6.0-KB936330-X86-wave0) on my desktop and that installing  no change.

I tried lots of things suggested on EE as well as on MS Help resources, still no change (deleting C:\Windows\SoftwareDistribution& regsvr32 /i Urlmon.dll& creating a new user account&installing directly from MS Update&)  still no change; after installing 8%, the error message appears.

Any suggestions how to install Vista SP1 without any errors?

SP1-error.jpg
80070002.jpg
7-.jpg
0
Comment
Question by:neshas
  • 14
  • 7
  • 5
  • +1
27 Comments
 
LVL 16

Expert Comment

by:cantoris
ID: 22658534
A couple of simple things to try from a command prompt:
Good old    chkdsk c: /F/V
Also   SFC /SCANNOW
Then reboot and try the install again.
0
 
LVL 3

Expert Comment

by:savic7uk
ID: 22658743
Hi
This problem occurs when some files are missing from the downloaded file.
Try this.

 1.Stop the Automatic Update. click  (Start) then (Run), type services.msc  and then click OK.
   -Right click on Automatic Updates and then click on (Stop).
   - Minimize the window (Services).
 
2. Rename  SoftwareDistribution.
To do that = Click on  (Start), then (Run), and then type cmd . Click  OK.
   -Type :  cd %windir%  and then press enter ENTER.
   - Type:  ren SoftwareDistribution SDTemp and then press ENTER
     - Type: exit  and then press ENTER.  

 3. Start Automatic Updates.
    - Maximize the  (Services) window.
     - Right click  on Automatic Updates  and then click on (Start).
     - Close (Services) window.
 
4. Go to the Windows Update website (Microsoft Update) and download and install the latest update.

Hope that does the trick.

0
 

Author Comment

by:neshas
ID: 22659605
savic7uk,  I've already tried that...didn't do the trick :(
Will try what cantoris suggested and see what happens.
0
 

Author Comment

by:neshas
ID: 22663521
cantoris,
chkdsk won't work as you've written (with /F/V), just simple chkdsk...and no errors were detected. I tried it in Safe mode as well, no way I could do it with /F/V).

SFC /SCANNOW came up with: "Verification 100% complete.
Windows Resource Protection found corrupt files but was unable to fix some of them.", and a large log file (8,5MB).
File is too large (for me) to spot significant errors...

Later I tried SP1 again, with no luck...still the same error message 0x80070002 (after 7-8% done).
0
 
LVL 16

Expert Comment

by:cantoris
ID: 22663712
This sounds a bit disconcerting.
Chkdsk should work though with /F /V.    What error does it give?  If it won't run properly, you could try booting the Vista CD to the Command Prompt option on its recovery tools menu.  Then run chkdsk from in there.  I'm wondering if you have a poorly drive.
I've also found a number of articles referring to problems with SFC pre-SP1 but no clear solution.
0
 

Author Comment

by:neshas
ID: 22665683
The message I get (when 'run as administrator') with /F/V:

The type of the file system is NTFS.
Cannot lock current drive.

Chkdsk cannot run because the volume is in use by another
process.  Would you like to schedule this volume to be
checked the next time the system restarts? (Y/N)

.....

When booting from my Vista CD, there in no options on recovery tools menu...just clean install.
0
 
LVL 16

Expert Comment

by:cantoris
ID: 22666859
When chkdsk asks you that question, type Y and then reboot at your convenience.  It will scan the disk when it boots up and you'll be able to see its progress.
0
 

Author Comment

by:neshas
ID: 22669475
chkdsk /F/V found no errors.
sfc/scannow made a huge log file and displayed this message:

Verification 100% complete.
Windows Resource Protection found corrupt files but was unable to fix some of them.

After that, I started updating SP1, but, nothing changed...after few minutes, cca 7-8% done, it stopped with the same, annoying message... 0x80070002.
:(
0
 
LVL 16

Accepted Solution

by:
cantoris earned 125 total points
ID: 22673205
Weird one this, but looking online it seems you're far from alone.  You've not used vLite or patched any system files have you?
If you use Windows Update, are there are pre-requisite updates offered to you that you have not yet installed?  ie Is there anything it wants you to install as well as SP1 that perhaps needs to go on first?
It looks as though a common solution to this problem is to reinstall Vista...

You might want to look here:
http://support.microsoft.com/oas/default.aspx?Gprid=12534
Looks as though you should get free help from MS.
0
 

Author Comment

by:neshas
ID: 22676649
No, I didn't patch any system files, I'm not in that 'business' :)
My system is updating regularly from MS on daily basis, and I have all the latest updates installed. Except for this one.

Let me point out that when SP1 came out, I immediately downloaded it and installed it without any problems.
Due to some problems with other software at that point, I thought that SP1 is causing some irregularities, so I uninstalled it (used restore point).

Time elapsed, and I just noticed that my machine is constantly trying to update from MS and I'm not letting it (I'm on dial up, so I close the connection far more before it downloads).

So I decided not to close the connection and to let it download...and the rest is here.

As for the help from MS that you suggest, thnx but...in my country I'm working with those people from MS, some of them were in my firm before they've stepped to MS :)
And believe me, they consult me on many problems with MS OS, MS apps... :))

So, that's why I'm here, on EE, but not on MS Support. Hoping to solve the problem easy way.
Not to reinstall Vista or something like that.
0
 

Author Comment

by:neshas
ID: 22701088
I downloaded the System Update Readiness Tool for Vista 32-bit.
After running it, I restarted the computer to check the results

Nothing happened so I started SP1 (stand alone package -Windows6.0-KB936330-X86-wave0)
After I while (unfortunately, I went to the other room so I'm not sure did my PC restarted, or was there some message on the screen), my screen was completely black with one line on top of it:
 !! 0xC01a001d !! 28429/82589 (\Registry\Machine\COMPONENTS\DerivedData...).

It looked as my machine was 'stuck'. keyboard was 'dead', the mentioned line was like blinking, the hdd led on my case was blinking but hdd was silent.

 After a while (10 min?), I had to do hard reset. Machine started but immediately it started to do some kind of checking, and it came back with the above-mentioned line and 'stuck' again.
Now, I turned off the machine, waited for some 10 sec, and started it again. Came up with the same 'stuck' line.
 
I tried the last Known Good Configuration (advanced), but nothing changed...the same 'stuck' line.
Then I tried the Safe mode, and it got 'stuck' again with this (last) line:
\Windows\System32\Drivers\crcdisk.sys
 
After that I turned off my machine and didn't turn it on again.
0
 
LVL 69

Assisted Solution

by:Merete
Merete earned 125 total points
ID: 22701165
neshas,
Referring to our previous communications on the problems you have,
ID:22677794Author:neshas
http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Windows/Windows_Vista/Q_23793295.html?cid=238#a22701093,
highlighting these areas
Before installing SP1, all users running Windows Vista RTM (that is, if you bought your computer with Vista preinstalled) will need to install three updates from Microsoft.
(2)
you installed vista sp1 previously and had no problems but rather was not happy with some of the new features so you uninstalled it.
That's when your problems started.
I think we covered most of it and a repair re-install is in order to put the original Vista in order.
I provided those detailed step by step in the other question.
It does seem like your original Vista has some integral problems.

Would still like to see some of your events errors, not the SFC logs please.
regards Merete
0
 

Author Comment

by:neshas
ID: 22701417
Before I provide some event errors, first I have to resolve the problem I have from yesterday, and that is:
!! 0xC01a001d !! 28429/82589 (\Registry\Machine\COMPONENTS\DerivedData...)

I cannot login at all. My screen is completely black with the above-line.
Can start Windows.

BTW, I bought my PC without any OS, that I installed XPPro.
Some year or two, I took Vista CD and installed Vista Ultimate over XPPro.
0
Find Ransomware Secrets With All-Source Analysis

Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

 
LVL 69

Expert Comment

by:Merete
ID: 22702247
This error 0xC01a001d is happening to a lot of folks after installing sp1,
I think the version you're installing has a time limited (expires june 2008)
why not consider waiting for the final version like many others.
Stick with the current version but fix it first.

There is a read me for Vista Sp1 and I highly recomend you check them out to make sure you have covered the drivers needed to upgrade to SP1
http://support.microsoft.com/kb/936330
http://www.hardforum.com/showthread.php?t=1287332


An inplace upgrade/ repair reinstall should fix the problems with your current system and put it right.
Google and you'll find the same problem listed many times and the solution is to run an inplace upgrade.
read these good insights as it confirms my thoughts.
Error during SP1 installation
http://forums.software.com/softhelp/vista/Error-SP1-installation-ftopict149384.html

Regards Merete

0
 

Author Comment

by:neshas
ID: 22702451
Truly appreciate your effort to help me Merete.
I've looked through the links you've posted, but couldn't find any solutions how to start my machine when this problem occurs.

Hence, my very first problem is how to start my machine.
And its obviously not a hardware problem, but a software one.

I never get a logon screen. It's just black with the error message.
Keyboard and mouse are useless.
I tried in Safe mode, but it got 'stuck'.
Restart...shut down...nothing helped.
Perpetuum Mobile.

In order to apply any of the suggestions, I first have to find a way how to start my machine.

Since I have lots of important stuff on this machine, some work is done on it, I had to ask MS support too, and still waiting for their response as well.
0
 
LVL 69

Expert Comment

by:Merete
ID: 22707422
Hello neshas, just to cover bases did you regester your Vista after installing it?
If for some reason MS decides your system is not regestered correctly it will nolonger have boot after a certain time period.
the work around on that is to also run a repair re-install using the upgrade option.
On the noboot,
Like xp when you have a problem with noboot there is several avenues if you don't have any " hard disc issues " or  " space issues " on the hard disc,
(1) slave the hard drive to another system run a chkdsk and save off your files email etc.
Create a new partition to install Vista back into.

(2)
Press Del to enter bios and set the bios to defaults.

(3) set the bios to boot from rom first boot, put it back to HDO later,
you'll need your Vista setup disc then press any key to run setup
wait,
when it gets to which windows highlight C drive then select repair or upgrade.

Same problem here points to either a corrupted regestry or bad sectors on a hard drive.
Black Screen with error 0xc00000e9 after reboot
http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=3130048&SiteID=17

It would seem your only work around is re-install or use the upgrade path option as it's known.
Since all other suggestions have failed I can't see you have too many choices left.
Here is that guide again please scroll down to the appropiate guide for your system.
http://www.windowsreinstall.com/winvista/
0
 

Author Comment

by:neshas
ID: 22719174
 This is becoming a nightmare for me. As more I try to find a solution, it seems as if I am further from it.  
Last night I booted from my Vista cd. Started repair and the results are horrifying (see 2 photos).  

Windows-cannot-repair.jpg
Windows-cannot-startup-repair.jpg
0
 
LVL 69

Expert Comment

by:Merete
ID: 22727164
How much ram do you have on there? More than 3 gig?
http://tomstricks.blogspot.com/2008/06/error-fix-when-you-try-to-install.html

Error 0x0000000a is caused by missing system files or broken system registry structures.
This is a critical sign of an unstable system.
If the above doesnt help.

When performing a repair remove all components non essential.
If you have Norton it maybe preventing you from accessing the files needed.
Windows Vista - Blue Screen Errors (STOP Errors)
http://support.gateway.com/s/Checklists/BPC/ck20070928123.shtml#step6

once you have no boot!! no safemode!!
If a chkdsk does not help
Your options in my humble opinion are very limited.
Please consider buying another hard drive and clean install if the files on this hard drive are very important.
How much space do you have on there?
Create a small partition in the unallocated space and install Vista to that.

Slave this hard drive to another computer or behind the new hard drive.
In slave it nolonger uses windows or a regestry.
0
 

Author Comment

by:neshas
ID: 22728968
I have 1GB RAM.

My HDD is 250GB which is more than enough. It has 2 partitions; one with OS and software and other with DATA. All DATA is backed up on daily basis on external USB 250GB HDD.
So, I'm not warried on my data, but that I'll have to install all over again lots of software, and do lots of settings for 3 users.
Before my copmuter got stuck with "0xC01a001d", I did checked my HDD and memory, and everything was/is just fine.

I'm quite sure that you are right when you say than my computer has "missing system files or broken system registry structures. This is a critical sign of an unstable system".
I confident that I have no hardware problems.


I've looked links you've provided in your previous post, but they cannot help me.

Let me sumarise my problem at the moment:
Whatever way I try to stat up my computer, it immediately starts doing some kind of checking. The screen is black and only one line at the top, with figures changing contsantly, until it reaches "0xC01a001d".

From that point the computer is stucked and I can go all over again (restart) or shut it down.

When I tried to boot from Vista cd, and did system repair, I got the message that it cannot be done (see my previous post with screen shots).

Last night I tried to do System restore with Vista cd (the only way it can be done at the moment), but unfortunately, that couldn't be done as well.


Restore-failed.jpg
0
 
LVL 69

Expert Comment

by:Merete
ID: 22729334
Hi neshas, did you unplug the usb drive?
It  sounds like the boot.ini was changed that'd be tough as Vista nolonger boots as xp,
this wont help you now but you may find it interesting.
http://www.microsoft.com/whdc/driver/tips/Debug_Vista.mspx
If the system is running some kind of check it maybe the boot loader is bad.
And you cannot access safemode either.
Just an idea some keyboards prevent access to safemode because the F8 key is taken,
is that possible?
Try a generic keyboard.
Once the regestry is corrupted you do realize there is really no alternative but clean install.
No sense in beating yourself up over it what's done is done.
However since you have backed up well done.
The sooner you get the system backup the sooner you'll have it all running nice and sweet.
That's all I can offer you neshas
All the best
Merete
0
 

Author Comment

by:neshas
ID: 22731546
Yes, I unplugged teh USB drive ...I carry it with me...

F8 is working fine, I have all the options of booting.
Maybe I should choose the one with Command Prompt, and than try something like "BCDEdit" (from the link you've posted me in your previous post)?

Will try and spend a little bit more time to resolve this problem of mine, before clean install.
You have to understand me, lots of software has to be installed all over again, lots of updates, lots of (user) settings...

Probably will do clean install, its good to do that with Windows from time to time...But I do have some obligations to other people just as with you and other EE, have to give them a chance to resolve this. If not, than clean install...and you get the points :)

In the meantime, I'm thinking to wave goodbye Microsoft for good...Mac Book Air looks just fine...really fine...
0
 
LVL 69

Expert Comment

by:Merete
ID: 22736125
:) agree with the Mac idea.
Many rolled back to xp as Vista was not for everyone and too much down time.
0
 

Author Comment

by:neshas
ID: 22749947
Well, I had to do it. Reinstall Vista all over again. It looks as some files or registry settings or both were somehow corrupted and there was no other way to make Vista work again. So, I finally gave up and did the inevitable. After all, maybe this is for the best, to refresh my computer, before buying Mac :)
Now, my horror started all over...installing other software as well, configuring settings...
I would like to be fair on this one and give most points to Merete as she helped me most, but Cantoris was actually the first to suggest reinstalling Vista.
Any suggestions please, before I give well deserved points, grades and finally close this question?
0
 
LVL 69

Expert Comment

by:Merete
ID: 22750458
Hello neshas, as your question really ran over two zones, the first correct response in this question is the one you should accept. I'm happy with a split points but cannot speak for others.
Accept Cantoris and split with others.
Click on the link accept multiple answers or something like that.
Always a pleasure to help!!
Thank you
Regards Merete

0
 

Author Comment

by:neshas
ID: 22751646
OK, Merete, looks like fair to me, hope Cantoris is agreed with that.
0
 

Author Closing Comment

by:neshas
ID: 31503778
Thank you both, Cantoris and Merete.
Unfortunately for me this IS the solution...hard days of installing and configuring are ahead of me...

Buy Mac!
0
 
LVL 16

Expert Comment

by:cantoris
ID: 22751724
Hi!
Absolutely - thank you for the points.  I hadn't been expecting any given all the hard work Merete had put in.  Sorry it did indeed come to a reinstall but if I had been in your position, even if I had managed to get it running I would not have trusted its stability after such a spectacular death and would have probably felt obliged to reinstall it.  I know how much work that can take to get it back to how you had it configured before.  Good luck.
Best wishes!
0

Featured Post

How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

Join & Write a Comment

Hi All Just a quick one for everybody. I was recently looking into setting the default User Account Picture for all my vista clients within the network but on closer inspection the group policy setting only allows you to set the default pictur…
There are many reasons a PC runs slower than when it was new, ranging from malicious software intended to mess things up to simple general Windows use.  Your PC performance may slowly degrade over time without you noticing but when you buy a PC from…
The Task Scheduler is a powerful tool that is built into Windows. It allows you to schedule tasks (actions) on a recurring basis, such as hourly, daily, weekly, monthly, at log on, at startup, on idle, etc. This video Micro Tutorial is a brief intro…
Illustrator's Shape Builder tool will let you combine shapes visually and interactively. This video shows the Mac version, but the tool works the same way in Windows. To follow along with this video, you can draw your own shapes or download the file…

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now