Solved

Exchange 5.5 OWA (only admins can log in)

Posted on 2008-10-07
9
164 Views
Last Modified: 2010-04-07
I have a Exchange 5.5 server running on Windows 2000 in a NT 4.0 Domain

My users can no longer log into OWA, only administrator accounts, they get a blank message prompt after the login prompt, the error message says nothing, then you click ok and the error says "The Exchange Servers is unavailable"

again if I log in as a member of the administrators group I can access OWA no problem

as far as I know there have not been any changes?
0
Comment
Question by:tkthelpdesk
  • 5
  • 4
9 Comments
 
LVL 31

Expert Comment

by:LeeDerbyshire
ID: 22659668
In IIS5 (i.e. on W2K server), Basic Auth (OWA 5.5 uses Basic Auth) requires that users have the Log On Locally right on the IIS server.  Do they still have that right?
0
 

Author Comment

by:tkthelpdesk
ID: 22659958
OWA is hosted on IIS 5.0 is running on a seperate server than exchange (forgot to mention)

I have tried adding "everyone" to the Log on Locally setting.

I can't add the users because its NT and won't show up in the list of accounts so I added "everyone"

If possible to add the users in a NT domain on this server (how could I?)

also should these rights be added to both Exchange and the server hosting the OWA?

0
 
LVL 31

Expert Comment

by:LeeDerbyshire
ID: 22660001
It's only the IIS server that is affected by this.  Adding Everyone is usually sufficent.  The best way to make sure is to sit at the console of the IIS server, and try to log in as one of the affected users.  If the login prompt keeps appearing, they won't be able to use OWA.
0
Best Practices: Disaster Recovery Testing

Besides backup, any IT division should have a disaster recovery plan. You will find a few tips below relating to the development of such a plan and to what issues one should pay special attention in the course of backup planning.

 

Author Comment

by:tkthelpdesk
ID: 22660194
I am able to log into the server running IIS hosting OWA

when I try and access the OWA site with the same account I get

first the landing page that wants you to type your profile

then the logon prompt (I enter a non admin user and password)

then I get a blank error message with no information (I click OK)

then I get "Failed to connect to the Exchange Server"
0
 
LVL 31

Expert Comment

by:LeeDerbyshire
ID: 22660228
The best place to look first (and it's often overlooked) is the built-in owa troubleshooting text.  Try going to http://servername/exchange/tshoot.asp
0
 

Author Comment

by:tkthelpdesk
ID: 22660307
Failed to Connect to the Microsoft Exchange Server <servername>
This is another error message you may receive when you attempt to log on to a mailbox through the Outlook Web Access client. Use the following checklist to troubleshoot this error:
 Should these permission checks etc be done on the EXCHANGE server or the web server hosting OWA?
0
 
LVL 31

Accepted Solution

by:
LeeDerbyshire earned 500 total points
ID: 22660381
The entire section refers to permissions on the IIS server.
0
 

Author Comment

by:tkthelpdesk
ID: 22661398
ok I did the first part and made sure "domain users" have the right permissions on Exchsrvr\Webdata and Exchsrvr\Webtemp as it said

now I have some users who can access it and others that cannot

the users that can connect are in the domain users group, the users that cannot connect are in the domain users groups as well

should I just give "everyone" group the same access to these folders?

the error that some users get is different

the go to the landing page and enter there alias
the get the login prompt and enter there username and password
then they get a "receive 500 Internal Server Error" (which is different)

So I am halfway there it seems? I only did the permission changes on the webdata and webtemp folders, I did not do anything else since that seemed to get it working partially
0
 
LVL 31

Expert Comment

by:LeeDerbyshire
ID: 22668165
Is there anything else displayed, other than '500 - internal server error'?  That is a general status code which means that 'something went wrong with the application at the server end'.  There should be a more specific error code and description.  If not, make sure that your IE does not have 'Friendly HTTP Errors' enabled in the options.
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Marketers need statistics and metrics like everybody else needs oxygen. In this article we explain how to enable marketing campaign statistics for Microsoft Exchange mail.
Find out what you should include to make the best professional email signature for your organization.
In this video we show how to create a User Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Mailb…
In this video we show how to create an Address List in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Organization >> Ad…

813 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now