Solved

VS 2008 MSI Error - Getting "1:", YES/NO - What does it even mean?

Posted on 2008-10-07
3
268 Views
Last Modified: 2013-11-26
I have an application written almost entirely in VB.Net, which runs as a Windows Service.  However, for the limited task of UnZipping .zip files, I had a method which used some J# code. This application has a setup probject, and everything worked great with VS 2005.  

However, as soon as I upgraded to VS 2008 and .Net 3.5, while the setup project still creates a setup.exe and an .msi file, both of them now fail when I attempt an install.  The install begins, but I then get a singularly unhelpful pop-up. This pop-up contains only this: "1:", followed by two buttons, one letting me click Yes, and one letting me click No. That's all I get nothing else.  If I click No, the installation process halts and that is that.  If I click Yes, an instance of my web browser is invoked, and I am brought to this Web page:
http://msdn.microsoft.com/en-us/vjsharp/default.aspx

Thinking that J# must be the source of my problems, I re-wrote the method in question with VB.Net code (using the downloaded ICSharpCode.SharpZipLib.dll), removed all references to J# from all projects and solutions, removed the J# redistributable from my machine entirely, restarted my computer, and STILL I GET THIS SAME PROBLEM!!.

I have no idea what is causing this, and it is preventing me from creating an .msi to support deployment to a production system.

Can anyone please tell me what is going on here, and what I need to do to fix the problem?  

Thank you very much in advance.
0
Comment
Question by:skylar1
  • 2
3 Comments
 
LVL 40

Expert Comment

by:Vadim Rapp
ID: 22694838
please produce detailed log file of the installation (http://support.microsoft.com/kb/223300) and post here.
0
 
LVL 40

Expert Comment

by:Vadim Rapp
ID: 22694861
Most likely, the installation has J# specified as prerequisite, and the question was supposed to be if the user wants to download it from ms site. Right-click setup project, open properties, click prerequisites, and uncheck J#.
0
 

Accepted Solution

by:
skylar1 earned 0 total points
ID: 22703874
I do not have the detailed log file of the installation.

J# is NOT checked as a prerequisite in the Properties UI.

I have given up on this and just recreated a completely new setup project.

Thank you for your attempts, but I would like to withdraw this question at this time.
0

Featured Post

Master Your Team's Linux and Cloud Stack!

The average business loses $13.5M per year to ineffective training (per 1,000 employees). Keep ahead of the competition and combine in-person quality with online cost and flexibility by training with Linux Academy.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

This document covers how to connect to SQL Server and browse its contents.  It is meant for those new to Visual Studio and/or working with Microsoft SQL Server.  It is not a guide to building SQL Server database connections in your code.  This is mo…
For those of you who don't follow the news, or just happen to live under rocks, Microsoft Research released a beta SDK (http://www.microsoft.com/en-us/download/details.aspx?id=27876) for the Xbox 360 Kinect. If you don't know what a Kinect is (http:…
The viewer will learn how to use and create keystrokes in Netbeans IDE 8.0 for Windows.
The viewer will learn how to synchronize PHP projects with a remote server in NetBeans IDE 8.0 for Windows.

860 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question