Solved

"You do not have permission" on Public Folder ONLY in Outlook 2007 / Exchange 2003 - OL2003 works

Posted on 2008-10-07
8
722 Views
Last Modified: 2012-05-05
Hello,

We have one user (a domain admin) who has Outlook 2007 in an Exchange 2003 environment. He is unable to post a new message to a public folder (where he is listed as 'Owner') and gets the error that he does not have permission to do so. However, using a different computer and Outlook 2003, he is able to post a new message to the public folder with no problems. Also, using OWA, that works too. We also tested with a different Outlook profile, logging on as another user who also has 'Owner' permissions and that also fails. He does have SP1 installed but it is looking like an Outlook 2007 problem. Can anyone help please? Thanks!
0
Comment
Question by:ddns
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
8 Comments
 
LVL 19

Expert Comment

by:MrLonandB
ID: 22659877
Try resetting the User's Account Password. Stop and Restart Outlook.
0
 
LVL 11

Expert Comment

by:DavidT543
ID: 22662134
Are you using cached mode?
Try switching off cached mode and try again.
 
0
 
LVL 11

Expert Comment

by:DavidT543
ID: 22662159
Also look at what the default form type is for the folder. It could be that the default form has some code behind it and is breaking teh security permissions - or is of the wrong form type.
What type of folder is it?
What is the default message class in the folder?
Does it use a custom form?
0
NEW Veeam Agent for Microsoft Windows

Backup and recover physical and cloud-based servers and workstations, as well as endpoint devices that belong to remote users. Avoid downtime and data loss quickly and easily for Windows-based physical or public cloud-based workloads!

 

Author Comment

by:ddns
ID: 22662166
I actually tried turning off cached mode, and it had no effect. Thanks, though.
0
 

Author Comment

by:ddns
ID: 22662183
I checked the default form type and it's Post (IPM.Post) and there is not a custom form for the folder.
0
 
LVL 11

Expert Comment

by:DavidT543
ID: 22663215
Check the permissions tab on the folder (rightclick on folder in Outlook 2007 and select permissions tab). In OL2007 its possible to be owner but not have rights to create a new item. In OL2003 this is not possible.
0
 

Author Comment

by:ddns
ID: 22663875
In Outlook 2007, when you open the properties of the problem public folder, the Permissions tab is not shown. We have confirmed the appropriate permissions are set by using Exchange System Manager, and also the PFDAVAdmin utility. The user is set to 'Owner' and we have also removed and re-added him. The DACL status in the PFDAVAdmin tool shows 'Good', and, again, it works as expected in Outlook 2003 and OWA.
0
 
LVL 11

Accepted Solution

by:
DavidT543 earned 500 total points
ID: 22666570
The fact that the permissions tab is not shown in OL2007 is a good indication that this is a folder permissions issue - so we are homing in on possible areas to look at. It may be easier to recreate a working folder than find the original fault.

It sounds like you are setting the permissions for the folders from Exchange System Manager / PFDAVAdmin and not through Outlook.

One work around would be to get the problem user to create a new Public Folder through Outlook (which should definitely give them the full owner permissions).You may need to give them 'create new subfolder' permissions on the parent folder.

 Check they can add/delete etc to this folder, then use this as the required Public Folder. You will need to set up permissions for other users. Then swap the names of the two folders and drag the contents of the old folder into the new folder. Make sure when you drag the contents that it copies and not moves them. (A copy will show a + sign next to the cursor as you drag. If it doesn't show, try holding down the shift key when you drag - it should toggle move/copy)

Finally  remove the permissions for anyone to see the older folder via Exchange System Manager.
0

Featured Post

NFR key for Veeam Agent for Linux

Veeam is happy to provide a free NFR license for one year.  It allows for the non‑production use and valid for five workstations and two servers. Veeam Agent for Linux is a simple backup tool for your Linux installations, both on‑premises and in the public cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

You need to know the location of the Office templates folder, so that when you create new templates, they are saved to that location, and thus are available for selection when creating new documents.  The steps to find the Templates folder path are …
This article will help to fix the below error for MS Exchange server 2010 I. Out Of office not working II. Certificate error "name on the security certificate is invalid or does not match the name of the site" III. Make Internal URLs and External…
This video discusses moving either the default database or any database to a new volume.
This video shows how to quickly and easily add an email signature for all users on Exchange 2016. The resulting signature is applied on a server level by Exchange Online. The email signature template has been downloaded from: www.mail-signatures…
Suggested Courses

636 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question