Solved

cisco, 501 c pix

Posted on 2008-10-07
14
307 Views
Last Modified: 2011-10-19
We have a Cisco Pix 501 C using 6.2 - We have purchased a new phone system that requires the we open ports 5000 through 6200 UDP for voice packets.  I need to know the command lines to facilitate that. I have attached a sample configuration that exists.  Thanks in advance!
intrac-pix-config-sample.txt
0
Comment
Question by:mikeplastic
  • 7
  • 6
14 Comments
 
LVL 12

Expert Comment

by:Pugglewuggle
ID: 22661309
Open those ports to allow traffic from the outside to inside or vice versa? What phone system is it? That's a LOT of ports!
0
 

Author Comment

by:mikeplastic
ID: 22661449
It is an Intertel System and below is the request:
The following ports will need opened in the firewall for the IP phone to function.

UDP Port 5000-6200 Incoming and Outgoing

TCP Port 5566 Incoming and Outgoing

0
 
LVL 57

Expert Comment

by:Pete Long
ID: 22661730
>>UDP Port 5000-6200 Incoming and Outgoing

Are you sure? outgoing I can understand but Incoming? whats the phone system? who has told you these ports need to be open inbound ?
0
 
LVL 12

Expert Comment

by:Pugglewuggle
ID: 22663815
And especially the huge number of ports... why so many? Is it ONLY 5000 and 6200, or is it 5000 THROUGH 6200?
Cheers!
0
 

Author Comment

by:mikeplastic
ID: 22665360
I believe that it is so many beacuse the voice packets need to transmit through this range.
0
 
LVL 12

Expert Comment

by:Pugglewuggle
ID: 22665417
Very interesting. So it is the entire range and not just those two? As far as getting that setup, can you please post your current config so I can come up with something for you?
Cheers!
0
 

Author Comment

by:mikeplastic
ID: 22668277
This is the jist of the current configuration.
intrac-pix-config-sample.txt
0
Do You Know the 4 Main Threat Actor Types?

Do you know the main threat actor types? Most attackers fall into one of four categories, each with their own favored tactics, techniques, and procedures.

 

Author Comment

by:mikeplastic
ID: 22668834
hostname cisco-pix
domain-name abby.com
fixup protocol ftp 21
fixup protocol http 80
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol sip 5060
fixup protocol skinny 2000
names
name 10.0.0.102 server1
name 10.0.0.103 server2
access-list 101 permit ip 10.0.0.0 255.255.255.0 10.0.50.0 255.255.255.0
access-list 101 permit ip host 10.0.0.13 10.0.50.0 255.255.255.0
access-list 101 permit ip host 10.0.0.11 10.0.50.0 255.255.255.0
access-list 101 permit ip host 10.0.0.115 10.0.50.0 255.255.255.0
access-list acl-out permit icmp any any
access-list acl-out permit tcp any host nn.nnn.nn.nnn eq 5566
access-list acl-out permit tcp any host nn.nnn.nn.nnn eq 3389
access-list acl-out permit udp any host nn.nnn.nn.nnn eq 3389
access-list acl-out permit udp any host nn.nnn.nn.nnn eq 5000
access-list acl-out permit udp any host nn.nnn.nn.nnn eq 6200
pager lines 24
logging on
logging buffered errors
logging trap debugging
logging host inside 10.0.0.100
interface ethernet0 10baset
interface ethernet1 10full
mtu outside 1500
mtu inside 1500
ip address outside nn.nnn.nn.nnn 255.255.255.0
ip address inside 10.0.0.199 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool ippool 10.0.50.1-10.0.50.254
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 101
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp interface 3389 abbatrondc1 3389 netmask 255.255.255.
255 0 0
static (inside,outside) udp interface 3389 abbatrondc1 3389 netmask 255.255.255.
255 0 0
static (inside,outside) udp interface 5000 10.0.0.68 6200 netmask 255.255.255.25
5 0 0
static (inside,outside) tcp interface 5566 10.0.0.68 5566 netmask 255.255.255.25
5 0 0
access-group acl-out in interface outside
route outside 0.0.0.0 0.0.0.0 24.154.55.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h323 0:05:00 si
p 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
no sysopt route dnat
crypto ipsec transform-set myset esp-des esp-md5-hmac
crypto dynamic-map dynmap 10 set transform-set myset
crypto map mymap 10 ipsec-isakmp dynamic dynmap
crypto map mymap interface outside
isakmp enable outside
isakmp identity address
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption des
isakmp policy 10 hash md5
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
vpngroup vpn3000 address-pool ippool
vpngroup vpn3000 split-tunnel 101
vpngroup vpn3000 idle-time 1800
vpngroup vpn3000 password ********
telnet 10.0.0.0 255.0.0.0 inside
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh nnn.nnn.nnn.nnn.nnn 255.255.255.255 outside
ssh timeout 60
terminal width 80


0
 
LVL 12

Expert Comment

by:Pugglewuggle
ID: 22671458
If you want to open the entire range, the command to use is:
access-list acl-out extended permit udp any host nn.nnn.nn.nnn range 5000 6200
Cheers! Let me know if that works!
0
 

Author Comment

by:mikeplastic
ID: 22672010
Thanks for the try:
I get the erros message:
ERROR: <extended> not a valid permission.
 usage: <no> access-list compiled.
0
 
LVL 12

Expert Comment

by:Pugglewuggle
ID: 22672078
oh woops - use that instead.
access-list acl-out permit udp any host nn.nnn.nn.nnn range 5000 6200  
Cheers!
0
 

Author Comment

by:mikeplastic
ID: 22672305
This command was accepted in the configuration.  I now have to get the VoIP phone to work.  Thank you for your help.  I will complete my testing prior to completing.
0
 
LVL 12

Accepted Solution

by:
Pugglewuggle earned 250 total points
ID: 22672320
No problem! Let me know!
0
 

Author Closing Comment

by:mikeplastic
ID: 31503891
Very good.  Dis what i asked!
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

Quality of Service (QoS) options are nearly endless when it comes to networks today. This article is merely one example of how it can be handled in a hub-n-spoke design using a 3-tier configuration.
If your business is like most, chances are you still need to maintain a fax infrastructure for your staff. It’s hard to believe that a communication technology that was thriving in the mid-80s could still be an essential part of your team’s modern I…
It is a freely distributed piece of software for such tasks as photo retouching, image composition and image authoring. It works on many operating systems, in many languages.
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now