2 IP addresses, choose what one to be returned in dns queries.

Afternoon,

Our exchange server has two IP addresses.
One for lan, the other for WAN/PPP Interface.

When pinging the server name the WAN/PPP ip is returned, and thus the server is unaccessible.
If I flush the DNS and re-register it on the client experiencing this it will revert back to the LAN address..

But after a while it goes back to the WAN/PPP interface again.

How can I resolve this? What is the best solution, and why is this happening?
Antonio KingIT ManagerAsked:
Who is Participating?
 
Chris DentConnect With a Mentor PowerShell DeveloperCommented:

Well the second option is to change the Interfaces the server listens on, that would prevent even the server itself from registering the incorrect entry.

These are the instructions:

1. Open the DNS Console
2. Open the Properties for the DNS Server
3. Select Interfaces
4. Change the option to "Only the following addresses:"
5. Enter the IP address of the internal interface only

Then simply delete the erroneous entry from the forward lookup zone and check it doesn't reappear.

Chris
0
 
omarfaridCommented:
I am not sure if windows dns has a mechanism for preferred ip based on source ip address. On the other hand BIND can do that
0
 
Chris DentPowerShell DeveloperCommented:

Hi,

This happens because DNS uses Round Robin to respond to requests where multiple addresses exist for a single resource.

Do you really need two addresses? I recommend you set the WAN/PPP interface not to register entries in DNS to avoid conflicts.

Chris
0
Worried about phishing attacks?

90% of attacks start with a phish. It’s critical that IT admins and MSSPs have the right security in place to protect their end users from these phishing attacks. Check out our latest feature brief for tips and tricks to keep your employees off a hackers line!

 
Chris DentPowerShell DeveloperCommented:

> I am not sure if windows dns has a mechanism for preferred ip based on source ip address

It does, NetMask Ordering. It's pretty basic though, it will try and order round robin responses so an answer on the local subnet is returned first.

Reliance on it should be avoided though really. It would be better (from my point of view) to investigate why the WAN/PPP address is registering.

Chris
0
 
Darius GhassemCommented:
As Chris states go into your Network Connections righ-click the WAN NIC then go to properties highlight the Internet Protocol then click properties. Once in the properties click Advance then go to the DNS tab uncheck register with DNS.
0
 
omarfaridCommented:
Hi Chris-Dent,

I am not aware of this "NetMask Ordering" feature in windows dns - thank you for bringing it, but BIND feature to response with a specific IP to a specific source IP is much better in this case.
 
0
 
Chris DentPowerShell DeveloperCommented:

> but BIND feature to response with a specific IP to a specific source IP is much better in this case.

You'll not find me arguing with that, Views are a feature I dearly wish could be implemented in MS DNS :)

It's just BIND tends to be a bit over the top for an AD Domain which is implied because of the Exchange part :)

Chris
0
 
jar3817Commented:
Just add a route to the wan/ppp network via exchange's lan IP.
0
 
Antonio KingIT ManagerAuthor Commented:
The WAN/PPP connection is not in Network Connections.

I don't know where it comes from, but it shows up in ipconfig/all

NOTE: This particular server is a domain controller. (Not sure if that makes any difference) and it hosts the DNS Server.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.