[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 220
  • Last Modified:

Trying to print from wireless laptop/computer to separate network

Hello.  We have a small network with a couple of computers and a printer connected to the LAN ports on a Sonicwall TZ 170.  We recently added a D-link WBR-1310 for wireless access.  The D-Link is attached directly to a LAN port on the SonicWall.  I have a laptop and a workstation both wirelessly connected to the D-Link.  I'm trying to find a way to allow any wirelessly connected users access to print to the networked printer.  The Sonicwall network is set up on a 192.168.168.0 class c.  The D-link upstream connection is off of this class C but I can't pass through any kind of DHCP from the Sonicwall to the wireless users.  I'm having to allow DHCP to the D-link connected users but am using a different IP scheme (192.168.1.0/24).  How would I get my wireless users access to print on the Sonicwall network?

Thanks.
0
mthoene
Asked:
mthoene
  • 4
  • 3
  • 2
2 Solutions
 
SysExpertCommented:
You should set the Dlink as an AP access point rather than a router, so that it inherits the same subnet as your Sonicwall - See the Dlink help and docs.


I hope this helps !
0
 
mthoeneAuthor Commented:
Hi SysExpert...I actually did try this based on the dlink docs.  Turned off uPnP and DHCP on the D-Link, and gave it an IP address from the Sonicwall.  Wireless computers could connect to the access point but could not pick up a DHCP address.
0
 
SysExpertCommented:
Strange. If you set it up as an access point it is supposed to simply be a wireless extension of the router, so DHCP should continue to be supplied by the Sonicwall.

Other options are to have the Dlink use a portion of the DHCP address space NOT used by the Sonicwall

Sonicwall  DHCP  192.168.168.2-50
DLINK DHCP  192.168.168.51-100


I hope this helps !
0
Evaluating UTMs? Here's what you need to know!

Evaluating a UTM appliance and vendor can prove to be an overwhelming exercise.  How can you make sure that you're getting the security that your organization needs without breaking the bank? Check out our UTM Buyer's Guide for more information on what you should be looking for!

 
PugglewuggleCommented:
What you need to do is just connect the cable to the SWITCH ports of the WBR, NOT the WAN port - that will stop this from working... Disregard the WAN configuration on the WBR and make sure the LAN address is what you want it to be (must be on same network/subnet mask) and then connect the cable from the sonicwall to a switchport on the WBR.
You problem should now be solved and you should have access on your wireless computers just like normal.
BTW - you can access the setup of the WBR with the LAN address you assigned it if you want to change settings or upgrade the firmware.
Bottom line - don't use the WAN port for anything.
Cheers! Let me know if you have any questions! :)
0
 
PugglewuggleCommented:
Oh, and yes, only have DHCP in one place on your network. Having more than 2 DHCP serves setup will cause serious issues...
I recommend to use the DHCP on the sonicwall and just disable DHCP on the WBR altogether - the sonicwall will take care of DHCP for the wireless computers too.
Cheers!
0
 
mthoeneAuthor Commented:
Puggle...I did try your solution before posting this question but it wasn't working. I had the cable plugged into the LAN ports of the WBR but the wireless would not pick up DHCP.  I'll start from scratch just in case I missed something.

SysExpert...I did try your solution too, assigning a different set of addresses from the same class C from the WBR but couldn't access the internet. I am beginning to think that this WBR is not the best option for an access point.
0
 
PugglewuggleCommented:
Did you have the IP address on the WBR set to a range outside the DHCP scope on the sonicwall AND did you have the DHCP server on the WBR off?
The WBR and any router can be used fine as an AP with the same exact function as long as you don't use the WAN port. I've done it well over 100 times.
Cheers! Let me know what's going on!
0
 
mthoeneAuthor Commented:
Ok gave it another whirl tonight.  Nothing would work.  Plugged the cable from the Sonicwall to a LAN port on the WBR, turned of DHCP on the WBR, made sure the IP address on the WBR was from outside the DHCP range on the Sonicwall.  The laptop still would not pick up a DHCP address.  I am wondering if there is a setting on the Sonicwall I'm missing.  I checked the firewall settings and nothing looks amiss.  
0
 
mthoeneAuthor Commented:
Experts solutions were perfect but for whatever reason did not work with this solution.  Chalking it up to 'network anomaly'. :)
0

Featured Post

Will You Be GDPR Compliant by 5/28/2018?

GDPR? That's a regulation for the European Union. But, if you collect data from customers or employees within the EU, then you need to know about GDPR and make sure your organization is compliant by May 2018. Check out our preparation checklist to make sure you're on track today!

  • 4
  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now