Solved

Outgoing Mail Problem

Posted on 2008-10-07
19
498 Views
Last Modified: 2013-11-30
I've tried three different network monitoring tools that have email notification functionality and the emails will go through if the address is my local exchange address but not if it is sent to an external Internet address.  Any ideas?
0
Comment
Question by:Stevenscs
  • 9
  • 5
  • 5
19 Comments
 
LVL 11

Expert Comment

by:Bertling
ID: 22661738
please can you provide more info on this?
0
 

Author Comment

by:Stevenscs
ID: 22661935
Sure, like what?
0
 
LVL 8

Expert Comment

by:Point-In-Cyberspace
ID: 22661937
It seems a trouble about smtp. This could be if you have an internal server as your smtp server.
Use the smtp server of your provider and not that of your internal server in the configuration of those tools. Normally it is smtp.providername.com or mail.providername.com
If you already did it try to verifiy if the machine where you are running those tools is able to go on Internet. To test this it's not sufficient to browse the web,. You have to open a command prompt and try to ping a site like www.google.com and see if it's reachable. Finellay try, always from a command prompt, to telnet to the smtp server of your provider: in acommand prompt input
  telnet smtp.providername.com 25
it should answer with something whit the word ready somewhere.

0
 
LVL 11

Expert Comment

by:Bertling
ID: 22661987
please advise if you can use NSLOOKUP on the exchange server itself and try to resolve the mx records of hotmail.com. if you can then we know its not a DNS issue

do you use a smart host or SMTP gateway to send your mail or use DNS?
0
 

Author Comment

by:Stevenscs
ID: 22663870
Point,
I can ping an external site from this computer.  When I try to ping the provider smtp.elpasotel.com or mail.elpasotel.com, I get request timed out.  I cannot telnet to either address - it says connection failed.

Bertling,
If I am using nslookup correctly - here is the output...
> hotmail.com
Server:  hawk00.ellicott.local
Address:  10.0.0.5

Non-authoritative answer:
Name:    hotmail.com
Addresses:  64.4.33.7, 64.4.32.7

In regards to how we send mail, I'm a novice when it comes to this, but here is what I found out in poking around: In AD I selected a user with an email account, properties, email addresses tab, and the type says SMTP.  Does that answer the question?

As an FYI, I have a linux based mail filter (webmin) that only looks at incoming mail.
0
 
LVL 11

Expert Comment

by:Bertling
ID: 22666792
hi there, try to telnet using this command from the excahnge server and revert the output:

telnet mx2.hotmail.com 25
0
 
LVL 8

Expert Comment

by:Point-In-Cyberspace
ID: 22668053
You have firewalls on somewhere.

I can connect to your provider on port 25:

telnet mail.elpasotel.com
220 mail2.elpasotel.com ESMTP MailEnable Service, Version: 0--3.53 ready at

You have to create a rule on the firewall for machine you need to send mail on the Internet so firewall don't block it.

Another way is to create an email address on AD for the user that the tools use to send mail. Exchange may block send for non existing accounts. Ask your exchange administrator help about this.

0
 

Author Comment

by:Stevenscs
ID: 22673730
Bertling,
Here is the output from the telnet:

220 bay0-mc6-f18.bay0.hotmail.com Sending unsolicited commercial or bulk e-mail to Microsoft's computer network is prohibited. Other restrictions are found at http://privacy.msn.com/Anti-spam/. Violations will result in use of equipment located in California and other states. Wed, 8 Oct 2008 06:46:13 -0700

Connection to host lost.
________________________________

Point,
I created a rule on my firewall to allow SMTP traffic from the monitoring tool computers IP address and placed it above the rule that blocks outgoing SMTP traffic from lanusers.  That did not work. I even went as far as disabling the rule that blocks outgoing SMTP traffic from lanusers, that did not work.

As for your second suggestion, I've already been using my own local domain email address as the sending address.
0
 
LVL 11

Expert Comment

by:Bertling
ID: 22676372
have you checked the settings on your SMTP connector wit hthe address space of * ?

please can you advise how this is setup?
thanks
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 
LVL 8

Expert Comment

by:Point-In-Cyberspace
ID: 22678537
> As for your second suggestion, I've already been
> using my own local domain email address as the sending address.

Then use the private ip address of your exchange as your smtp server

For the firewall, with this rule for smtp enabled, try to telnet to the smtp server of your provider on port 25.
If the rule is good you should be able to connect to it's server.

0
 

Author Comment

by:Stevenscs
ID: 22724604
Sorry for the delay, I got busy with some other issues.

Bertling,
I don't know what you mean by SMTP connector settings.  Will you be more specific?

Point...
I tried the private IP of the exchange server as my SMTP server, no joy.

I AM able to telnet to telnet mail.elpasotel.com 25 with my new firewall rule in place.

What next?
0
 
LVL 11

Expert Comment

by:Bertling
ID: 22726418
there is a smtp connector in routing groups. the peroperties of this there is a tab called address space. it will have a * as the address space.

please advise the info on this tab and the general tab
0
 

Author Comment

by:Stevenscs
ID: 22731889
Bertling,
On the address tab I've got Type = SMTP, Address = *, Cost = 1, Under Connector scope Entire organization is selected.  Under the General tab, "Use DNS to route to each address space on this connector" is selected, under Local bridgeheads, Server = (my exchange server name is listed), Virtual Server = Default SMTP Virtual Server, at the bottom "Do not allow public folder referrals" is checked.
0
 
LVL 8

Expert Comment

by:Point-In-Cyberspace
ID: 22732488
Well, let's make another step.

Configure an email client on the machine you are using the tools. It can be Outlook express or thunderbird or whatever.

Create a fake account with a user like test@test.com
As pop3 server put 127.0.0.1
As smtp server put: mail.elpasotel.com


Now try to create and send an email to an address that you can verify after, avoiding your active directory mail account.

When you'll check mail the receive will give error and this is right, but your mail should go.
If it can't be send then tell me what error show.

For the exchange, just for your knowledge and not to solve in this way, it should be blocked on smtp send. Probably it's configured to use only outlook to send mails.
To check this config your lan account on outlook express using the ip address of exchange as smtp server and try to send an email. You'll get an error.

0
 

Author Comment

by:Stevenscs
ID: 22758879
Point,
Here is the error from Outlook Express:

The message could not be sent because one of the recipients was rejected by the server. The rejected e-mail address was 'myaddress@gmail.com'. Subject 'test from OE', Account: '127.0.0.1', Server: 'mail.elpasotel.com', Protocol: SMTP, Server Response: '503 This mail server requires authentication when attempting to send to a non-local e-mail address. Please check your mail client settings or contact your administrator to verify that the domain or address is defined for this server.', Port: 25, Secure(SSL): No, Server Error: 503, Error Number: 0x800CCC79
0
 
LVL 8

Expert Comment

by:Point-In-Cyberspace
ID: 22759541
This error means that the smtp server of your provider require authentication to relay mail to external addresses.
This is not so strange.

Now you have two ways:

1) check if your tools are able to send mail to a server that require authentication. If yes then you can get the required username and password from your ISP. Probavly you already have them configured in your exchange.

2) let exchange accept smtp delivery from your lan to internet addresses. In this case you have to config exchange in the right way.


0
 

Author Comment

by:Stevenscs
ID: 22759988
Point,
Let's try option two, how do I configure Exchange to accept smtp delivery from my LAN to Internet addresses?
0
 

Author Comment

by:Stevenscs
ID: 22823582
Point and Bertling,
Did you give up?
0
 

Accepted Solution

by:
Stevenscs earned 0 total points
ID: 22886792
I tried another server monitoring tool and it does external email notifications.  It is called Tembria Server Monitor
0

Featured Post

Do You Know the 4 Main Threat Actor Types?

Do you know the main threat actor types? Most attackers fall into one of four categories, each with their own favored tactics, techniques, and procedures.

Join & Write a Comment

Easy CSR creation in Exchange 2007,2010 and 2013
Learn to move / copy / export exchange contacts to iPhone without using any software. Also see the issues in configuration of exchange with iPhone to migrate contacts.
In this video we show how to create an Accepted Domain in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Ac…
This video discusses moving either the default database or any database to a new volume.

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now