Solved

Caller Name incoming from PRI not displaying

Posted on 2008-10-07
11
5,803 Views
Last Modified: 2013-12-27
My Call manager express isn't displaying the Caller Name on the IP Phone. I see the name presented in the isdn q931 debug however. Any help is appreciated. Debug isdn q931 and Running config are attached.




Debug isdn q931:
 
 

Cisco2811#

Oct  7 19:57:52.838: ISDN Se0/0/0:23 Q931: RX <- SETUP pd = 8  callref = 0x025D

        Bearer Capability i = 0x8090A2

                Standard = CCITT

                Transfer Capability = Speech

                Transfer Mode = Circuit

                Transfer Rate = 64 kbit/s

        Channel ID i = 0xA98381

                Exclusive, Channel 1

        Facility i = 0x9F8B0100A10F02010106072A8648CE1500040A0100

                Protocol Profile =  Networking Extensions

                0xA10F02010106072A8648CE1500040A0100

                Component = Invoke component

                        Invoke Id = 1

                        Operation = InformationFollowing (calling_name)

                                Name information in subsequent FACILITY message

        Progress Ind i = 0x8283 - Origination address is non-ISDN

        Calling Party Number i = 0x2183, '4072575115'

                Plan:ISDN, Type:National

        Called Party Number i = 0xA1, '4075732031'

                Plan:ISDN, Type:National

Oct  7 19:57:52.862: ISDN Se0/0/0:23 Q931: TX -> CALL_PROC pd = 8  callref = 0x825D

        Channel ID i = 0xA98381

                Exclusive, Channel 1

Oct  7 19:57:52.878: ISDN Se0/0/0:23 Q931: TX -> ALERTING pd = 8  callref = 0x825D

        Progress Ind i = 0x8188 - In-band info or appropriate now available

Oct  7 19:57:53.246: ISDN Se0/0/0:23 Q931: RX <- FACILITY pd = 8  callref = 0x025D

        Facility i = 0x9F8B0100A117020101020100800F574952454C4553532043414C4C4552

                Protocol Profile =  Networking Extensions

                0xA117020101020100800F574952454C4553532043414C4C4552

                Component = Invoke component

                        Invoke Id = 1

                        Operation = CallingName

                                Name presentation allowed

                                Name = WIRELESS CALLER

Cisco2811#

Oct  7 19:57:55.226: ISDN Se0/0/0:23 Q931: TX -> CONNECT pd = 8  callref = 0x825D

Oct  7 19:57:55.254: ISDN Se0/0/0:23 Q931: RX <- CONNECT_ACK pd = 8  callref = 0x025D

Oct  7 19:57:55.258: %ISDN-6-CONNECT: Interface Serial0/0/0:0 is now connected to 4072575115 N/A

Oct  7 19:57:57.519: %ISDN-6-DISCONNECT: Interface Serial0/0/0:0  disconnected from 4072575115 , call lasted 2 seconds

Oct  7 19:57:57.523: ISDN Se0/0/0:23 Q931: TX -> DISCONNECT pd = 8  callref = 0x825D

        Cause i = 0x8090 - Normal call clearing

Oct  7 19:57:57.555: ISDN Se0/0/0:23 Q931: RX <- RELEASE pd = 8  callref = 0x025D

Oct  7 19:57:57.563: ISDN Se0/0/0:23 Q931: TX -> RELEASE_COMP pd = 8  callref = 0x825D
 
 
 
 

Running Config:
 

!

! Last configuration change at 15:55:12 East Tue Oct 7 2008 by eric

! NVRAM config last updated at 15:51:24 East Tue Oct 7 2008 by eric

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname Cisco2811

!

boot-start-marker

boot-end-marker

!

logging userinfo

logging buffered 10240 debugging

no logging console

enable secret 5 ***************************

!

aaa new-model

!

!

aaa authentication login Local-Login local

!

aaa session-id common

!

resource policy

!

clock timezone EST -5

clock summer-time East recurring

network-clock-participate wic 0

ip subnet-zero

!

!

ip cef
 

ip name-server 66.155.216.122

ip ips notify SDEE

!

isdn switch-type primary-ni

!

voice-card 0

 no dspfarm

!
 

ivr prompt streamed flash

!

application

 service queue flash:IVR/app-b-acd-2.1.2.2.tcl

  param aa-hunt3 6732

  param queue-len 10

  param aa-hunt4 5200

  param aa-hunt1 888

  param queue-manager-debugs 1

  param number-of-hunt-grps 3

 !

 service recorder flash:/IVR/recorder.tcl

  paramspace english language en

  paramspace english index 1

  paramspace english location flash:/IVR/

 !

 service aa flash:IVR/app-b-acd-aa-2.1.2.2.tcl

  param schedule-Sun 0000-0000

  paramspace english index 1

  param number-of-hunt-grps 3

  param menu-timeout 1

  param schedule-Sat 0000-0000

  param dial-by-extension-option 2

  param handoff-string aa

  param schedule-Mon 0800-1700

  paramspace english language en

  param max-time-vm-retry 2

  param max-extension-length 3

  param aa-pilot 22334

  param schedule-Tue 0800-1700

  paramspace english location flash:IVR/

  param second-greeting-time 30

  param schedule-Wed 0800-1700

  param schedule-Fri 0800-1700

  param schedule-Thu 0800-1700

  param welcome-prompt _bacd_welcome.au

  param call-retry-timer 5

  param voice-mail 5200

  param max-time-call-retry 300

  param service-name queue

 !

!

username eric privilege 15 password 7 ***************************

!

!

controller T1 0/0/0

 framing esf

 linecode b8zs

 channel-group 8 timeslots 8-23

 pri-group timeslots 1-7,24

!

!

translation-rule 10

 Rule 1 1 1 ANY national

!

!

translation-rule 5001

 Rule 1 5001 5000

!

gw-accounting syslog

!

interface FastEthernet0/0

 description DATA VLAN

 encapsulation dot1Q 10

 ip address 192.168.19.254 255.255.255.0

 no ip redirects

 no ip proxy-arp

 ip nat inside

 ip virtual-reassembly

 ip policy route-map Default-Route-RR

 no snmp trap link-status

!

interface FastEthernet0/1

 description Voice VLAN

 ip address 172.16.200.1 255.255.255.0

 no ip redirects

 no ip proxy-arp

 ip nat inside

 ip virtual-reassembly

 ip policy route-map Default-Route-T1

 duplex auto

 speed auto

!

interface Serial0/0/0:8

 description ISDN PPP Channel Group

 ip address ***.***.***.*** 255.255.255.252

 ip access-group Incoming-from-Internet in

 ip nat outside

 ip virtual-reassembly

 encapsulation ppp

 crypto map VPN-MAP

!

interface Serial0/0/0:23

 description ISDN D-Channel

 no ip address

 isdn switch-type primary-ni

 isdn incoming-voice voice

 isdn calling-number 4074106732

 isdn supp-service name calling

 no cdp enable

!

ip classless

ip route 0.0.0.0 0.0.0.0 Serial0/0/0:8

!

!

ip http server

ip http authentication local

ip http secure-server

ip nat inside source list NAT-Source-For-T1 interface Serial0/0/0:8 overload

!

ip access-list extended Default-Route-RR

 deny   ip any 192.168.19.0 0.0.0.255

 deny   ip any 172.0.0.0 0.16.255.255

 permit ip 192.168.19.0 0.0.0.255 any

ip access-list extended Default-Route-T1

 deny   ip any 192.168.19.0 0.0.0.255

 deny   ip any 172.0.0.0 0.16.255.255

 permit ip 172.16.200.0 0.0.0.255 any

ip access-list extended FreshAirVPN-SplitTunnel

 permit ip 192.168.19.0 0.0.0.255 any

 permit ip 172.16.2.0 0.0.0.255 any

 permit ip 172.16.200.0 0.0.0.255 any

ip access-list extended Incoming-from-Internet

 deny   tcp any host ***.***.***.*** eq 1720

 permit ip any any

ip access-list extended NAT-Source-For-T1

 deny   ip any 172.16.2.0 0.0.0.255

 permit ip 172.16.200.0 0.0.0.255 any

 permit ip 192.168.19.0 0.0.0.255 any

!

logging trap debugging

logging 192.168.19.1

!

route-map Default-Route-RR permit 10

 description Select traffic and force it through Road Runner

 match ip address Default-Route-RR

 set ip next-hop 192.168.19.253

!

route-map Default-Route-T1 permit 10

 description Select traffic and force it through T-1

 match ip address Default-Route-T1

 set ip next-hop ***.***.***.***

!

!

!

tftp-server flash:P0030702T023.bin

tftp-server flash:P0030702T023.loads

tftp-server flash:P0030702T023.sb2

tftp-server flash:P0030702T023.sbn

tftp-server flash:S00104000100.sbn

tftp-server flash:Analog1.raw

tftp-server flash:Analog2.raw

 ----Extra TFTP files removed----

tftp-server flash:Vibe.raw

tftp-server flash:24.raw

tftp-server flash:55.raw

!

control-plane

!

!

!

voice-port 0/0/0:23

 description PRI

!

!

!

!

!

dial-peer voice 1 pots

 description Inbound DID Routing

 incoming called-number ..........

 direct-inward-dial

 port 0/0/0:23

!

dial-peer voice 2 pots

 description Inbound AA ACD

 service aa

 incoming called-number 4074106732

 port 0/0/0:23

!

dial-peer voice 100 pots

 description Outgoing Local

 destination-pattern 9[2-9].........

 port 0/0/0:23

!

dial-peer voice 101 pots

 description Outgoing National LD

 destination-pattern 91..........

 port 0/0/0:23

 prefix 1

!

dial-peer voice 102 pots

 description Outgoing International LD

 destination-pattern 9011T

 translate-outgoing called 10

 port 0/0/0:23

 prefix 011

!

dial-peer voice 911 pots

 description Forced 911

 destination-pattern 9911

 port 0/0/0:23

!

dial-peer voice 66 voip

 description recorder script

 service recorder

 destination-pattern ^66$

 session protocol sipv2

 session target ipv4:172.16.200.1

 incoming called-number ^66$

 dtmf-relay rtp-nte

 codec g711ulaw

 no vad

!

dial-peer voice 67 voip

 description Local AA Access

 service aa

 destination-pattern ^22334$

 session protocol sipv2

 session target ipv4:172.16.200.1

 incoming called-number ^22334$

 dtmf-relay rtp-nte

 codec g711ulaw

 no vad

!

dial-peer voice 50 voip

 description VoiceMail System

 destination-pattern 5...

 session target ipv4:192.168.19.80

 dtmf-relay h245-alphanumeric

 codec g711ulaw

 no vad

 no supplementary-service h450.2

 no supplementary-service h450.3

!

dial-peer voice 51 voip

 description VoiceMail System No CLID

 destination-pattern 5001

 translate-outgoing called 5001

 session target ipv4:192.168.19.80

 dtmf-relay h245-alphanumeric

 codec g711ulaw

 clid strip

 no vad

 no supplementary-service h450.2

 no supplementary-service h450.3

!

!

!

!

telephony-service

 load 7960-7940 P0030702T023

 load 7914 S00104000100

 max-ephones 24

 max-dn 144

 ip source-address 172.16.200.1 port 2000

 auto assign 1 to 24

 no caller-id name-only

 timeouts interdigit 4

 system message The Fresh Air Group

 url services http://phone-xml.berbee.com/menu.xml

 create cnf-files version-stamp 7960 Sep 19 2008 13:10:51

 voicemail 5000

 max-conferences 8 gain -6

 moh music-on-hold.au

 web admin system name admin secret 5 *********************************

 dn-webedit

 time-webedit

 transfer-system full-consult

 transfer-pattern 9..........

 transfer-pattern 9...........

 transfer-pattern 22334

 transfer-pattern 5...

 secondary-dialtone 9

 xmltest

!

!

ephone-dn  1  dual-line

 number 100

 label Reception (100)

 description Reception

 name Reception

 call-forward busy 5100

 call-forward noan 5100 timeout 18

!

!

ephone-dn  2  dual-line

 number 101

 label Tamara (101)

 description Tamara A.

 name Tamara

 call-forward busy 5101

 call-forward noan 5101 timeout 18

!

!

....

....

 ---- Extra DN's removed ----

....

....

ephone-dn  12  dual-line

 number 111 secondary 4075732031

 label Eric (111)

 description Eric M.

 name Eric

 call-forward busy 5111

 call-forward noan 5111 timeout 18

!

!

ephone-dn  13  dual-line

 number 112

 label Aaron (112)

 description Aaron S.

 name Aaron

 call-forward busy 5112

 call-forward noan 5112 timeout 18

!

!

ephone-dn  44

 number 8000*...*1 secondary 8000*...*2

 mwi on-off

!

!

ephone-dn  45

 number 8000*...*1 secondary 8000*...*2

 mwi on-off

!

!

ephone-dn  110  dual-line

 number 7000

 label Main (407-410-6732)

!

!

ephone-dn  111  dual-line

 number 7001

 label Main Rollover (407-410-6732)

!

!

ephone-dn  120

 number 888

 description Emergency Number

 call-forward all 917572780842

!

!

ephone-dn  121

 number 200

 label General Delivery Mailbox

 intercom 5000

!

!

ephone  1

 description Reception Phone

 mac-address 000D.BC50.E672

 type 7960 addon 1 7914

 button  1:1 3:121 5:110 6:111 7m2 8m3 9m4 10m5

 button  11m6 12m7 13m8 14m9 15m10 16m11 17m12 18m13

!

!

!

ephone  2

 description Tamara

 mac-address 0019.305D.D910

 type 7960

 button  1:2 6:111

!

!

....

....

 ---- Extra Phones Removed ----

....

....

!

!

ephone  12

 description Eric

 mac-address 0015.FA0C.B755

 type 7960

 button  1:12

!

!

!

ephone  13

 description Aaron

 mac-address 0012.D9ED.EA67

 type 7960

 button  1:13

!

!

ephone-hunt 10 sequential

 pilot 6732

 list 7000, 7001

 final 22334

 timeout 10

!

!

!

line con 0

 password 7 151A5A1E55227A2C78

 logging synchronous

 login authentication Local-Login

line aux 0

 login authentication Local-Login

 modem InOut

 transport input all

line vty 0

 logging synchronous

 login authentication Local-Login

 monitor

 transport input ssh

line vty 1 5

 logging synchronous

 login authentication Local-Login

 transport input ssh

!

scheduler allocate 20000 1000

ntp clock-period 17180771

ntp update-calendar

ntp server 132.163.4.103

!

end

Open in new window

0
Comment
Question by:CiscoKid-Eric
  • 4
  • 4
  • 3
11 Comments
 
LVL 79

Expert Comment

by:lrmoore
ID: 22664424
What exact version of IOS do you have? There's a bug in some versions..
0
 

Author Comment

by:CiscoKid-Eric
ID: 22664458
12.4(3b) Advanced Enterprise
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 22664489
caller-id name delivery was added in 12.4.11XW
0
 

Author Comment

by:CiscoKid-Eric
ID: 22664623
That's weird. I had this system setup at a different site connected to XO communications, and it came through over there. Now it's with Paetec, but both places were NI-2 PRI's
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 450 total points
ID: 22664707
Could just be a bug in your current version or a tiny difference in the way it is delivered by the telco.
This could help:
http://www.cisco.com/en/US/docs/ios/12_4/12_4x/release/notes/rn2800xw.html#wp363697

0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 
LVL 4

Assisted Solution

by:icanhelp
icanhelp earned 50 total points
ID: 22675927
I think you should check with your telco and ask them SPECIFICALLY:  "Where is the ISDN PRI signal actually being generated?"  Premise equipment or at the central office?  Some ISPs claim that they're handing your a PRI circuit, when in actually it's a channelized T1 and are generating the PRI specific signalling at your building and not at central office.

Why is this significant?  Because the PRI communications on your D-channel is then being reconverted in-band back to the CO whereas they may not be able to strip all parameters (or pass in to your office for that matter) all of the feature sets available on a normal PRI.

I noticed that you do have your T1 controller "chopped" up into different groups.  Looks like to me that they're actually handing you a Channelized T1 and mimicking PRI signalling from their onsite equipment to your router.  There's another SIGNIFICANT piece to this.  If they actually are using channelized T1 (T1 CAS or Robbed Bit Signalling), the PSTN information is being passed in-band rather than out of band (as such as what the D channel is for).  H323 as a protocol for Cisco routers cannot pull out inband ANI (caller ID) signals to pass along the caller ID to your set.  Sounds like to me you had a true PRI before and now you don't.

let me know if this is correct.  It's an easy call to make and make sure that they know exactly what you're asking.  Don't simply ask them if you have an ISDN PRI....ask them where exactly the signal is being generated and is it completely out of band D-channel signalling all the way to the central office's switch.

cheers.

rc
0
 
LVL 4

Expert Comment

by:icanhelp
ID: 22675937
correction:

I stated previously:  "...H323 as a protocol for Cisco routers cannot pull out inband ANI (caller ID) signals to pass along the caller ID to your set..."

To correct, I mean that H323 on Cisco Routers cannot pull ANI out whe T1Cas circuits are being used.  FXO and PRI circuits with H323 have no problem pulling out ANI.
0
 
LVL 4

Expert Comment

by:icanhelp
ID: 22701761
did this help you?
0
 

Author Comment

by:CiscoKid-Eric
ID: 24287053
Finally got this one resolved. It's definately the IOS image version, and the telco's handling of the information. The telco is sending the Calling party's name in a supplemental message, which the older versions of IOS didn't support. The new versions allow you to use the "isdn supp-service name calling" command on the serial interface to append the ie messages to the original q931 info.
0
 

Author Comment

by:CiscoKid-Eric
ID: 24287058
btw...I'm now using Adv Enterprise 12.4(24)T.
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 24287375
Thanks for the update!
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
Thomson router 3 64
Ghost Calls on Cisco Video Conference System 5 39
Dyndns Configuration 3 49
Routing VLANs 5 47
Almost all Internet protocol telephones have built-in switches at the back that allow you to connect your personal computer to one port and use the other port to connect your phone to to a Cisco switch.   Why we need to connect the PC to the pho…
Creating an OSPF network that automatically (dynamically) reroutes network traffic over other connections to prevent network downtime.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now