Solved

ActiveSync keeps asking for password multiple times when syncing with Exchange

Posted on 2008-10-07
5
1,312 Views
Last Modified: 2013-12-05
Hi all,

I am having the following strange issue. I have a Windows Mobile 6.0 / 6.1 device (I have an Axim, a Samsung BlackJack II, etc). I have an Exchange Server 2007 running on Windows 2008, configured behind a NAT and RPC over HTTP with ports forwarded on the outside router (port 135 is blocked, but RPC over HTTP works fine). I am having an issue where NONE of my Windows Mobile devices "remember" the password.

The situation is as follows: when I run ActiveSync, it will prompt me for the password anywhere between 3 and 15 times or so. It seems it needs a password for EVERY step of the sync: Calendar, Email, Tasks, etc. When I enter the password, the sync progresses slightly. Eventually, if I enter it all the 15 times or whatever, it will stay synced and will sync perfectly by itself until I power off the device and power it on again.

The server is set up to authenticate using self-signed SSL+personal certificates; I have installed the self-signing CA's certificate onto the WM6 device, and installed a personal certificate on it as well (although I don't think it ever asks me to use the personal one).

What do I do? Any advice appreciated. It does not seem to be related to a specific Windows Mobile device - _all_ WM devices appear to behave this way with my servers.
0
Comment
Question by:t00manyusers
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 1

Expert Comment

by:Cvif3v3r
ID: 22663820
Have you tried removing your Personal certificates and seeing if this corrects the issue? I use exchange 2007 for about 25 mobile devices and have not had this issue with but one of them. The old Q phone had an issue when we first started using them, but that was Windows Mobile 5. The personal certificates may be the cause of this issue. Try removing the requirement for personal certificates and if it functions correctly, rebuild your personal certs.
0
 

Author Comment

by:t00manyusers
ID: 22664418
Hang on, are you saying I should remove the _requirement_ for certs, or I should remove the certificates itself from the Windows Mobile device? If you mean remove the _requirement_ from Exchange - how should I do it?
0
 

Author Comment

by:t00manyusers
ID: 22680657
Any help, anyone?...
0
 
LVL 1

Accepted Solution

by:
Cvif3v3r earned 500 total points
ID: 22680673
If you remove the requirement for certs and it works you have eliminated the possibility of errors on the exchange server regarding aActive Sync. Then you are left with troubleshooting the certificates. Just a thought.
0
 

Author Comment

by:t00manyusers
ID: 22810056
Sorry about the delay - was travelling, didn't have a chance to get back to this. Having set the certificate requirement to "ignore" from the previous "accept", it seems to no longer harrass me about passwords. Thanks for the thought!
0

Featured Post

Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article will help to fix the below error for MS Exchange server 2010 I. Out Of office not working II. Certificate error "name on the security certificate is invalid or does not match the name of the site" III. Make Internal URLs and External…
An introduction to the wonderful sport of Scam Baiting.  Learn how to help fight scammers by beating them at their own game. This great pass time helps the world, while providing an endless source of entertainment. Enjoy!
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…
In this video, viewers are given an introduction to using the Windows 10 Snipping Tool, how to quickly locate it when it's needed and also how make it always available with a single click of a mouse button, by pinning it to the Desktop Task Bar. Int…
Suggested Courses

628 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question