Solved

Cisco PAT issue (PIX 501)

Posted on 2008-10-07
5
359 Views
Last Modified: 2010-04-09
Hi,

I'm trying to port forward SMTP & SSL to an internal Exchange 2003 server, however upon running shields up, non of the ports are responding through my PIX,  below is my current running config:-

PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password SX/Y7cXtfgcNOcz9 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname pixfw
domain-name workgroup
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name 192.168.0.13 Exchange
access-list outside_access_in permit tcp any host Exchange eq smtp
access-list outside_access_in permit tcp any host Exchange eq https
access-list outside_access_in deny tcp any any
pager lines 24
icmp deny any outside
mtu outside 1500
mtu inside 1500
ip address outside dhcp setroute retry 4
ip address inside 192.168.0.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm location 192.168.16.58 255.255.255.255 outside
pdm location Exchange 255.255.255.255 inside
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) Exchange Exchange netmask 255.255.255.255 0 0
access-group outside_access_in in interface outside
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 192.168.0.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
telnet 192.168.0.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 192.168.0.2-192.168.0.10 inside
dhcpd dns 81.26.107.2
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd enable inside
terminal width 80
banner login Disconnect immediately if not authorised
banner motd Home cable firewall
Cryptochecksum:ffffcca67b44b1c97ae7883631c5011b
: end
pixfw(config)#

Any help would be greatly appreciated!
0
Comment
Question by:dt3itsteam
  • 2
  • 2
5 Comments
 
LVL 13

Assisted Solution

by:Quori
Quori earned 82 total points
ID: 22663961
Curious - are you running shields-up from the Exchange box?
0
 
LVL 1

Author Comment

by:dt3itsteam
ID: 22664068
Hi,

Not from the exchage box directly, but on a host machine running vmware, which is running the Exchange server, 192.168.0.13 is reachable on the network through ICMP and telet port 25
0
 
LVL 13

Assisted Solution

by:Quori
Quori earned 82 total points
ID: 22664099
Okay.

Well, a couple things come to mind:

1) Your ACL is checking for the Exchange host as destination, so if you're running shields-up from another internal IP then the rule may not apply as the NAT established socket destination would not match that of exchange.

2) I do not recall if shields-up uses ICMP to the port to test, or a connect method. If it is ICMP, then you have ICMP deny outbound set and it won't show up.

3) Is it working in spite of not showing up in shields-up?
0
 
LVL 12

Accepted Solution

by:
Pugglewuggle earned 43 total points
ID: 22666136
This is your problem:
static (inside,outside) Exchange Exchange netmask 255.255.255.255 0 0
You have the IP forwarded to itself.
Try replacing it with
static (inside,outside) <outside IP> Exchange netmask 255.255.255.255 0 0
If that won't work then use:
static (inside,outside) interface Exchange netmask 255.255.255.255 0 0
Cheers!
 
0
 
LVL 1

Author Comment

by:dt3itsteam
ID: 22667462
Hi guys,

Thanks for the response, the issue was actually Mcaee access Protection, which has caught me out before!!  Donl't know why I didn't think of it this time!  Disabling the local host service then allows Intrenet Traffic through to my Exchange box.

Thanks agaian anyway for the input and suggestions
0

Featured Post

Control application downtime with dependency maps

Visualize the interdependencies between application components better with Applications Manager's automated application discovery and dependency mapping feature. Resolve performance issues faster by quickly isolating problematic components.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Optimal Xbox 360 connectivity requires "OPEN NAT". If you use Juniper Netscreen or SSG firewall products in a home setting, the following steps will allow you get rid of the dreaded warning screen below and achieve the best online gaming environment…
Imagine you have a shopping list of items you need to get at the grocery store. You have two options: A. Take one trip to the grocery store and get everything you need for the week, or B. Take multiple trips, buying an item at a time, to achieve t…
This Micro Tutorial hows how you can integrate  Mac OSX to a Windows Active Directory Domain. Apple has made it easy to allow users to bind their macs to a windows domain with relative ease. The following video show how to bind OSX Mavericks to …
This is used to tweak the memory usage for your computer, it is used for servers more so than workstations but just be careful editing registry settings as it may cause irreversible results. I hold no responsibility for anything you do to the regist…

910 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

24 Experts available now in Live!

Get 1:1 Help Now