Solved

IE won't accept proxy server config

Posted on 2008-10-07
13
273 Views
Last Modified: 2013-12-08
we've recently installed a proxy server for our workstations to connect through.  i've configured this correctly, and am able to connect with multiple workstations.  I'm able to go into each workstations IE settings, set the proxy settings, and save with no issues.  One pc in particular (which happens to be my pc) is giving me trouble.  i need to change the proxy server address to 10.10.10.10/ss
however, it keeps erasing the "/ss".  when i type 10.10.10.10/ss, then click ok, then go back in, it reverts to whtever the last value was (not always the same value.. i can change it to 10.10.10.100, save, and that will be what it reverts to next time).  i'm able to make this change with no problem on all other workstations, which are same OS (xp), same version of IE..  also, i WAS able to make this change on my pc the other day, but now am not able to.  here's where it gets even stranger:

i've double checked all group policies that might affect this, but again - all other pcs WITHOUT admin access are able to do this - yet my pc/user, with full admin access, cannot.

any thoughts?

thanks!
0
Comment
Question by:jc8125
  • 7
  • 6
13 Comments
 

Author Comment

by:jc8125
ID: 22663854
forgot to mention, have also tried logging in safe mode and as administrator to make changes, neither had any effect, same behavior.
0
 

Expert Comment

by:ITS_TLH1
ID: 22663904
Question: What version of Microsoft Internet Explorer are you using?
0
 

Expert Comment

by:ITS_TLH1
ID: 22663993
Okay, I just noticed the tag for Internet Explorer 7 (*long day*).

Try these steps and let us know:

1. Try making the changes in Safe Mode and then Restart in normal mode.

2. How are you typing in the address? "If you are entering a universal naming convention (UNC) or local network address for the proxy server, be sure you are using backslashes (\) rather than slashes (/). For example, the correct way is to type \\servername, not //servername."

3.  You can try the attached Registry script to forcibly load the settings into the registry.
Regedit4
 

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings]

"MigrateProxy"=dword:00000001

"ProxyEnable"=dword:00000001

"ProxyHttp1.1"=dword:00000000

"ProxyServer"="/10.10.10.10/ss"

"ProxyOverride"="<local>"

Open in new window

0
 

Expert Comment

by:ITS_TLH1
ID: 22664162
Script updated because I can't follow my own instructions with using backslashes:
Regedit4

 

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings]

"MigrateProxy"=dword:00000001

"ProxyEnable"=dword:00000001

"ProxyHttp1.1"=dword:00000000

"ProxyServer"="\10.10.10.10/ss"

"ProxyOverride"="<local>"

Open in new window

0
 

Author Comment

by:jc8125
ID: 22668669
first i couldn't get the script to run, then i read somewhere that XP boxes need to add this as the first line of .reg file:  "Windows Registry Editor Version 5.00"
then it accepted the changes..

however, they didn't work.  the proxy server still shows as 10.10.10.10 when i look in IE, and when i attempt to add the /ss, it reverts back.  
i'm able to change the value in firefox, and as i said, i was able to change the value in IE a few days ago - so this is extremely puzzling.  what could be overriding the registry values?  

next step that i'm thinking is to backup my favorites, etc, and try a uninstall/reinstall of ie?  not sure if that will cure this problem, but it's all i can think of.

let me know if you have any other thoughts..
thanks!
0
 

Expert Comment

by:ITS_TLH1
ID: 22668711
This is just a thought. But do you have 'System Restore' turned on? System Restore can make changes to Windows system files, registry settings, and programs installed on your computer; so it may be forcibly reverting the settings back. Try turning 'System Restore' off temporarily while you make the changes and see if they stay.
0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 

Author Comment

by:jc8125
ID: 22669405
turned off system restore, rebooted.  
made changes to registry.
went into IE, same problem, no change.
looked in registry, and ProxyServer string was GONE!  not blank, but GONE!  (see screenshot attached)
re-merged registry script, no string was created for ProxyServer.  manually created string, back to original issue.
at this point i decided that we were moving backwards instead of forward, and removed IE7 (always hated it anyway, only upgraded to view web sites during development)
once back in IE6, all is well.  able to connect to any proxy server, no problem.
upgraded back to IE7, same problem appears.  it will accept any proxy server, as long as there is no trailing slash.  i just can't wrap my head around the fact that it allowed me to do this the other day.  
any other thoughts are appreciated..  as i've seemed to have hit a brick wall here.
(other than "use firefox instead of IE"..  which i completely agree with - but that's missing the point..)
0
 

Author Comment

by:jc8125
ID: 22669420
in the post above where i said trailing slash, i meant a slash after the ip

(example: 10.10.10.10/ss), not an actual trailing slash
0
 

Expert Comment

by:ITS_TLH1
ID: 22669792
You know I was thinking. Have you tried changing the Proxy settings under a different profile on the machine? Try creating a new profile (or logging into a different one) and then see if you can change and save settings. If you can, then you know its a problem with your profile.

FYI... Your screenshot did not post.
0
 

Author Comment

by:jc8125
ID: 22669878
just tried under another user, and under "administrator", no change.  
0
 

Accepted Solution

by:
ITS_TLH1 earned 250 total points
ID: 22671410
I don't know how you have your network setup; but here we are able to re-image a box in less than 30 minutes. I would suggest re-imaging your machine since the problem is local and (no offense) most of us Admins destroy our own boxes messing with settings, loading software and just being the curious IT folk we are. It might be best to reimage your machine.

- If you can stay with IE6, then I suggest staying with it until some more patches come out for IE7.

- You can also try third-party proxy software if you really need IE7.

After asking around it definately seems as though Microsoft didn't spend much time on Proxy'ing with IE7. Expert 'yellowjetski' has mentioned on here before about using the IE7 Pro addon from http://www.ie7pro.com. I haven't used it, but I know of several people who swear by it when you absolutely have to use IE7.
0
 

Author Comment

by:jc8125
ID: 22671586
i had a feeling we were heading in that direction.  thankfully as the admin i will more than likely connect directly without the proxy anyway, but it makes it a pain to configure/diagnose/etc when you have to hop to another box to connect.  in any event, i'll chalk this one up to a ms glitch (can't imagine one of those).  if it becomes too much of a hassle, i'll redo the pc and post here to confirm it solved the issue.

thanks for your thoughts and advise.  
0
 

Author Closing Comment

by:jc8125
ID: 31504018
thanks again
0

Featured Post

What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

Join & Write a Comment

Do you come here a lot? Are you lazy like me and don't want to go through the "trouble" of having to click your Dock's Safari icon and then having to click your Experts Exchange Favorites bookmark to get here? Well then this article is for you.
This article offers some helpful and general tips for safe browsing and online shopping. It offers simple and manageable procedures that help to ensure the safety of one's personal information and the security of any devices.
Shows how to create a shortcut to site-search Experts Exchange using Google in the Chrome browser. This eliminates the need to type out site:experts-exchange.com whenever you want to search the site. Launch the Search Engine Menu: In chrome, via you…
How to create a custom search shortcut to site-search Experts Exchange using Google in the Firefox browser. This eliminates the need to type out site:experts-exchange.com whenever you want to search the site. Launch your Bookmark Menu: Press 'Ctrl +…

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now