Solved

configuring etherchannel between switches

Posted on 2008-10-07
5
1,387 Views
Last Modified: 2012-05-05
We have 2 floors at one of our locations.  The main floor is where the core 3750 switch with 48 GB ports is and the other floor has 4 3560s, each with 4 GBIC ports.  One of the 3560 is already set up for etherchannel to the 3750.  I need to configure the other 3 switches (which already have 1 connection to the 3750) to use the second GBIC port and enable etherchannel.  

I'm sure this is not that difficult to set up but since I have never done it before I figured I'd check with the experts.  


Here's the pertinent parts of the configs for the routers that are currently working (at least I think...let me know if you need more information)


3750 config (Core Switch)

vlan 7
 name Management

interface Port-channel5
 description Uplink to 3560-48-9th-floor-2
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 7
 switchport mode trunk

interface GigabitEthernet1/0/39
 description Crossconnect to 9th floor Switch II GIG port I
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 7
 switchport mode trunk
 mls qos trust cos
 channel-group 5 mode on


interface GigabitEthernet2/0/39
 description Crossconnect to 9th floor Switch II GIG port II
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 7
 switchport mode trunk
 mls qos trust cos
 channel-group 5 mode on

interface Vlan7
 ip address 192.168.157.1 255.255.255.0

end



2560 wih etherchannel configured and working

vlan 7,10,20-21,40

interface Port-channel1
 description uplink to Core
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 7
 switchport mode trunk

interface GigabitEthernet0/1
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 7
 switchport mode trunk
 speed 1000
 duplex full
 mls qos trust cos
 channel-group 1 mode on
!
interface GigabitEthernet0/2
 description Crossconnect to 8th floor wwc-4948g port 39
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 7
 switchport mode trunk
 speed 1000
 duplex full
 mls qos trust cos
 channel-group 1 mode on

interface Vlan7
 ip address 192.168.157.11 255.255.255.0

end


3560 not configured for etherchannel yet

interface GigabitEthernet0/1
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 7
 switchport mode trunk
 priority-queue out
 mls qos trust cos
!
interface GigabitEthernet0/2
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 7
 switchport mode trunk
 priority-queue out
 mls qos trust cos

end



so, there's nothing about port-channel in there...i assume i'm going to have to add the following

interface Port-channel1
 description uplink to Core
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 7
 switchport mode trunk


as well as this to each GBIC port

speed 1000
duplex full
channel-group 1 mode on


Is that it?  

Also, I haven't installed the GBICs yet.  Can that be done while the switch is in production?  Should I configure the ports first before plugging in the GBIC/the network cable?  I imagine if i plug in the cable before configuring Etherchannel I'm going to have some spanning-tree problems.  

I know this is long...thanks for your time and help in advance.
0
Comment
Question by:shanna1017
  • 2
  • 2
5 Comments
 
LVL 50

Expert Comment

by:Don Johnston
ID: 22664492
The port channel interface will be created automatically by the IOS when you issue the "channel-group" command on the physical interfaces.

Personally, when going between Cisco switches, I prefer "desirable" mode.


0
 

Author Comment

by:shanna1017
ID: 22664835
ok so i just need to add the channel-group commands to each interface and I should be good to go?  

what about this questions?

"Also, I haven't installed the GBICs yet.  Can that be done while the switch is in production?  Should I configure the ports first before plugging in the GBIC/the network cable?  I imagine if i plug in the cable before configuring Etherchannel I'm going to have some spanning-tree problems.  "

I know this is long...thanks for your time and help in advance.
0
 
LVL 50

Accepted Solution

by:
Don Johnston earned 500 total points
ID: 22664898
Yes. The channel-group command is done on each physical interface.

I would install the GBICs, shutdown the interfaces, connect the cables, configure the interfaces and then "no shut" them.

And if it were me, I'd do it during a maintenance window. You know, anything that can go wrong... :-)
0
 

Author Comment

by:shanna1017
ID: 22664902
cool.  thanks a bunch donjohnston!

assuming everything works as explained I will award you the points.
0
 
LVL 12

Expert Comment

by:Pugglewuggle
ID: 22666192
One other thing to note - if you are trunking VLANs over the etherchannel - make sure you don't just allow a fre VLANs - allow them ALL if it is not a problem. This will prevent problems later if you need to add more.
Let me explain - when adding VLANs to a trunked etherchannel port, you MUST configure the VLANs on all physical ports AND in the etherchannel commands or the etherchannel will go down and you will have to make a trip to the device to manually add the configuration to the rest of the interfaces.
Save yourself the trouble and just trunk all VLANs now instead of possibly taking a whole segment of your network that connects through the etherchannel offline later. If this is a main switch, you (or a colleague) can take your whole company offline BY ACCIDENT for whatever time it takes you to get to the switch and fix it through the console cable.
Just a bit of advice learned the hard way. I hope this saves you the same trouble!
Cheers!
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Netgear switch to Cisco switch VLAN not passing traffic 8 54
Alcatel Lucent OS6450 switch randomly reboots 4 69
cisco switch POE watt limitation 5 86
Switch Migration 8 57
The worst thing when starting a new job is when the previous Network Administrator left behind no documentation. How do you get into the devices? If you've been in this situation or just accidently mistyped your password, this article will hopefully…
I eventually solved a perplexing problem setting up telnet for a new switch.  I installed a new Cisco WS-03560X-24P switch connected to an existing Cisco 4506 running a WS-X4013-10GE Sup II-Plus. After configuring vlans and trunking,  I could no…
Microsoft Active Directory, the widely used IT infrastructure, is known for its high risk of credential theft. The best way to test your Active Directory’s vulnerabilities to pass-the-ticket, pass-the-hash, privilege escalation, and malware attacks …
I've attached the XLSM Excel spreadsheet I used in the video and also text files containing the macros used below. https://filedb.experts-exchange.com/incoming/2017/03_w12/1151775/Permutations.txt https://filedb.experts-exchange.com/incoming/201…

840 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question