Solved

weird connectivity issue between serial0 connection and a switch

Posted on 2008-10-07
5
262 Views
Last Modified: 2013-11-09
I have a Cisco 1720 router with a T1 CSU/DSU WIC in it.  The building has a T3 that it splits up and gives to the companies in the building.  They have given us an IP address that I used for the serial interface.  After I configured the router (config to follow...), the WIC was in alarm.  Couldn't figure out why.  Eventually, I transformed an RJ-45 Ethernet cable into an RJ-48C cable (spliced wires 1,4 and 2,5) and the amber alarm light went off.  Serial0 interface now shows as UP.  However, the lights on the Router are all green, but there is no light on the switch.  It's like the switch doesn't see it.  I've switched cables, ports, etc. to no avail.  The local network behind the router cannot access anything outside the router.  Any ideas what is wrong?  Here's the router config:

version 12.1
no service single-slot-reload-enable
service timestamps debug datetime localtime
service timestamps log datetime localtime
service password-encryption
!
hostname router_axx
!
no logging buffered
no logging buffered
logging rate-limit console 10 except errors
enable secret 5 $1$DNwM$rmHCiTTpun2RRBHm4kK6f.
!
memory-size iomem 25
clock timezone MST -7
clock summer-time MDT recurring
ip subnet-zero
no ip finger
ip name-server 12.127.xxx.71
ip dhcp excluded-address 10.20.20.1
ip dhcp excluded-address 10.20.20.251
ip dhcp excluded-address 10.20.20.252
ip dhcp excluded-address 10.20.20.253
!
ip dhcp pool ais
   network 10.20.20.0 255.255.255.0
   default-router 10.20.20.1
   domain-name ais_regus
   dns-server 12.127.xxx.71
!
!
!
!
interface FastEthernet0
 ip address 10.20.20.1 255.255.255.0
 ip access-group 100 in
 ip access-group 100 out
 ip nat inside
 speed auto
 full-duplex
 no cdp enable
!
interface Serial0
 ip address 12.41.xxx.30 255.255.255.224
 ip nat outside
 no cdp enable
!
ip nat pool nat-pool 12.41.xxx.30 12.41.xxx.30 netmask 255.255.255.240
ip nat inside source list 1 pool nat-pool overload
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0
no ip http server
!
access-list 1 permit 10.20.20.0 0.0.0.255
access-list 100 permit tcp any any
access-list 100 permit udp any any
access-list 100 permit ip any any
access-list 100 permit icmp any any
no cdp run
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password 7 14300705020D397B2A
login
!
no scheduler allocate
end
0
Comment
Question by:jamjamiss
  • 2
  • 2
5 Comments
 
LVL 79

Expert Comment

by:lrmoore
Comment Utility
What, exactly, are you connecting the T1 interface to? It cannot plug into an Ethernet switch!
0
 

Author Comment

by:jamjamiss
Comment Utility
Okay, so how can this be done then?  Once again, I've got a single public IP that I have been assigned, and am using PAT on the router.  My network of 5 or so people are behind the router.  What do I connect the router's serial interface to?
0
 
LVL 12

Accepted Solution

by:
Pugglewuggle earned 500 total points
Comment Utility
You can ONLY plug a T1 CSU/DSU into a T1 line! If you're trying to plug this into a T3 then that will NEVER work. if the building provides you with internet from their switch, then you will need to get an ethernet WIC for your 1720.
I have a few extras that I ordered just for 1720s and 1721s if you need one (can I say that on here?). The part number is WIC-1ENET= They're usually about $50 USD + shipping.
This should get you online once you get one of those in and configure it... One other thing... I see you're running IOS 12.1 on your 1720. Upgrade that immediately to something like 12.3 or 12.4... 12.1 is way old. Just make sure that whatever it is it supports a WIC-1ENET card. Some of the older IOS wouldn't work with certain cards.
BTW I hope you didn't fry your T1 card... it might be gone though after plugging it into an ethernet network... best of luck to you on that.
Cheers! Let me know if you have any questions!
0
 
LVL 12

Expert Comment

by:Pugglewuggle
Comment Utility
BTW... you connect the serial interface to nothing. :)
0
 

Author Closing Comment

by:jamjamiss
Comment Utility
Thanks Pugglewuggle.  That makes sense.  I knew it was something easy I was just missing!  I'll go buy a new WIC for it.  Thanks again!!
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Join & Write a Comment

#Citrix #Citrix Netscaler #HTTP Compression #Load Balance
I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now