Solved

Everytime I restart Solaris Network resets to DHCP now I have to restart manually? Can someone help

Posted on 2008-10-07
7
971 Views
Last Modified: 2013-12-27
I hope there are some Solaris Experts on here that can provide help. I ran the installer and had it set the networking as DHCP however I no longer want to use DHCP however even though I edit these files:

/etc/nodename
/etc/hostname.xxn
/etc/inet/hosts
/var/crash/hostname

and then run a command
ifconfig (devicename) set ip_address_i_want_to\_set

Then it will reset the new IP and work. But everytime I rebooted the server it would reset the password to use dhcp. I searched everywhere and found nothing except people saying to use sys-unconfig. I think this is a bit ridiculous seeing that this is unix/linux and we shoudln't be forced to use application based wizards to reset things. Isn't that the point of linux, not to be like windows. I should just be able to go into a file and make the change and viola. anyways, if anyone can tell me how to do it without sys-unconfig that would be great!

But back to my main problem. Since I used sys-unconfig (which is why these two questions are related) now everytime I restart my machine networking is not working. If I run the command svcadm enable -rst network everything turns on and my network is live again and I have an internet connection.

Before I run the command if I check svcs I get this result for offline services:
offline         9:50:32 svc:/milestone/network:default
offline         9:50:32 svc:/network/nfs/status:default
offline         9:50:32 svc:/network/nfs/nlockmgr:default
offline         9:50:32 svc:/network/nfs/cbd:default
offline         9:50:32 svc:/network/nfs/mapid:default
offline         9:50:33 svc:/network/nfs/client:default
offline         9:50:33 svc:/network/ssh:default
offline         9:50:34 svc:/application/management/seaport:default
offline         9:50:34 svc:/application/management/snmpdx:default
offline         9:50:34 svc:/application/management/dmi:default
offline         9:50:35 svc:/application/management/sma:default
offline         9:50:50 svc:/application/print/rfc1179:default


anyone know what this means and why its happening
0
Comment
Question by:nichiaiinc
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
  • 2
7 Comments
 
LVL 40

Expert Comment

by:omarfarid
ID: 22665752
In /etc dir look for file like

/etc/dhcp.interface (e.g. dhcp.hme0)

To stop your system from using DHCP, remove this file or rename it.

For static you need a file in /etc dir like

/etc/hostname.interface (e.g. hostname.hme0)

this file contains hostname of the server or hostname for that ip address and should be in /etc/hosts file (mapped to an ip address)
0
 

Author Comment

by:nichiaiinc
ID: 22667518
Thanks Omarfarid! You will for sure get some of the points for this question. Could you answer the second part of it. Since now this issue is actually resolved but when my server reboots the networking is down and I have to manually start it. How do I just set this to automatically start when the server boots up.
0
 
LVL 40

Expert Comment

by:omarfarid
ID: 22667542
have you created the file hostname.interface (here interface in the interface you are using e.g. hme0) ?

When you say manually, what exactly you do?
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:nichiaiinc
ID: 22667562
Yep, I have created all those files.

When i restart the server networking doesnt work.

I run this command

svcadm enable -rst network

and then everything works.
0
 
LVL 22

Accepted Solution

by:
blu earned 500 total points
ID: 22668254
Instead of running "svcadm enable -rst network" run the command "svcadm enable -rs network"  

When you specify the "-t" option, you are saying "turn on all network services temporarily" which is exactly what you don't want, you want them on permanently.
0
 
LVL 22

Expert Comment

by:blu
ID: 22668273
By the way, after you do that, you should run the "svcs" command and go through the list and check that you really want all of the enabled services running. When you use the "-r" command, you are enabling all dependent services on network. That probably includes some services that you don't want.
0
 

Author Closing Comment

by:nichiaiinc
ID: 31504078
DEAD ON. THakn you BLU! I am new to Solaris and especially this SVC system. but I am getting the hang of it now. cheers!
0

Featured Post

On Demand Webinar: Networking for the Cloud Era

Did you know SD-WANs can improve network connectivity? Check out this webinar to learn how an SD-WAN simplified, one-click tool can help you migrate and manage data in the cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

FreeBSD on EC2 FreeBSD (https://www.freebsd.org) is a robust Unix-like operating system that has been around for many years. FreeBSD is available on Amazon EC2 through Amazon Machine Images (AMIs) provided by FreeBSD developer and security office…
Why Shell Scripting? Shell scripting is a powerful method of accessing UNIX systems and it is very flexible. Shell scripts are required when we want to execute a sequence of commands in Unix flavored operating systems. “Shell” is the command line i…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
In a previous video, we went over how to export a DynamoDB table into Amazon S3.  In this video, we show how to load the export from S3 into a DynamoDB table.

724 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question