Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Autodiscover service

Posted on 2008-10-08
3
Medium Priority
?
595 Views
Last Modified: 2012-05-05
The autodiscover work fine for computer in the domain, I change the URL of service to match the SSL installed on the Exchange 2007 Server to "mail.domain.com"
For computers not in the domain, they can open Outlook, send and receive email but they are not able to set their Out of office and access shared calendar.
I try the "Test E-mail AutoConfiguration" and the test failed because Outlook try to access "autodiscover.domain.com" and not the URL configured for the service.
I find a workaround : I add a CNAME in the internal DNS autodiscover.domain.com ->  mail.domain.com
But now I get an error when I start Outlook because the SSL doesn't match name "autodiscover.mail.com"
If I click on Yes, it's work.
How can I get rid about this warning message ?
A wildcard certificate could be the solution but it's really very expensive.

Thanks for your help
0
Comment
Question by:polarisit
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 
LVL 8

Assisted Solution

by:sstone55423
sstone55423 earned 200 total points
ID: 22667181
I think you are right that either getting a new cert, or a wildcard cert may be the best answer, but I think a multiple osmain( UCC) certificate will work -- from Godaddy.com, about $89/year.
0
 

Accepted Solution

by:
polarisit earned 0 total points
ID: 22668169
Because Autodiscover in Exchange 2007 is Active Directory based, computer outside the domain could not read the server info.
Solution is to create a SRV record in the internal DNS pointing on the Exchange Server
See MS article : http://support.microsoft.com/kb/940881/en-us

Work for, just a remark, the first time you start your Outlook, you will have a message that you will be redirect on mail.domain.com, check "don't show this message again" and accept.
0
 
LVL 8

Expert Comment

by:sstone55423
ID: 22713564
Did you get everything working okay, or do you need more help?  If you got it working, please close the question.
0

Featured Post

Office 365 Training for Admins - 7 Day Trial

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Outlook for dependable use in a very small business   This article is about using the Outlook application (part of Microsoft Office) in a very small business, or for homeowners where dependability and reliability are critical requirements. This …
Check out this step-by-step guide for using the newly updated Experts Exchange mobile app—released on May 30.
To show how to create a transport rule in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Rules tab.:  To cr…
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…
Suggested Courses

715 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question