Solved

Help understanding PiX 506 running config - 500 points for quick anwser

Posted on 2008-10-08
2
367 Views
Last Modified: 2008-10-08
Good Morning experts

The company I work are changing their ISP which means I need to reconfigure our PIX 506 firewall I am complete novice with firewalls but I have knowledge of network, Cisco router and switches.

I need help understanding the running config of our Pix the print out is listed below.

I take it that when we change ISP our external IP address will change and this will need to be reflexed in the firewall configuration ?

1.) ip address outside 212.115.52.52 255.255.255.248 "This is our ISP IP number"
     ip address inside 10.44.0.254 255.255.255.0 "This is our internal network number"

2.) "What does this line mean" -  ip local pool pool2 10.44.0.181-10.44.0.187

3.) "What does this line mean" - global (outside) 1 212.115.52.53

4.) "What does this line mean" - - nat (inside) 1 10.0.0.0 255.0.0.0 0 0
 and why would it have asub net mask  of 255.0.0.0 when our internal address range has a subnet mask of 255.255.255.0

5.) What does this line mean 10.44.0.199 is our smtp\spam filter - - static (inside,outside) 212.115.52.54 10.44.0.199 netmask 255.255.255.255 0 0
 
6.) What do these line mean - 10.44.3.0 and 10.44.5.0 are satalite office connected via a WAN
access-group mail in interface outside
route outside 0.0.0.0 0.0.0.0 212.115.52.49 1
route inside 10.44.3.0 255.255.255.0 10.44.0.253 1
route inside 10.44.5.0 255.255.255.0 10.44.0.253 1

7.) What does "access-list mail permit tcp any host 212.115.52.54 eq smtp" mean

8.) any info on the rest of the config I know part of it is for VPN but we don't use that anymore..



PIX Version 6.1(4)
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password lDQ1e86P2tr0BHxt encrypted
passwd B0xTh6IPomovnN3d encrypted
hostname manorpark
domain-name wisemanlee.co.uk
fixup protocol ftp 21
fixup protocol http 80
fixup protocol smtp 25
no fixup protocol h323 1720
no fixup protocol rsh 514
no fixup protocol rtsp 554
no fixup protocol sqlnet 1521
no fixup protocol sip 5060
no fixup protocol skinny 2000
names
access-list mail permit tcp any host 212.115.52.54 eq smtp
pager lines 24
logging on
logging buffered errors
logging trap notifications
interface ethernet0 auto
interface ethernet1 auto
mtu outside 1500
mtu inside 1500
ip address outside 212.115.52.52 255.255.255.248
ip address inside 10.44.0.254 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool pool2 10.44.0.181-10.44.0.187
no pdm history enable
arp timeout 14400
global (outside) 1 212.115.52.53
nat (inside) 1 10.0.0.0 255.0.0.0 0 0
static (inside,outside) 212.115.52.54 10.44.0.199 netmask 255.255.255.255 0 0
access-group mail in interface outside
route outside 0.0.0.0 0.0.0.0 212.115.52.49 1
route inside 10.44.3.0 255.255.255.0 10.44.0.253 1
route inside 10.44.5.0 255.255.255.0 10.44.0.253 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h323 0:05:00 si
p 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
sysopt ipsec pl-compatible
no sysopt route dnat
crypto ipsec transform-set myset esp-des esp-md5-hmac
crypto dynamic-map cisco 1 set transform-set myset
crypto map dyn-map 20 ipsec-isakmp dynamic cisco
crypto map dyn-map interface outside
isakmp enable outside
isakmp key ******** address 0.0.0.0 netmask 0.0.0.0
isakmp identity address
isakmp policy 1 authentication pre-share
isakmp policy 1 encryption des
isakmp policy 1 hash md5
isakmp policy 1 group 2
isakmp policy 1 lifetime 50400
vpngroup wisevpn address-pool pool2
vpngroup wisevpn dns-server 10.44.0.199
vpngroup wisevpn wins-server 10.44.0.199
vpngroup wisevpn default-domain wisemanlee.co.uk
vpngroup wisevpn idle-time 1800
vpngroup wisevpn password ********
telnet 10.44.0.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
terminal width 80
Cryptochecksum:a25b67d9fb8617260ae6b546472f2dd9
manorpark#
0
Comment
Question by:ise438
2 Comments
 
LVL 3

Accepted Solution

by:
callyp earned 500 total points
ID: 22667519
1. you just need to replace existing IP's with new IP's. take backup of config and replace.
2. This is you local LAN IP range pool used for vpn
3.  Any LAN IP will be translated to this IP while going outside (to internet)
4. Translate internal LAN IP address. you can change it to that, just someone has allowed as it in class A
5. Internet SMTP server IP translated (NAT) to public IP. static nat.
6. Router to outside and branch offices to inside while connecting to LAN.
7. Rule to allow SMTP port 25 to that IP.
8. if not using then just disable isakmp, later can again be enabled if reuqired. keep configs.
 
0
 

Author Comment

by:ise438
ID: 22667756
Fantastic reply
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Suggested Solutions

I recently updated from an old PIX platform to the new ASA platform.  While upgrading, I was tremendously confused about how the VPN and AnyConnect licensing works.  It turns out that the ASA has 3 different VPN licensing schemes. "site-to-site" …
Quality of Service (QoS) options are nearly endless when it comes to networks today. This article is merely one example of how it can be handled in a hub-n-spoke design using a 3-tier configuration.
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now