Solved

Loss of laptop <fn> key for volume -- a puzzlement

Posted on 2008-10-08
10
2,911 Views
Last Modified: 2013-12-09
My WinXP-sp2 Acer Aspire 5550's <fn> hotkey for volume adjustment and mute were working fine until just recently.  This post highlights my attempts to fix it, but in the end my only recourse is to create a desktop shortcut to sndvol32.exe with a hotkey of <ctl>+<alt>+V to bring up the Realtek volume control property box.  I could also use the Vol control next to the clock, but sometimes it's hidden by full-screen apps.

The <fn> hotkey works fine with all other keys (screen brightness, etc.)  I have upgraded all drivers to their latest versions using DriverMax.  I notice that <fn> still works for screen brightness in a booted Dos or Bart PE environment.  My v1.06 Phoenix Tech. BIOS has no settings for hotkeys.  Nor do the Sound tabs in Control Panel.

I have System Restored back a month to no avail.  I have created a 2nd OS partition and loaded the original WinXP C-drive from 2006 using PQ Drive Image 7.0  No <fn> + Sound functionality, and adjusting screen brightness works fine.  *** Now then, if this environment with its original drivers and registry doesn't hack it, then it must be hardware- or BIOS-related, right? ***

As a basis of comparison, my wife's Aspire 5580 is working fine in the <fn> dept.  But, her <fn> + Sound also does not function in the Dos or Bart PE environments.  Her keyboard driver is the Acer version using dkbfltr.sys  My keyboard driver is the standard Microsoft driver for 102-keyboards.

I exported her keyboard driver using DriverMax and imported it to my Aspire 5550.  Still no <fn> + Sound.  The fact that <fn> works with everything else, and that three (3) sound-related keys don't work does not point to sticky keys, IMHO.

I don't relish reflashing the BIOS...

Anyone have a bright idea?

===== SYSTEM SUMMARY ======

OS Name      Microsoft Windows XP Professional
Version      5.1.2600 Service Pack 2 Build 2600
OS Manufacturer      Microsoft Corporation
System Name      DBUSHNELL
System Manufacturer      Acer
System Model      Aspire 5550
System Type      X86-based PC
Processor      x86 Family 6 Model 14 Stepping 8 GenuineIntel ~1662 Mhz
Processor      x86 Family 6 Model 14 Stepping 8 GenuineIntel ~1662 Mhz
BIOS Version/Date      Phoenix Technologies LTD V1.06, 6/19/2006
SMBIOS Version      2.4
Windows Directory      C:\WINDOWS
System Directory      C:\WINDOWS\system32
Boot Device      \Device\HarddiskVolume1
Locale      United States
Hardware Abstraction Layer      Version = "5.1.2600.2765 (xpsp.050928-1517)"
User Name      DBUSHNELL\DBushnell
Time Zone      SE Asia Standard Time
Total Physical Memory      512.00 MB
Available Physical Memory      172.47 MB
Total Virtual Memory      2.00 GB
Available Virtual Memory      1.96 GB
Page File Space      1.20 GB
Page File      C:\pagefile.sys
==========================
0
Comment
Question by:DaveUdon
  • 5
  • 2
10 Comments
 
LVL 31

Expert Comment

by:rid
ID: 22667956
What key is used in conjunction with the Fn key for sound volume? Does it work as it should, when not used with Fn?
/RID
0
 

Author Comment

by:DaveUdon
ID: 22668394
Good point, Rid, thanks.  It's something I should have mentioned.  The Sound Adjustment is <fn> + up/down arrow keys, and yes, they work as they should without <fn>.  The mute is PF8, and that works fine to enter Safe Mode at bootup.
0
 

Author Comment

by:DaveUdon
ID: 22668987
I just restored my wife's C-drive from her Aspire 5580 to a 2nd OS partition on my Aspire 5550 using PQ Drive Image 7.0 (bit-image restore).  It booted ok, then went crazy with all the new hardware found, running around trying to find drivers.

MP3's played immediately, however, and the keyboard of course was fine.  Still no <fn> + Sound capability, but all other <fn> functions worked.  Next, I'll restore my 5550 C-drive to a 2nd OS partition on her 5580 and see what happens.  I'll report the results back here.
0
Do You Know the 4 Main Threat Actor Types?

Do you know the main threat actor types? Most attackers fall into one of four categories, each with their own favored tactics, techniques, and procedures.

 
LVL 31

Accepted Solution

by:
rid earned 250 total points
ID: 22669120
The Fn + [someother_key] arrangement differs in function from maker to maker and sometimes from model to model. Many use hardware calls to implement whatever these keys are supposed to adjust, and in those cases the functionality is present even when in BIOS setup; others use drivers to create the "shortcuts". Your model isn't known to me. You could try safe mode or by booting with a live CD (e.g. Knoppix or Ubuntu) and see what, if any, shortcuts work. If all but sound work in a different environment, a hardware problem may be suspected; if none works they need drivers and you will have to use windows and further testing may be required.

Have you installed anything at all (software, hardware) before the problem occurred? Any sort of update that has taken place?
/RID
0
 

Author Comment

by:DaveUdon
ID: 22669971
Rid, thanks for your comments.  Trying Ubuntu is a good idea, but the last time I played with it, I couldn't get any sound out, and I lacked the patience to make it work by adding drivers... Windows it is.

On both Aspire models, I booted into Dos; I went into the BIOS, then Safe Mode, then the Welcome screen (account-choice).  In all four areas on both laptops, <fn> worked fine on all non-Sound keys.  No <fn> + Sound.

On the "good" 5580 laptop, the <fn> + PF8 (mute)/Up-Down Arrow keys (volume) commence working immediately after the Welcome screen, just as the desktop appears.

Therefore, one might surmise that the Fn+Sound feature is driver-related (and that I could have a hardware problem).

If the feature is driver-related, then restoring the dealer's original Windows-install in a 2nd OS window should have worked, right?  It certainly worked back then, right up to this month or last.

Tomorrow morning, I'll try restoring a few more oldie-but-goodie backups on my machine, and I'll also try loading my C-drive to my wife's 5580 in an OS partition.  If you're not thrilled about that idea because of device-driver problems, I'll first backup her drivers using DriverMax, and then load them over my C-drive restore.

Your question about recent software/hardware changes is well taken, but I'm constantly installing stuff and then removing it later.  I do make lots of backups to offset my blunders.  Also I'm constantly cleaning the registry with Registry Fix and Registry Cleaner.  With backups going back two years, however, and the ability to browse and mount Drive Image backups, I feel that I have things under control.

Let's see what happens with some more testing tomorrow.  You've come up with some good ideas, and I appreciate them.

My conclusion for now: I have a hardware problem...
0
 

Author Comment

by:DaveUdon
ID: 22679655
Ok, I restored a "bad" laptop's C-drive backup from a few months ago to my wife's "good" laptop in a 2nd OS partition.  The instant the desktop appeared (after the Welcome screen), the <fn> + Sound keys worked.  The searching for new drivers quickly settled down, and everything appeared to be working, including of course, the fn-sound keys.

Now then, for a final check, I'm in the process of restoring that same backup to my own "bad" laptop in a 2nd OS partition.

Just a thought: it appears that my wife's "good" laptop waits until a Windows desktop is displayed before allowing the fn-sound keys to work.  Otherwise, they don't... not in Dos, nor the BIOS, nor Safe Mode, not the Welcome screen.

But what about Ubcd4Win (Bart PE) with the sound card operating?  Just curious, but would it work then?  I have to give it a shot and report back.

In the end, it's looking more and more like a hardware fault in my laptop.
0
 

Author Comment

by:DaveUdon
ID: 22685401
I restored the C-drive backup which worked successfully on my wife's "good" laptop -- into a 2nd OS partition on my "bad" laptop.  No <fn> + Sound keys.  All other Fn keys worked.

As to my curiosity about whether my wife's <fn> + Sound keys would work in a pre-installed environment like Ubcd4Win (Bart PE)... I booted it up, but the <fn> + Sound keys didn't work.  I tried executing <systemroot>\system32\sndvol32.exe, but it told me that a mixer device wasn't installed.

Ok -- enough.  It looks like I have a hardware problem with the <fn> + Sound keys.  I can live with it.

Thanks for your interest...
0

Featured Post

Do You Know the 4 Main Threat Actor Types?

Do you know the main threat actor types? Most attackers fall into one of four categories, each with their own favored tactics, techniques, and procedures.

Join & Write a Comment

SCOPE I WILL CONCENTRATE ON LCD SCREEN INVERTOR , CCFL BULB PROBLEMS.   The old question "My laptop screen is black what can it be ?". POSSIBLE PROBLEMS ARE.  1. INVERTER BOARD IS BAD.  2. CCFL BULB IN LCD SCREEN IS BAD.  3. NO VIDEO TO T…
I originally posted this Article Here (http://www.bestelectronicarticles.com/computers/software-troubleshooting/how-to-find-a-driver-for-you-devices-in-windows.html) and thought I would now share with the Experts Exchange community. Driver Proble…
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

9 Experts available now in Live!

Get 1:1 Help Now