Enable Exchange Search for single mailbox

I have enabled exchange search for my mailbox database (shell cmd Get-MailboxDatabase |select name, indexenabled returns IndexEnabled=True)
But for some reason there is one mailbox which dont have this enabled (Test-ExchangeSearch <mailbox name> returns ResultFound=False, and SearchTime=-1, where other users returns: ResultFound=True, and SearchTime=8)

I didnt manage to find any command which can enable Exchange Search on a single mailbox, can anybody help me?

Thanks in advance :)
Who is Participating?
skarumConnect With a Mentor Author Commented:
I created a case with MS, and ended up exporting content, and recreating the mailbox  
the indexing  is configured at the database level, is possible the index got corrupted but its kinda odd that only 1 mbx is affected.

you can stop the service and delete the catalog folder and restart the service which will reindex the database.

you can look at this as well
skarumAuthor Commented:
Found out that our server was lacking SP1 and future updates, so Ill try this first and see if this solves the issue. Else Ill try your suggestion ATIG.
Thanks for your reply anyway >)
skarumAuthor Commented:
Updating the server didnt help, so Ill run a
ResetSearchIndex -Force -All tonight to rebuild the search index
so the steps to fix an index would be
--if you look at the script is manually does the steps below :)

1. stop the Microsoft Exchange Search Indexer service
2. Delete the catalog folder
3. Start the service backup
--this will remove the old/corrupted index and build a new one

you can double check you have indexing enabled

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.