Solved

Terminal emulation under Solaris 10 x64 - how do you set your term when connecting via PC Cygwin?

Posted on 2008-10-08
7
2,102 Views
Last Modified: 2013-12-27
I experience terminal emulation issues when connecting to Solaris (I use the same tools to connect to Linux and have never had a problem). For example, vi acts erratically when the term is set to cygwin or vt100. What do others do to solve this, and do you have to add terminfo for those cases (vt100, cygwin)? If so, where are you getting the terminfo?

Any pointers would be helpful. I use bash on Solaris 10 x64 (sunfire x4240) and have exported the TERM variable as both cygwin (which is default when using cygwin ssh to connect) and vt100. For example, in vi, the delete key changes case (in other words, it's mapped as ~). I'd love to have more control and understanding on these emulation issues. I connect with both XP and Vista and see the same issues (cygwin shell with cygwin ssh, and command shell with cygwin ssh).
SunOS mymachine 5.10 Generic_137112-02 i86pc i386 i86pc
~ >echo $TERM
vt100
~ >

Open in new window

0
Comment
Question by:rzup
  • 4
  • 3
7 Comments
 
LVL 40

Assisted Solution

by:omarfarid
omarfarid earned 200 total points
ID: 22670181
Before telnet or ssh to the solaris system, from cygwin terminal set TERM to vt100

then telnet or ssh to solaris

0
 
LVL 1

Author Comment

by:rzup
ID: 22670452
Tried it (setting vt100 locally first), no improvement. If I go to the top of the file and move the cursor right (using 'l') the first line works, if I move down to the next line and move right characters become garbled..
0
 
LVL 40

Expert Comment

by:omarfarid
ID: 22670521
can  you run stty on both and compare?

after login, if you

echo $TERM

what do you see?
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
LVL 1

Author Comment

by:rzup
ID: 22670634
Localmachine:

localmachine ~
$ export TERM=vt100

localmachine ~
$ stty
speed 38400 baud; line = 0;
-imaxbel
-echoe -echok -echoctl -echoke

Then I connect to the server:

localmachine ~
$ ssh mymachine

Welcome to mymachine
~ >echo $TERM
vt100
~ >stty
speed 38400 baud; -parity
rows = 25; columns = 80; ypixels = 291; xpixels = 164;
erase = ^h; eol = -^?; eol2 = -^?; swtch = ;
brkint -inpck -istrip icrnl -ixany onlcr tab3
echo -echoe -echok iexten
~ >
0
 
LVL 40

Expert Comment

by:omarfarid
ID: 22670819
can you run

stty -a

on both and compare characteristics ?
0
 
LVL 1

Author Comment

by:rzup
ID: 22670844
Local CP (Cygwin shell same as previous:
$ stty -a
speed 38400 baud; rows 25; columns 80; line = 0;
intr = ^C; quit = ^\; erase = ^H; kill = ^U; eof = ^D; eol = <undef>;
eol2 = <undef>; swtch = ^Z; start = ^Q; stop = ^S; susp = ^Z; rprnt = ^R;
werase = ^W; lnext = ^V; flush = ^O; min = 1; time = 0;
-parenb -parodd cs8 -hupcl -cstopb cread -clocal -crtscts
-ignbrk brkint -ignpar -parmrk -inpck -istrip -inlcr -igncr icrnl ixon -ixoff
-iuclc -ixany -imaxbel
opost -olcuc -ocrnl onlcr -onocr -onlret -ofill -ofdel nl0 cr0 tab0 bs0 vt0 ff0
isig icanon iexten echo -echoe -echok -echonl -noflsh -tostop -echoctl -echoke
 
Server (connected with ssh from the above cygwin shell):

~ >echo vt100
vt100
~ >stty -a
speed 38400 baud;
rows = 25; columns = 80; ypixels = 241; xpixels = 164;
csdata ?
eucw 1:0:0:0, scrw 1:0:0:0
intr = ^c; quit = ^\; erase = ^h; kill = ^u;
eof = ^d; eol = -^?; eol2 = -^?; swtch = <undef>;
start = ^q; stop = ^s; susp = ^z; dsusp = ^y;
rprnt = ^r; flush = ^o; werase = ^w; lnext = ^v;
-parenb -parodd cs8 -cstopb -hupcl cread -clocal -loblk -crtscts -crtsxoff -pare
xt
-ignbrk brkint -ignpar -parmrk -inpck -istrip -inlcr -igncr icrnl -iuclc
ixon -ixany -ixoff -imaxbel
isig icanon -xcase echo -echoe -echok -echonl -noflsh
-tostop -echoctl -echoprt -echoke -defecho -flusho -pendin iexten
opost -olcuc onlcr -ocrnl -onocr -onlret -ofill -ofdel tab3
~ > 
 
 
 
 
 
 
 
 
 
 
 
0
 
LVL 1

Accepted Solution

by:
rzup earned 0 total points
ID: 22673621
It turns out that one easy way to fix this is to install vim and use it instead. It allows for the delete key to be remapped, also.
0

Featured Post

Networking for the Cloud Era

Join Microsoft and Riverbed for a discussion and demonstration of enhancements to SteelConnect:
-One-click orchestration and cloud connectivity in Azure environments
-Tight integration of SD-WAN and WAN optimization capabilities
-Scalability and resiliency equal to a data center

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When you do backups in the Solaris Operating System, the file system must be inactive. Otherwise, the output may be inconsistent. A file system is inactive when it's unmounted or it's write-locked by the operating system. Although the fssnap utility…
Introduction Regular patching is part of a system administrator's tasks. However, many patches require that the system be in single-user mode before they can be installed. A cluster patch in particular can take quite a while to apply if the machine…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
This video shows how to set up a shell script to accept a positional parameter when called, pass that to a SQL script, accept the output from the statement back and then manipulate it in the Shell.

808 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question