?
Solved

Crystal Report working in creator, but not on intranet

Posted on 2008-10-08
9
Medium Priority
?
698 Views
Last Modified: 2013-12-19
I have created a crystal report using an Oracle database that works fine when I run it from Crystal Reports itself, but when I install it on Crystal Reports Server 2008 it fails with an error (see below) when opened on the intranet.

A search on google has a few people recommending the report be rewritten to solve the problem but this has not help in my case. All other reports on the intranet are working normally.

The error is ;
Error in File C:\DOCUME~1\Reports\LOCALS~1\Temp\{F945D63E-F27B-4E01-8846-92E865E79978}.rpt: The request could not be submitted for background processing.
webReporting.dll error '800002ad'
Error in File C:\DOCUME~1\Reports\LOCALS~1\Temp\{F945D63E-F27B-4E01-8846-92E865E79978}.rpt: The request could not be submitted for background processing.
/rassamples/en/asp/rPortfolio/HTMLViewers/interactiveViewer.asp, line 31

In case it is useful the SQL used in the report is listed below in case it is a wierd join causing the problem;

SELECT "TABLE_ACT_ENTRY"."ENTRY_TIME", "TABLE_CASE"."ID_NUMBER", "TABLE_GBST_ELM"."TITLE", "TABLE_NOTES_LOG"."INTERNAL", "TABLE_PHONE_LOG"."INTERNAL", "TABLE_RESRCH_LOG"."INTERNAL", "TABLE_CLOSE_CASE"."SUMMARY", "TABLE_ACT_ENTRY"."ADDNL_INFO", "TABLE_CASE"."TITLE", "TABLE_USER"."S_LOGIN_NAME", "TABLE_NOTES_LOG"."DESCRIPTION", "TABLE_PHONE_LOG"."NOTES", "TABLE_RESRCH_LOG"."NOTES"
FROM   "SA"."TABLE_CLOSE_CASE" "TABLE_CLOSE_CASE", "SA"."TABLE_ACT_ENTRY" "TABLE_ACT_ENTRY", "SA"."TABLE_USER" "TABLE_USER", "SA"."TABLE_CASE" "TABLE_CASE", "SA"."TABLE_NOTES_LOG" "TABLE_NOTES_LOG", "SA"."TABLE_RESRCH_LOG" "TABLE_RESRCH_LOG", "SA"."TABLE_PHONE_LOG" "TABLE_PHONE_LOG", "SA"."TABLE_GBST_ELM" "TABLE_GBST_ELM"
 WHERE  ("TABLE_ACT_ENTRY"."ACT_ENTRY2USER"="TABLE_USER"."OBJID" (+)) AND ("TABLE_ACT_ENTRY"."ACT_ENTRY2CASE"="TABLE_CASE"."OBJID" (+)) AND ("TABLE_ACT_ENTRY"."ACT_ENTRY2NOTES_LOG"="TABLE_NOTES_LOG"."OBJID" (+)) AND ("TABLE_ACT_ENTRY"."ACT_ENTRY2RESRCH_LOG"="TABLE_RESRCH_LOG"."OBJID" (+)) AND ("TABLE_ACT_ENTRY"."ACT_ENTRY2PHONE_LOG"="TABLE_PHONE_LOG"."OBJID" (+)) AND ("TABLE_ACT_ENTRY"."ENTRY_NAME2GBST_ELM"="TABLE_GBST_ELM"."OBJID") AND ("TABLE_CLOSE_CASE"."LAST_CLOSE2CASE" (+)="TABLE_CASE"."OBJID") AND ("TABLE_ACT_ENTRY"."ENTRY_TIME">=TO_DATE ('06-10-2008 00:00:00', 'DD-MM-YYYY HH24:MI:SS') AND "TABLE_ACT_ENTRY"."ENTRY_TIME"<TO_DATE ('07-10-2008 00:00:00', 'DD-MM-YYYY HH24:MI:SS')) AND "TABLE_USER"."S_LOGIN_NAME"='SJRYAN'

Open in new window

0
Comment
Question by:Gryff
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
9 Comments
 
LVL 101

Expert Comment

by:mlmcc
ID: 22670354
Do you have other reports that work in CR Server?

mlmcc
0
 

Author Comment

by:Gryff
ID: 22670404
Yes, I have written a number of reports using the same database and loaded them on the same CR server without issue. This particular report is only unusual in the amount of tables joined together, and even that I wouldn't consider particularly large.
0
 

Author Comment

by:Gryff
ID: 22678542
Sorry, I have made a mistake in the OP. It is not running on Crystal server 2008 (I just clicked help for a version number and didn't notice it just opened the Main crystal webpage) it is in fact running on ePortfolio Lite.

I have also created a second report that exhibits the same behaviour. I remember of both of these reports I intially got an error indicateing I have multiple starting points but I believed I had resolved them. I certainly don't get the error anymore while working on them.
0
Get your Conversational Ransomware Defense e‑book

This e-book gives you an insight into the ransomware threat and reviews the fundamentals of top-notch ransomware preparedness and recovery. To help you protect yourself and your organization. The initial infection may be inevitable, so the best protection is to be fully prepared.

 

Author Comment

by:Gryff
ID: 22679089
Neither of these reports have sub-reports in them so I don't think that would be the cause, but I will download the hotfix and see if it does anything.

I think it may have something to do with the joins on these reports, but I can't see what.
0
 

Author Comment

by:Gryff
ID: 22679602
We have just had another report of this error, but this time happening on a Crystal Report we have had up and running for some months now. So I guess it is looking like something has happened/changed on the eportfolio server.
0
 

Accepted Solution

by:
Gryff earned 0 total points
ID: 22701487
I have managed to resolve this.

All it turned out to be was a case sensitivity issue with the DSN name. Crystal doesn't appear to care about the case when referring to a DSN, but the webapp that displays the report in our intranet fails over with this error if the case is wrong (initial capital letter in this case)
0
 
LVL 101

Expert Comment

by:mlmcc
ID: 22702298
Interesying.  I wouldn't have thought of that.

Click the DELETE QUESTION link in the question block and follow the prompts to accept your last comment aas the answer.

mlmcc
0
 
LVL 101

Expert Comment

by:mlmcc
ID: 22702307
Interesting.  I wouldn't have thought of that.

Click the DELETE QUESTION link in the question block and follow the prompts to accept your last comment as the answer.

mlmcc
0

Featured Post

Want to be a Web Developer? Get Certified Today!

Enroll in the Certified Web Development Professional course package to learn HTML, Javascript, and PHP. Build a solid foundation to work toward your dream job!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article started out as an Experts-Exchange question, which then grew into a quick tip to go along with an IOUG presentation for the Collaborate confernce and then later grew again into a full blown article with expanded functionality and legacy…
Checking the Alert Log in AWS RDS Oracle can be a pain through their user interface.  I made a script to download the Alert Log, look for errors, and email me the trace files.  In this article I'll describe what I did and share my script.
Via a live example, show how to restore a database from backup after a simulated disk failure using RMAN.
This video explains what a user managed backup is and shows how to take one, providing a couple of simple example scripts.
Suggested Courses

801 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question