Solved

Destination Net Unreachable

Posted on 2008-10-08
12
2,366 Views
Last Modified: 2013-11-15
Good Morning,

This question has been asked and I have searched through most of the postings, but unfortunitly i have not found the solution so that is why I am posting this message.

The company I work for has quite a few locations, and every few weeks some of our satilite locations, get a Destination Host Unreachable when they try to ping a particular PC on our network.

We are running Linux, Ubuntu to be exact.

Example: One of our servers in location A is setup with a ip address of 192.168.15.2. They can ping every PC/Server in subnet 192.168.27.X except our terminal server which is 192.168.27.76. When they try to ping it they get this:
PING Hydra3.Domain (192.168.27.76) 56(84) bytes of data.
192.168.30.1: destination net unreachable
192.168.30.1: destination net unreachable

The wierd thing is that this clears up within 24 hours.

I talked to a friend and he suggested I look at the routing table, but everything looks ok.

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.19.0    *               255.255.255.0   U     0      0        0 eth1
link-local      *               255.255.0.0     U     1000   0        0 eth1
default         192.168.19.1    0.0.0.0         UG    100    0        0 eth1

Any help would be greatly appreciated, unfortunitly because this is an intermittent problem, it is hard to troubleshoot, since it is working right now.
0
Comment
Question by:philtukey
  • 6
  • 3
12 Comments
 
LVL 39

Expert Comment

by:noci
ID: 22672999
PING Hydra3.Domain (192.168.27.76) 56(84) bytes of data.
192.168.30.1: destination net unreachable

You need to look at a lot of routing tables.....
on this system (appearantly has an address in 192.168.19.??, from 2-254).
What btw is the translation of link-local.. at it's netmask is rather large.
netstat -rn would tell you the real address.  (doesn't look like 192.168.15...)
But ok.

From system x (192.168.15.2) sends to the next HOP (depending on routing tables) if link local != 192.168.0.0 => the next hop is some 192.168.15.1? system
that will forward to ??? to 192.168.30.1 which tells you that it cant reach the network containing 192.168.27.76.

Now you have to look on 192.168.30.1 at the routing tables to find out what it will do with packets being sent to 192.168.27.???
Also look at the NAT translations that may heppen on the road.

First draw yourself a picture of your net and what route you would have expected it to take.
An aid here might be traceroute as that will should you how routing is done at the individual nodes. If possible to get tcptraceroute than use that with the right portnumber for your terminal service than the packets would even take the right route if some NAT is involved.
0
 
LVL 1

Author Comment

by:philtukey
ID: 22673075
My apologies, I accidently listed the netstat for the wrong server. Here is the correct netstat -rn for the 15.X server in question.

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.15.0    *               255.255.255.0   U     0      0        0 eth1
link-local      *               255.255.0.0     U     1000   0        0 eth1
default         192.168.15.1    0.0.0.0         UG    100    0        0 eth1
0
 
LVL 1

Author Comment

by:philtukey
ID: 22673100
I am new at Linux so how would go look at 192.168.30.1 in the routing table? Apparently these servers do not have traceroute installed, how do I install that onto the linux servers? Where would I go to find NAT information?
0
 
LVL 39

Expert Comment

by:noci
ID: 22673227
I run gentoo myself but that only means the package manager is different, I thought apt-get was the tool for debian derived distro's.
'apt-get traceroute' maybe?
 
What you show is 'netstat -r'  which shows the default as default.
'netstat -rn' should show default as 0.0.0.0.
I hope that link-local actually is 169.254.0.0 (can be found in /etc/networks).
because you would have a rather "interesting" setup if it is 192.168.0.0...

And is logging on to 192.168.30.1 possible to try to investigate there what the routing looks like? netstat -rn from that system?
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 1

Author Comment

by:philtukey
ID: 22673281
I ran netstat -rn and that is what I got.

I will try to run 'apt-get traceroute'
0
 
LVL 1

Author Comment

by:philtukey
ID: 22673701
When I run apt-get traceroute and got E: Invalid operation traceroute.

Thanks,
0
 
LVL 1

Author Comment

by:philtukey
ID: 22673751
Here is a better log if what I recieved last night when I tried to ping 192.168.27.76 from 192.168.15.2
4 packets transmitted, 3 received, 25% packet loss, time 3006ms
rtt min/avg/max/mdev = 220.843/512.429/796.577/235.102 ms
root@ziserv:~# ping 192.168.27.76
PING 192.168.27.76 (192.168.27.76) 56(84) bytes of data.
From 192.168.30.1 icmp_seq=3 Destination Net Unreachable
From 192.168.30.1 icmp_seq=4 Destination Net Unreachable
From 192.168.30.1 icmp_seq=6 Destination Net Unreachable
From 192.168.30.1 icmp_seq=7 Destination Net Unreachable
From 192.168.30.1 icmp_seq=8 Destination Net Unreachable
From 192.168.30.1 icmp_seq=9 Destination Net Unreachable

--- 192.168.27.76 ping statistics ---
9 packets transmitted, 0 received, +6 errors, 100% packet loss, time 8005ms

Thanks,

0
 
LVL 39

Accepted Solution

by:
noci earned 250 total points
ID: 22674198
'apt-get install tcptraceroute'
and
'apt-get install traceroute'
should do the trick according to quick look on the [k]ubuntu site.

It does mean that the system 192.168.30.1 doesn't known how to reach the
network 192.168.27.???
and the network is NOT locally connected to the 192.168.30.1 system either as it would return Destination Host unreachable.
so the network looks a bit like

You (...15.2 -> ...15.1 ==> 30.1 ??> 27.76)

Please investigate the 192.168.30.1 system for routing / connection troubles.
0
 
LVL 1

Author Comment

by:philtukey
ID: 22914019
The reason I left it open is because we are waiting for the problem to come back. It comes and goes randomly. So it is hard for me to troubleshoot it, when it working.
0

Featured Post

Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

Join & Write a Comment

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
After running Ubuntu some time, you will be asked to download updates for fixing bugs and security updates. All the packages you download replace the previous ones, except for the kernel, also called "linux-image". This is due to the fact that w…
Excel styles will make formatting consistent and let you apply and change formatting faster. In this tutorial, you'll learn how to use Excel's built-in styles, how to modify styles, and how to create your own. You'll also learn how to use your custo…
Illustrator's Shape Builder tool will let you combine shapes visually and interactively. This video shows the Mac version, but the tool works the same way in Windows. To follow along with this video, you can draw your own shapes or download the file…

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now