Solved

Can not RDP into Terminal Server

Posted on 2008-10-08
7
486 Views
Last Modified: 2013-12-04
I believe this started when I ran windows updates on October 03 but I am unsure so I don't want to blame that for the problem.

The problem being is that I am unable to Remote Desktop into our terminal server. I can ping the interface and I can Remote Desktop from the console of the box but it will not allow incoming sessions.

I have tried to restart multiple services, (i.e. Routing & Remote Access) but to no avail. Is there anything in particular that i should look for. I am not too familular with terminal servers.

Thanks.
0
Comment
Question by:respawn
  • 2
  • 2
  • 2
  • +1
7 Comments
 
LVL 8

Expert Comment

by:russell124
ID: 22671229
First thing, check that Remote access is enabled to the server.

Right-Click "My Computer", select "Properties" to open up the System Properties window.  Go to the "Remote" tab in System Properties, and make sure that the "Enable Remote Desktop on this Computer" option is enabled.

Make sure your account is either a domain admin, or a member of the Remote Desktop users, otherwise your session will be denied.

Make sure that the "Terminal Services" service is running as well.  You can check this in the Administrative tools, or by running "Services.msc".
0
 
LVL 8

Expert Comment

by:rjwesley
ID: 22671232
Things to check: the Remote Tab in System Properties, your firewall, the Terminal Services in the Services applet should be started, shouldn't be running but Windows Firewall. Terminal Server requires port 3389 by default.

Rob
0
 
LVL 9

Expert Comment

by:chingmd
ID: 22671365
If the last update included SP3, it has been indicated that it resets several things.  Once of them being Windows firewall.  

Re-enable remote desktop access.  

Check both of place indicated above.
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 

Author Comment

by:respawn
ID: 22674147
Alright so I check all those settings, I checked them before but I figured it won't hurt to check them again. So... Remote Desktop is enabled in the Remote Tab of System. The services labeled "Terminal Services" and "Terminal Services Licensing" are both started and I tried restarting them to ensure it wasn't anything buggy. I tried to go into Windows firewall but I get the message "Windows Firewall cannot run becuase another program or service is running that might use the network address translation component (ipnat.sys)." I am unsure what this means or how to deal with it. Do you think it might be related? I wanted to disable RRAS but I'd have to reconfigure it after and I'm not exactly comfortable doing that. Thanks.
ipnat-msg.png
0
 
LVL 8

Assisted Solution

by:russell124
russell124 earned 150 total points
ID: 22674265
Was the server configured to use RRAS as a firewall/router prior to the updates?

If so, you need to configure RRAS for Remote Desktop/Terminal Services, since it has taken over the firewall duties from the basic windows firewall.  
0
 
LVL 9

Assisted Solution

by:chingmd
chingmd earned 350 total points
ID: 22674297
From everything that I've seen so far.  RRAS and firewall cannot co exist on the same machine.

I did find this however:  http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/2003_Server/Q_22583488.html

0
 

Accepted Solution

by:
respawn earned 0 total points
ID: 22680502
Alright so the problerm looks solved and it looks like it had nothing to do with the updates. It did however have something to do with restarting the machine. Also it had nothing to do really with Windows Firewall. The solution was simple and I'm not entirely sure why it worked, I just know it did.

I went into Services.msc on the Terminal Server, I found the RRAS Service and through its properties I disabled it from starting when the machine is booted. I then restarted the server and let everything load. I tried to connect remotly and it worked just like it did before but I still needed RRAS for external employees to be able to register with the domain. So I went back into Services.msc and again through its properties I selected it to load automaticly and then started the services. RRAS came online and remote users were able to register with the domain as well I was able to keep the functionality of RDP and Terminal Connections.

Thank you all for your help and support.  
0

Featured Post

How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

Join & Write a Comment

SHARE your personal details only on a NEED to basis. Take CHARGE and SECURE your IDENTITY. How do I then PROTECT myself and stay in charge of my own Personal details (and) - MY own WAY...
Users of Windows 10 Professional can disable automatic reboots using the policy editor. This tool is not included in the Windows home edition. But don't worry! Follow the instructions below to install (a Win7) policy editor on your Windows 10 Home e…
It is a freely distributed piece of software for such tasks as photo retouching, image composition and image authoring. It works on many operating systems, in many languages.
This video demonstrates how to create an example email signature rule for a department in a company using CodeTwo Exchange Rules. The signature will be inserted beneath users' latest emails in conversations and will be displayed in users' Sent Items…

757 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now