Server 2008 IIS redirects http access to http://localhost/<sitename>

I installed fresh install of Server 2008 enterprise edition and SQL Server 2005 express edition. I installed IIS and .NET 3.0 features as those were not by default installed. I added DotNetNuke (uses ASP.NET) installation and configured IIS for this (opened IIS 7, the site appeared under Default Web Site, converted it to application). The virtual directory for this was, by default, set to be /dnn.

With thease settings, the DotNetNuke site opened nicely by typing http://dnn01/dnn on the server which was hosting the site. One notable thing, though, was the fact that the site redirected me to http://localhost/dnn. This naturally worked when using the server, but when I tried to access the site from another computer on the same domain, the http://dnn01/dnn redirected me again to http://localhost/dnn, which naturally was not working. If adding a regular html-site to IIS everything works fine. Do you have any idea what would solve the problem?

I alredy tried using bindings for the default web site, but at least with a few iterations could not find a way to fix the problem.

Thank you so much!
JaniHuttunenAsked:
Who is Participating?
 
JaniHuttunenConnect With a Mentor Author Commented:
Ok, found solution:

Need to add a second portal alias for the server name.

Under Admin -> Site Settings when logged in as host you will see Portal Aliases.  Click "Add HTTP Alias"  Then put in the server address. In this case dnn01/dnn.


0
 
loftywormConnect With a Mentor Commented:
Sounds like you are missing a config file in DotNetNuke that needs to be setup.  I would look at the install documentation for your app.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.