Solved

IIS 6.0 will not start getting error messages

Posted on 2008-10-08
7
795 Views
Last Modified: 2012-06-21
I am getting error messages in the event log.

A process serving application pool 'DefaultAppPool' reported a failure. The process id was '1340'.  The data field contains the error number.
 And 2268 event id. Could not load all ISAPI filters for site/service.  Therefore startup aborted.
Not sure what to do.  Tried restarting it. rebooting ,restarted the service.  Not sure what to do.  Please help.
 
0
Comment
Question by:kdschool
  • 2
  • 2
  • 2
  • +1
7 Comments
 
LVL 14

Accepted Solution

by:
dfxdeimos earned 100 total points
ID: 22671756
Are there any other even log entries, more specifically in the security log? When did this start happening? As a test try setting the DefaultAppPool to run under the DOMAIN\Administrator 's account.
0
 
LVL 18

Assisted Solution

by:sk_raja_raja
sk_raja_raja earned 200 total points
ID: 22671976
0
 
LVL 13

Assisted Solution

by:TechTiger007
TechTiger007 earned 200 total points
ID: 22671987
Did you install/uninstall any ISAPI filters? Check your site "site/service" in IIS manager goto ISAPI filters and check if all the dlls are there in the correct location. If there is any issues in the dlls you will get this error
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 

Author Comment

by:kdschool
ID: 22672743
The symantec folks were helping me intall back up exec recovery and after the re-boot the web server would not work any longer.  They are trying to figure out if the error messages that were in the log but have not gotten back with me.  Can you tell me where IIS stores the .dll files so I can see what is in that folder?
0
 
LVL 18

Assisted Solution

by:sk_raja_raja
sk_raja_raja earned 200 total points
ID: 22672795
0
 
LVL 13

Assisted Solution

by:TechTiger007
TechTiger007 earned 200 total points
ID: 22678867
Right click on the website in IIS and select properties.
In ISAPI tab under ISAPI filters select each entry and check if any one displays status as "Not Loaded" (mostly this entry will also display a red arrow in status column) Select the unloaded filter and click on edit button, a pop up window will display the name of the filter and location of the dll associated with the filter. Check if the dll is available in the specified path. If the filter is no longer needed you can remove it from the list.
Try restarting the IIS.
0
 

Author Comment

by:kdschool
ID: 22678976
I had a good back up that I created before installing the Symantec Products.  I restored the server from this back up and now the web server is fine.   I installed the back up exec recovery product, then did a reboot and that is when the errors occured.   I really need to identify what happened here so I can prevent it in the future.  Is there any way for me to tell or run some type of product that would help me figure out why this happened.  These two log events started showing up after the reboot the 2268 always first then the 2214 after that.  The 2214 is refering to the oracle web gate that allows me to use ldap for several secured folders.  I had tested that on Monday this week and it was fine with no problems so I am wondering if the symantec install caused all this??? Thank you so much for any help on this issue.  It was really scary when that site went down.

W3SVC-WP Event ID 2268 Could not load all ISAPI filters for site/service.  Therefore startup aborted.
W3SVC-WP Event ID 2214The HTTP Filter DLL C:\Program Files\NetPoint\Webgate\access\oblix\apps\webgate\bin\webgate.dll failed to load.  The data is the error..
0

Featured Post

Control application downtime with dependency maps

Visualize the interdependencies between application components better with Applications Manager's automated application discovery and dependency mapping feature. Resolve performance issues faster by quickly isolating problematic components.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Prologue It is often required to host multiple websites on a single instance of IIS, mostly in development environments instead of on production servers. I am sure it is not much a preferred solution on production servers but this is at least a pos…
On July 14th 2015, Windows Server 2003 will become End of Support, leaving hundreds of thousands of servers around the world that still run this 12 year old operating system vulnerable and potentially out of compliance in many organisations around t…
This is used to tweak the memory usage for your computer, it is used for servers more so than workstations but just be careful editing registry settings as it may cause irreversible results. I hold no responsibility for anything you do to the regist…
In this video I am going to show you how to back up and restore Office 365 mailboxes using CodeTwo Backup for Office 365. Learn more about the tool used in this video here: http://www.codetwo.com/backup-for-office-365/ (http://www.codetwo.com/ba…

864 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

25 Experts available now in Live!

Get 1:1 Help Now