Solved

Remote Access unavailable unless users logged on to domain locally

Posted on 2008-10-08
10
391 Views
Last Modified: 2013-11-21
I am unable to log on to my servers remotely using either RDP or Citrix/ICA unless a user is logged on to the domain locally, i.e. sitting at their desk.  Basically, when the last person leaves for the day until the first person logs in, I am unable to log in remotely using Remote Desktop or a Citrix ICA Client. BUT after someone logs in at their desk, I am able to connect using either method.  I can log on to my firewall and ping all the servers during the time that I am unable to connect to them.
The only changes have been an Exchange 2007 server added, an upgraded Citrix License console version, and an upgrade to our practice management software called Time Matters.  The exchange server hasn't been brought up yet in production but is running.
To me, it seems like there is something installed that is basically shutting down terminal services once the last user logs off.   I have rebooted everything including network equipment several times.  This happened with no change to hardware, software or configuration of the network.  Please send questions and hopefully an answer!
0
Comment
Question by:aaronfranko
  • 5
  • 4
10 Comments
 
LVL 18

Expert Comment

by:sk_raja_raja
Comment Utility
do you check for any event logs ???
0
 
LVL 18

Expert Comment

by:sk_raja_raja
Comment Utility
1.Does this happens in all the servers across domain ?
2.Do you have Terminal Services License server in place ?
0
 

Author Comment

by:aaronfranko
Comment Utility
raja - Yes, there is a terminal server license server in place.  It is set per user and has been in place for several years without a problem. I've checked the event logs and the only thing peculiar I found was that the Network Connections service was being sent a start control at the time the first person logged in at their desk.  I changed it and the NLA service to automatic and rebooted all the servers since this worked for someone else I found with a similar issue.  This didn't resolve the problem.  If you are looking for something else specifically in the event log, please let me know.  Also, yes this happens to both application servers for which I attempt to connect.
0
 
LVL 18

Expert Comment

by:sk_raja_raja
Comment Utility
I think this is something to do with the TS licenseing issue.....when somebody is logged in the domain the workstation you use is able to obtain the License, but when they logoff EOD it gets revoked....

I would say this is actually a weird issue, but can track down the culprit....i  am assuming you have tried to RDP from different dekstops and still you have same issue.....

Can you check for any event logs on your TS licensing server ?is it running on the DC ?
how many TS cal you have ?
did you try to rdp using mstsc /console?
0
The problems with reply email signatures

Do you wish that you could place an email signature under a reply? Well, unfortunately, you can't. That great Exchange/Office 365 signature you've created will just appear at the bottom of an email chain. What a pain! Is there really no way to solve this? Well, there might be...

 

Author Comment

by:aaronfranko
Comment Utility
I've tried RDP from several different desktops
The TS Licensing server is also on the DC
I have enough TS CALS -
since mstsc /console and remote desktop connection are the exact same thing, yes, I have used that method.  As I mentioned, I have also attempted connecting via Citrix ICA client with the same result.  

I think the TS licensing issue is a possibility but I also think that other alternatives should be explored.  If it were strictly a licensing issue, I wouldn't be able to log in at 4:30 then not at 6:30 from the same laptop when nobody else is logged in just because I am inside then outside the LAN.  This problem is being outside the LAN but it is not a firewall issue since it works sometimes and doesn't work at others.  

Thanks for your help so far.  Please let me know what else I can look at.
0
 

Author Comment

by:aaronfranko
Comment Utility
One more piece of information - I'm now noticing random disconnect/reconnect while I'm logged on to the server locally with RDP as administrator.  I'm logged in on the same laptop in a Citrix Session but no disconnects however Citrix has some session reliability that may be making this unnoticable.  
0
 

Author Comment

by:aaronfranko
Comment Utility
Yesterday night after the last person logged off and I was still logged in to the Citrix Desktop, I tried to open the Citrix Management console and got en error regarding cannot connect the RPC server or something like that and it was unable to discover the server I was on. Probably just coincidence but trying everythiing.  Could RPC problems have anything to do with it? If so, what can I do to fix it?  I will look for more specific info once I get logged back on this morning.
0
 

Accepted Solution

by:
aaronfranko earned 0 total points
Comment Utility
I finally fixed the problem.  It was an odd network problem with a NAT address causing problems.
0
 
LVL 18

Expert Comment

by:sk_raja_raja
Comment Utility
glad that you have fixed....can you please explain in detail about the the fix..
0

Featured Post

What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

Join & Write a Comment

#Citrix #POC #XenDesktop #vCenter #VMware #ESX
ADCs have gained traction within the last decade, largely due to increased demand for legacy load balancing appliances to handle more advanced application delivery requirements and improve application performance.
How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now