Windows 2003 Terminal Server Printer Problem

I am trying to get an HP Deskjet 6122 printer to work with Windows Terminal Server 2003. The printer is  local to the machine running Remote Desktop. I have tried attaching the printer USB and Parallel. In each case it sets up in terminal server and on the remote desktop, but all print jobs just shoot out a blank page. If I am not attached to the remote desktop, the printer prints correctly. This problem occurs regardless of which desktop it is attached to, (there are 25 terminals on the network and each have this model printer). Any computer trying to print to this using remote desktop have the same result. I would appreciate any help. Thank-you
bossiercomputersAsked:
Who is Participating?
 
lnkevinConnect With a Mentor Commented:
Correction:

C:\WINDOWS\system32\spool\drivers\w32x86\3\.....

Where ... is your driver and hpzeng07.exe happens to be my driver

K

0
 
lnkevinCommented:
Two things you need to print from remote desktop: drivers and session set up.

A. Connect to a printing session:
1. Click Start, point to All Programs, point to Accessories, point to Communications, and then click Remote Desktop Connection.
2. Click Options in the Remote Desktop Connection dialog box.
3. Click the Local Resources tab.
4. Click Printers in the Local Devices box.
5. Click Connect.

B. Install printer driver once you login the server.
1. Go to Printers and Faxes of the server
2. Click File
3. Click Server Properties
4. Click Drivers Tab
5. Click Add and follow the wizard to install driver on the server.

K
0
 
bossiercomputersAuthor Commented:
Thanks for the reply. I followed your instructions. The printer says it is installed correctly but I still get the same problem. All print requests from the remote desktop to the local printer just spit out a blank page. This is a very frustrating problem.
0
 
lnkevinCommented:
Here is what you should do:

Right click on My computer --> Properties --> Advanced--> Performance Settings button --> Data execution prevention (tab)--> Select the Turn on DEP for all programs and services except those I select: option > Click Add --> Browse C:\WINDOWS\system32\spool\drivers\w32x86\3\hpzeng07.exe --> Open --> Click Apply--> Click OK, and OK again.

K
0
 
bossiercomputersAuthor Commented:
Thank-You for this help! The printers work great now.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.