Solved

Cisco 851 Frame Relay configuration

Posted on 2008-10-08
4
817 Views
Last Modified: 2013-12-12
Hello,
Basically I just needed help to configure Frame relay on the WAN interface (FE4) on this cisco switch.

I'm pretty much clueless on how to configure frame relay on this device.

this is the information i got from the ISP

Details
=============
Circuit ID:         LXXXXX
Bandwidth:          1.5Mbps

WAN IP Address:     19x.xxx.xxx.109
WAN Subnet Mask:    255.255.255.252

Default Gateway:    19x.xxx.xxx.110
Primary DNS Server: 19x.xxx.xxx.58
Secondary DNS:      19x.xxx.xxx.3

LAN IP Addresses:   2xx.xxx.xxx.81 - 2xx.xxx.xxx.86
LAN Subnet Mask:    255.255.255.248



Local Access Details
====================
Provider:           Frame Relay
Leased Line #:      490-1087 / 490-1088
VLAN ID:            415


any help will be appreciated,

regards,
0
Comment
Question by:jazz250
  • 2
4 Comments
 
LVL 50

Expert Comment

by:Don Johnston
ID: 22674374
I'm making some assumptions external CSU, inverse arp, etc.), but here goes:

conf t

int s1/0 (or whatever interface is connected to the frame provider)

 encapsulation frame-relay

 ip address 19x.xxx.xxx.109 255.255.255.252

 no shut

ip route 0.0.0.0 19x.xxx.xxx.110

Open in new window

0
 
LVL 10

Accepted Solution

by:
kyleb84 earned 300 total points
ID: 22675798
Sorry, but you cannot configure Frame Relay on a Cisco 851, as this is an Ethernet router.

If your ISP has installed a Frame Relay router (Probably a higher grade Cisco router) and left you with an 851 and a spare Ethernet port out of the ISP's router than this is the default configuration of an 851

Router:

(Connect to it via the Serial cable supplied, use Hyperterminal if you wish, 9600-8-N-1)

Paste this in, and:
- Replace all the [INSERT HERE] tags i've put in there with relevant data
- Fix up the XXX's in the IP's i've put in there

Let me know how you go!

conf t

!

hostname [YOUR ROUTER NAME GOES HERE]

!

logging buffered 8192

no logging console

!

no aaa new-model

!

ip cef

no ip bootp server

ip domain name your.domain.here

ip ssh version 2

!

!

!

username [A USERNAME] privilege 15 password [PASSWORD]

!

!

interface FastEthernet0

 spanning-tree portfast

!

interface FastEthernet1

 spanning-tree portfast

!

interface FastEthernet2

 spanning-tree portfast

!

interface FastEthernet3

 spanning-tree portfast

!

interface FastEthernet4

 ip address 19X.X.X.109 255.255.255.252

 no shut

!

interface Vlan1

 ip address 2xx.xxx.xxx.81 255.255.255.248

 no shut

!

ip route 0.0.0.0 0.0.0.0 19X.X.X.110

!

no ip http server

no ip http secure-server

!

access-list 22 permit 2xx.xxx.xxx.80 0.0.0.7

!

no cdp run

!

control-plane

!

banner login ^C
 

***********************************************************************

* Access to this computer system is limited to authorised users only. *

* Unauthorised users may be subject to prosecution under the Crimes   *

*                       Act or State legislation                      *

*                                                                     *

* Please note, ALL CUSTOMER DETAILS are confidential and must         *

*                         not be disclosed.                           *

***********************************************************************

^C

!

line con 0

 no modem enable

 transport output all

line aux 0

 transport output all

line vty 0 2

 access-class 22 in

 exec-timeout 20 0

 login local

 transport input telnet

line vty 3 4

 exec-timeout 20 0

 login local

 transport input ssh

!

scheduler max-task-time 5000

end

Open in new window

0
 
LVL 10

Expert Comment

by:kyleb84
ID: 22675815
I should add:

Paste this in after the above one:

conf t
crypto key generate rsa
ip ssh version 2
end
wr me

You'll now have SSH access to it from the web, and the config will be saved.
0
 
LVL 23

Assisted Solution

by:Mysidia
Mysidia earned 200 total points
ID: 22855102
Frame relay is a serial technology, not a protocol built on or based on Ethernet.

To connect frame relay to your equipment you need a CSU/DSU with a serial interface,  or a router with a WIC that supports frame relay.

An 851 does not have any serial interfaces,  it has only ethernet interfaces.
And you cannot install a WIC in an 851.  
It is a fixed configuration router that you cannot add interfaces to.

If your  ISP/telco has provided you with a plain old ethernet port to access your frame "circuit" ,   then the configuration is just as with a normal Ethernet
connection.

You apply the ip address to the interface, or enable DHCP client (if the ISP equipment is serving your ip using DHCP).


However, you cannot just plug an  Ethernet cable into the smart jack and have it work.
i.e.  Ethernet interface to ethernet is ok...     Ethernet to T1/frame relay is not.

0

Featured Post

Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Balance MONTHLY bandwidth between 2 connections 4 33
ASYNC Bandwidth (cable modem) Theoretical Speed Limit 5 94
VPN and bonded ADSL 4 185
Model ES-601WS 5 131
Cable Modem Provisioning from DPoE compliant server  This Article is to support CMTS administrators to provide an overview of DOCSIS compliance configuration file, and to provision a cable modem located at customer place from a Back office serve…
Sometimes you have to pull out old tricks to get a new firewall to work… While we were installing a new Sonicwall at a customers site we found that sites they were able to visit before were not working.  It seemed random and we could not understa…
Learn how to create flexible layouts using relative units in CSS.  New relative units added in CSS3 include vw(viewports width), vh(viewports height), vmin(minimum of viewports height and width), and vmax (maximum of viewports height and width).
Many functions in Excel can make decisions. The most simple of these is the IF function: it returns a value depending on whether a condition you describe is true or false. Once you get the hang of using the IF function, you will find it easier to us…

920 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now