[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 236
  • Last Modified:

Exchange and DNS

Do I have to enter an external DNS server for exchange to use or should I us internal DNS?
0
Brent400
Asked:
Brent400
  • 3
  • 2
  • 2
1 Solution
 
NutrientMSCommented:
Internal.  Your exchange server needs to be able to see your Domain Controller.
0
 
NutrientMSCommented:
Sorry, to clarify that.  Your internal DNS server should have a forwarder set to your next-hop DNS server (ISP usually).  This is so all internal queries go to your Domain Controller and respond, and ones destined for external sites will be passed along to the external DNS server.
0
 
Exchange_GeekCommented:
Never, have your Exchange or as a matter of fact any one your internal server pointing to external DNS server - ONLY and ONLY your DNS should have forwarders set pointing to external DNS server.

Reason, your internal DNS might not have all the information in the world about DNS servers - this job gets done when you have external DNS set to respond to your queries - this is done by setting the ip address on the forwarders list.

:)
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
Brent400Author Commented:
That's what I thought and that's the way it is configured.
I guess the problem is more on the DNS server.

My forwarders are set to 198.6.1.1 and 198.6.1.2. These I believe are UU.net servers. Should I be setting them to somthing else or add a few more servers? Add my ISP's?
0
 
Brent400Author Commented:
The problem I'm really try to figure out is why I have a few domains that I have trouble recieving email from.
I tested an address using Smtpdiag and DNS was not resolving. I tried the Smtpdiag with the -d option and
I connected. The I tried the standard Smtpdiag with email address and /v option that failed before and it worked fine.

Did the DNS server cache the new IP from the -d option?





0
 
Exchange_GeekCommented:
Look, it is always best to have the ISP DNS server listed in the forwarders list.

Also, if you are fighting the problem why few domains do not get emails from your server / delay in receiving emails - i would recommend change the SMTP Connector scope to use smart host and NOT DNS.

When you are entering smart host entry specify the ip address of your ISP in [ ] brackets. Simple.
0
 
NutrientMSCommented:
That should only be an issue if you were trying to send to them yes?  If you were having issues receiving from them would mean that either their SMTP server was having issues connecting to your Exchange server on port 25, or if DNS is an issue, if you run an Anti-Spam filter that has Sender Address Verification running if would not be able to resolve the senders email address.

For some testing:
On your Exchange server, open command prompt
open nslookup
type: set type=mx
type: domain.com (obviously the domain you are having issues with)
check the result (google.com      MX preference = 10, mail exchanger = smtp1.google.com)
type: exit
type: telnet <nslookup result> 25
eg: telnet smtp1.google.com 25

See if the server responds.  If this all works, then outbound SMTP shouldn't be a problem.  If it doesn't, post the response of your NSLOOKUP.

Cheers.
0

Featured Post

Free recovery tool for Microsoft Active Directory

Veeam Explorer for Microsoft Active Directory provides fast and reliable object-level recovery for Active Directory from a single-pass, agentless backup or storage snapshot — without the need to restore an entire virtual machine or use third-party tools.

  • 3
  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now