• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1407
  • Last Modified:

Debian Etch - Postfix - mailname different from hostname - is this a problem?

We are installing a Debian Etch server with Postfix as the mail server. During the test all seams fine except sending emails to some servers. Sending to certain addresses it looks like the email has been sent but never arrives to the destination mailbox.

In the mail.log it sais : "...lnxsrv postfix/smtp[6065]: .......to=<tom@targetdomain.com.au>, relay=targetdomain.com.au[...]:25, delay=31072, delays...,dns=4.4.2, status =deferred (lost connection with targetdomain.com.au[202....] while receiving the initial server greeting)

In the mx record the server is office.clientdomain.com.au while the actual hostname of the server is lnxsrv, fqdn is lnxsrv.clientdomain.com.au. I have tried it with mailname set to lnxsrv and also with setting it to office, neither seam to resolve the issue.
The client can send email to servers not hooked up with postini service, but not to the one using postini spam/AV filtering service.

any clues?

TIA,

Tom
0
tom_szabo
Asked:
tom_szabo
  • 2
1 Solution
 
bevhostCommented:
Check that the Servers Name (HELO greeting it sends) is a name that can be looked up in the DNS.
Check that it resolves to your server.

Also check that the Reverse DNS for your server also has a matching A record pointing back to the Server.

See Section 2.1 of...
http://www.faqs.org/rfcs/rfc1912.html
0
 
bevhostCommented:
I once had a client who was sending emails from a .com.au email address from a computer that had a .co.nz server name and the IP address whois was owned by a japanese ISP.

He wondered why I was blocking his emails.

I used a package called policyd-weight to do this checking.
I imagine that postini does similar things.
0
 
Xyptilon2Commented:
Initiate a manual conversation with the receiving mailserver (MX record) using a telnet based program. Or if you can, enable conversation logging with a program like "recordio" to debug the issue.

Reverse DNS lookups are sometimes done as an anti-spam measure, if it doesn't match a match is flagged, or sometimes even blocked. To make this match with the IP in the header of the email, ask the manager of your IP range (not the DNS provider, although sometimes it's the same person) to setup a PTR record for your IP address mapping back to your FQDN.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now