Outlook RPC over HTTP fails to connect, even over LAN

I've followed all the normal troubleshooting methods, and it is definitely an issue with server configuration. I have ensured that SBS Cert is installed correctly, all my Outlook parameters are correct, the RPC Proxy is installed (as it is installed as a part of SBS) and I have confirmed and double checked the configuration. I have followed the guide to check all components and cannot find anything obsucre -

<a href="http://www.petri.co.il/configure_rpc_over_https_on_a_single_server.htm">http://www.petri.co.il/configure_rpc_over_https_on_a_single_server.htm</a>

I have also run the Exchange Server Remote Connectivity Analyzer - <a href="https://www.testexchangeconnectivity.com/">https://www.testexchangeconnectivity.com/</a>

I receive the following error message on the last step:       

Testing NSPI Interface on Exchange Mailbox Server
       An error occured while testing the NSPI Interface.
      Test Steps
       
      Attempting to ping RPC Endpoint 6004 (NSPI Proxy Interface) on server rohrig2k3dc.rohrig.local
       Failed to ping Endpoint
      Additional Details
       RPC Status 2147483647 (2147483647) returned in 0 ms.

When connecting using RPC over HTTP on the local network I can see that the connection fails on the HTTPS protocol and reverts back to TCP/IP connections in Outlook.

Any suggestions?
AccdatAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
Olaf De CeusterConnect With a Mentor Commented:
1: Disable IPv6. It's not used in SBS2003 (I assume you are running SBS 2003)
2: Rerun Internet Connection Wizard (Point 2 in To Do List)
3: Run Remote Access Wizard: (Point3 in To Do List)
lease download the SBSBPA and run it: http://www.microsoft.com/downloads/details.aspx?familyid=3874527A-DE19-49BB-800F-352F3B6F2922&displaylang=en
Fix all the problems it finds. Especially the NIC related stuff.
If still problems: Please post Ipconfig/all of server and one workstation.
Hope that helps,
Olaf
0
 
cavinlimCommented:
Exchange 2003 is single server or have front end & back end server?

and your certificate is local CA or public CA (purchase)?
0
 
Dan560Commented:
Have you port forwarded 443 to your server?

0
Free tool for managing users' photos in Office 365

Easily upload multiple users’ photos to Office 365. Manage them with an intuitive GUI and use handy built-in cropping and resizing options. Link photos with users based on Azure AD attributes. Free tool!

 
AccdatAuthor Commented:
cavinlim

The certificate was a local CA - the standard certificate that Small Business Server creates during the CEICW. It is a single server.


Dan560,

Yes - I do have port 443 forwarded correctly. As previously mentioned, the http://mail.companyurl.com/rpc works and established HTTPS without error. The issue also occurs when connecting to the server over the local network with RPC over HTTP configured.
0
 
AccdatAuthor Commented:
Update: I've reinstalled the RPC Proxy windows networking component with no change in the behaviour. I am still failing to ping the RPC Endpoint 6004 (NSPI Proxy Interface).
0
 
AccdatAuthor Commented:
Update: I noticed when pinging the server name from a command prompt on the server itself, it is resolving to an IPv6 address even though IPv6 has been deselected on both network adapators (One NIC in use, one disabled) - here is the CMD dump:

C:\>ping rohrig2k3dc

Pinging rohrig2k3dc [fe80::1%1] from fe80::1%1 with 32 bytes of data:

Reply from fe80::1%1: time<1ms
Reply from fe80::1%1: time<1ms
Reply from fe80::1%1: time<1ms
Reply from fe80::1%1: time<1ms

Ping statistics for fe80::1%1:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 0ms, Average = 0ms

C:\>ipconfig /all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : ROHRIG2K3DC
   Primary Dns Suffix  . . . . . . . : Rohrig.local
   Node Type . . . . . . . . . . . . : Unknown
   IP Routing Enabled. . . . . . . . : Yes
   WINS Proxy Enabled. . . . . . . . : Yes
   DNS Suffix Search List. . . . . . : Rohrig.local

Ethernet adapter Local Area Connection 2:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Intel(R) PRO/1000 MT Network Connection
   Physical Address. . . . . . . . . : 00-04-23-C7-21-3A
   DHCP Enabled. . . . . . . . . . . : No
   IP Address. . . . . . . . . . . . : 192.168.0.1
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.0.254
   DNS Servers . . . . . . . . . . . : 192.168.0.1
   Primary WINS Server . . . . . . . : 192.168.0.1

Tunnel adapter Automatic Tunneling Pseudo-Interface:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Automatic Tunneling Pseudo-Interface
   Physical Address. . . . . . . . . : C0-A8-00-01
   DHCP Enabled. . . . . . . . . . . : No
   IP Address. . . . . . . . . . . . : fe80::5efe:192.168.0.1%2
   Default Gateway . . . . . . . . . :
   DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
                                       fec0:0:0:ffff::2%1
                                       fec0:0:0:ffff::3%1
   NetBIOS over Tcpip. . . . . . . . : Disabled

Could this IPv6 be causing problems with RPC over HTTP?
0
 
AccdatAuthor Commented:
olafdc

I ended up removing IPv6 completely (it was already disabled, but obviously still active). It just so happened that I was fixing another problem with Remote Access when network connectivity failed completely. I reinstalled network adaptor drivers and TCP/IP. I ran change IP utility in Safe Mode with Networking then the Internet Connection Wizard in Normal Mode. I then ran the the check using http://www.testexchangeconnectivity.com and ensured RPC over HTTP was working via a locally network workstation using the connection status window for Outlook 2007.

Thanks for your advice!

Accdat
0
All Courses

From novice to tech pro — start learning today.