Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

NTP commands in IOS 12.4T?

Posted on 2008-10-08
14
1,329 Views
Last Modified: 2012-05-05
Where are they/where'd they go!? Lol

I've never noticed this before, but they're not there in 12.4(15)T7. Only sntp. What's up with that!?

Platform is C850.
0
Comment
Question by:Pugglewuggle
  • 6
  • 5
  • 2
14 Comments
 
LVL 2

Expert Comment

by:AdamComp
ID: 22676355
what router image are you using?
0
 
LVL 12

Author Comment

by:Pugglewuggle
ID: 22676400
Okay, I know that they do not have it in the image, I'm just asking why the heck not!? WTF is the point of getting rid of NTP and leaving SNTP?
Is Cisco crazy?
(BTW I already checked the FN - i know that's what you were going to do...)
0
 
LVL 2

Expert Comment

by:AdamComp
ID: 22677160
Sorry, I thought you were asking why it didn't technically, not philosophically :)

That is pretty dumb, though.  It looks like there is only one 12.4 image that works on that too.  I think it's a ploy to make you by a more expensive router.  Well, Just for the heck of it, here's a cool article about how to make a consumer grade router have most features that Cisco routers have:

http://lifehacker.com/344765/turn-your-60-router-into-a-user+friendly-super+router-with-tomato

enjoy!
0
Connect further...control easier

With the ATEN CE624, you can now enjoy a high-quality visual experience powered by HDBaseT technology and the convenience of a single Cat6 cable to transmit uncompressed video with zero latency and multi-streaming for dual-view applications where remote access is required.

 
LVL 79

Expert Comment

by:lrmoore
ID: 22677716
Works with my router
System image file is "flash:c2800nm-ipvoicek9-mz.124-15.T7.bin"
What feature set are you trying to use?

ROUTER#sho ntp assoc

      address         ref clock     st  when  poll reach  delay  offset    disp
*~192.168.100.254  6x.2x.52.xx      3    45    64  377     1.2   -0.04     0.1
 * master (synced), # master (unsynced), + selected, - candidate, ~ configured

ROUTER(config)#ntp ?
  access-group        Control NTP access
  authenticate        Authenticate time sources
  authentication-key  Authentication key for trusted time source
  broadcastdelay      Estimated round-trip delay
  clock-period        Length of hardware clock tick
  logging             Enable NTP message logging
  master              Act as NTP master clock
  max-associations    Set maximum number of associations
  peer                Configure NTP peer
  server              Configure NTP server
  source              Configure interface for source address
  trusted-key         Key numbers for trusted time sources
  update-calendar     Periodically update calendar with NTP time

ROUTER(config)#ntp
0
 
LVL 2

Expert Comment

by:AdamComp
ID: 22678699
lrmoore: you're using a 2800 router.  He is using one of those much smaller 850 series mainly meant for SOHO installations
0
 
LVL 12

Accepted Solution

by:
Pugglewuggle earned 0 total points
ID: 22679366
Yeah, that's a 2800... this particular one is an 850... I had worked with 12.4T on the 1800 and 2800 routers and never noticed NTP being gone...
I'm running advanced security on an 851W. I previously had  124-4.T5 for the 850 and that DID have NTP, so when I upgraded and I checked the sh ntp ass and it said command not recognized I was just kind of like "huh?"
It looks like the 851 stopped supporting NTP at 124-6.T11
I just don't understand why Cisco would do something this stupid. Other than to sell more stuff... they have been ripping features just to sell stuff a whole lot lately and I'm getting really, really tired of it... look at the new Call Manager licensing for example... You have to license 6 lines to a 7960 phone or you can't use it at all (Even if you don't use 2 lines).
I mean, come on, how much space can NTP possibly take that they can't squeeze a few more bytes onto a 11MB image for a 20MB flash? Ridiculous...
And no DD-WRT for me... it's an unstable joke in my opinion. Cisco Cisco Cisco. :)
Arrgghhh! Cisco, you're so good and yet you suck so bad!
0
 
LVL 12

Author Comment

by:Pugglewuggle
ID: 22681907
Okay - I'm usually the one answering questions but now I'm stuck. I increased the points too.
I deleted the 12.4(15)T7 and uploaded 12.4(6)T11 so I could get NTP back on the device.
In my rush I forgot to verify the checksum of the image and rebooted with a corrupt image.
I've now tried every combination of sending breaks before boot, after boot, and during boot and I cannot get into ROMMON mode to upload the 12.4(6)T11 image with XMODEM over the console cable.
I'm used to just sending breaks and it will immediately stop the boot and go into ROMMON. Instead, ROMMON never comes up and the boot just fails with the well known checksum failed, corrupt image, blah blah message.
Any ideas? If I can just get ROMMON I'll be good to go.
0
 
LVL 12

Author Comment

by:Pugglewuggle
ID: 22682683
Ahh nevermind. Finally got it to work.
Hmmm. Stupid missing NTP.
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 22683198
0
 
LVL 12

Author Comment

by:Pugglewuggle
ID: 22684174
Maybe they'll put NTP back in IOS 12.5.
Yeah right. I guess I'll keep dreaming.
Thanks and cheers! :)
0
 
LVL 2

Expert Comment

by:AdamComp
ID: 22710277
how do you accept your own answer?
0
 
LVL 12

Author Comment

by:Pugglewuggle
ID: 22710299
You click accept answer right next to your post - it's just not worth anything... kind of like a cancel.
0
 
LVL 2

Expert Comment

by:AdamComp
ID: 22716082
bs
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
WiFi Routers with Guest Network capability 14 73
How to set DHCPv6 options on a Sonicwall? 13 175
WAN Site Edge Routers 15 62
ISP Change 14 63
New Server 172.16.200.2  was moved from behind Router R2 f0/1 to behind router R1 int f/01 and has now address 172.16.100.2. But we want users still to be able to connected to it by old IP. How to do it ? We can used destination NAT (DNAT).  In DNAT…
Problem Description:   Couple of months ago we upgraded the ADSL line at our branch office from Home to Business line. The purpose of transforming the service to have static public IP’s. We were in need for public IP’s to publish our web resour…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

809 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question