Solved

PIX setup for Blackberry Enterprise Server (port 3101)

Posted on 2008-10-09
8
3,513 Views
Last Modified: 2012-06-27
We have a PIX 501 v 6.3(5) PDM 3.0(4) and need to make changes to allow Blackberry Enterprise Server to work with Exchange 2007.  I have made change via CLI and PDM and still fails connection test.  The SRP address is srp.us.blackberry.net and the BES ip addresses are 206.51.26.33 & 204.187.87.33.  No matter what changes I make I always get the Connection refused (10061).  I can ping each and resolve the name.
I would appreciate any help.  CLI is fine but I would especially like to know how to configure via the PDM if possible.

Thank you
0
Comment
Question by:lobarassoc
  • 4
  • 4
8 Comments
 
LVL 33

Accepted Solution

by:
MikeKane earned 500 total points
ID: 22678518
You will need port 3101  open for proper communication:

access-list inside_access_in permit tcp host <Your BES Server internal IP> host 204.187.87.33 eq 3101
access-group inside_access_in in interface inside

This assumes you are using an access list as defined in the access group.    

BAsically, you just need to allow for port 3130 outbound from your server.    If you like, you can post your PIX code removing any personal details for review....
0
 

Author Comment

by:lobarassoc
ID: 22678920
I just added the above statements via CLI for ip address listed and 206.51.26.33.  Updated the PIX and still receive the 10061 Connection refused error for both IPs
Thanks for the fast response.
0
 
LVL 33

Expert Comment

by:MikeKane
ID: 22680018
Next best step is to let me see your pix code if you dont mind.    Just remove any personal detail like public ip or usernames, etc....  
0
 

Author Comment

by:lobarassoc
ID: 22689036
Below is a copy of the config.  I have all the statements that I added relating to the BES and Blackberry sites listed so you can see what was previously entered without success.
As I mentioned earlier each time when running connection test I get bac 'Connection refused (error 10061)
Thanks for the help.
Building configuration...
: Saved
:
PIX Version 6.3(5)
interface ethernet0 10baset
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password encrypted
passwd encrypted
hostname pix501
domain-name xxxx.com
fixup protocol dns maximum-length 512
fixup protocol esp-ike
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
no fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name 192.168.1.0 internal
name
name 192.168.1.9 hades
name 192.168.1.15 hermes
name email
name 192.168.1.20 xxxxxx
name 192.168.1.190 Syslog
name 192.168.1.10 exchange
name 192.168.1.26 BES
name 192.168.1.25 DC2
name 192.168.1.24 DC1
name 206.51.26.33 Blackberry
name 204.187.87.33 Blackberry2
object-group service Blackberry tcp
  port-object range 3101 3101
  port-object eq smtp
object-group network smtp-hosts
object-group service BES tcp
  port-object eq 3101
access-list inside_access_in permit tcp any any eq www
access-list inside_access_in permit tcp any any eq https
access-list inside_access_in permit tcp any any eq domain
access-list inside_access_in permit udp any any eq domain
access-list inside_access_in permit icmp any any
access-list inside_access_in permit tcp any any eq ftp
access-list inside_access_in permit tcp any any eq imap4
access-list inside_access_in permit ip host xxxxxxx any
access-list inside_access_in permit tcp any any eq pop3
access-list inside_access_in permit tcp host BES eq 3101 host Blackberry
access-list inside_access_in permit tcp host BES eq 3101 host Blackberry object-group Blackberry
access-list inside_access_in permit tcp any eq 3101 host Blackberry2
access-list inside_access_in permit tcp any eq 3101 host Blackberry object-group Blackberry
access-list inside_access_in permit tcp host bes host Blackberry2 eq 3101
access-list inside_access_in permit tcp host bes host Blackberry eq 3101
access-list inside_access_in permit tcp any any eq smtp
access-list inside_access_in permit tcp host BES object-group BES any
access-list outside_access_in permit tcp any host email eq smtp
access-list outside_access_in permit tcp any host email eq pop3
access-list outside_access_in permit tcp any host email eq imap4
access-list outside_access_in permit tcp any host  eq www
access-list outside_access_in permit tcp any host email eq https
access-list outside_access_in permit icmp any any echo-reply
access-list 110 permit ip internal 255.255.255.0 10.1.1.0 255.255.255.0
access-list nonat permit ip internal 255.255.255.0 10.1.1.0 255.255.255.0
pager lines 24
logging on
logging timestamp
logging trap notifications
logging history alerts
logging host inside Syslog
no logging message 304001
mtu outside 1500
mtu inside 1500
ip address outside  255.255.255.248
ip address inside 192.168.1.1 255.255.255.0
ip verify reverse-path interface outside
ip verify reverse-path interface inside
ip audit info action alarm
ip audit attack action alarm
ip local pool vpnpool
ip local pool pptp
pdm location internal 255.255.255.0 inside
pdm location exchange 255.255.255.255 inside
pdm location xxxxxxx 255.255.255.255 inside
pdm location E-Comm 255.255.255.0 outside
pdm location hermes 255.255.255.255 inside
pdm location hades 255.255.255.255 inside
pdm location email 255.255.255.255 outside
pdm location Syslog 255.255.255.255 inside
pdm location DC1 255.255.255.255 inside
pdm location DC2 255.255.255.255 inside
pdm location BES 255.255.255.255 inside
pdm location Blackberry2 255.255.255.255 outside
pdm location Blackberry 255.255.255.255 outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 5
global (outside) 6
nat (inside) 0 access-list 110
nat (inside) 5 internal 255.255.255.0 0 0
nat (inside) 6 0.0.0.0 0.0.0.0 0 0
static (inside,outside) email exchange netmask 255.255.255.255 0 0
static (inside,outside) hades netmask 255.255.255.255 0 0
access-group outside_access_in in interface outside
access-group inside_access_in in interface inside
rip inside default version 1
route outside 0.0.0.0 0.0.0.0 000.00.0.00 1
timeout xlate 0:10:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
aaa-server partnerauth protocol radius
aaa-server partnerauth max-failed-attempts 3
aaa-server partnerauth deadtime 10
aaa-server partnerauth (inside) host hermes timeout 10
http server enable
http internal 255.255.255.0 inside
no snmp-server location
snmp-server contact
snmp-server community public
snmp-server enable traps
tftp-server inside Syslog /TFTPBOOT/PIXFIREWALL/CONFIG
floodguard enable
sysopt connection timewait
sysopt connection permit-ipsec
sysopt connection permit-pptp
service resetinbound
service resetoutside
crypto ipsec transform-set myset esp-des esp-md5-hmac
crypto dynamic-map dynmap 10 set transform-set myset
crypto map mymap 10 ipsec-isakmp dynamic dynmap
crypto map mymap client authentication partnerauth
crypto map mymap interface outside
isakmp identity address
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption des
isakmp policy 10 hash md5
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
vpngroup vpn3000 address-pool vpnpool
vpngroup vpn3000 dns-server hermes 192.168.1.16
vpngroup vpn3000 wins-server hermes
vpngroup vpn3000 default-domain xxxxx.com
vpngroup vpn3000 idle-time 1800
vpngroup vpn3000 password ********
telnet timeout 5
ssh timeout 5
console timeout 0
vpdn group 1 accept dialin pptp
vpdn group 1 ppp authentication pap
vpdn group 1 ppp authentication chap
vpdn group 1 ppp authentication mschap
vpdn group 1 ppp encryption mppe 40
vpdn group 1 client configuration address local pptp
vpdn group 1 client configuration dns hermes 192.168.1.16
vpdn group 1 client configuration wins hermes
vpdn group 1 client authentication aaa partnerauth
vpdn group 1 pptp echo 60
vpdn enable outside
dhcpd lease 3600
dhcpd ping_timeout 750
terminal width 80
Cryptochecksum:a5fc495ad3232233c2bb4e332161e44
: end
[OK]
 
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 33

Expert Comment

by:MikeKane
ID: 22689938
I take it that
global (outside) 6
has some ips following it that you removed....    

The code looks good as far as I could tell from my quick read.    I would then say to watch the syslog server's entries...look for any denies originating from your BES IP.     It should ID any ACL lists blocking and/or help clue in to something else.  
0
 

Author Comment

by:lobarassoc
ID: 22690105
yes sir
0
 
LVL 33

Expert Comment

by:MikeKane
ID: 22711397
Anything from the syslog showing blocked packets?
0
 

Author Closing Comment

by:lobarassoc
ID: 31504641
Thanks a lot Mike for the support. I was able to resolve by looking at syslog.  There was a name conflict and also 2 ip addresses (redundant NICs) As soon as I fired up syslog and used some trace utilities I could see where my problem was.  Just changed the PIX config and immediately successful.  Thanks again for the help. Sorry for the delay in issuing points
0

Featured Post

Top 6 Sources for Identifying Threat Actor TTPs

Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

Join & Write a Comment

Suggested Solutions

I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
Following basic email etiquette rules will help you write a professional email and achieve a good, lasting impression with your contacts.
In this video we show how to create a User Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Mailb…
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…

757 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now