• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 448
  • Last Modified:

Remote Web Workplace in SBS 2003 is not showing a 2008 Terminal Server

I am trying to get my new 2008 Terminal Server to show up as an Application Server in Remote Web Workplace in SBS 2003.  I have made the registry change in the 2008 TS to add the TSEnabled=1 DWORD value, and restarted the TS server.  I have also disabled the firewall on the TS server to see if that was the problem.  

And before someone replies saying it isn't possible, it is.  I've seen all kinds of blogs, including Susan's official SBS blog saying that this is possible.  Susan's blog posted instructions to add the TSEnabled value but that didn't work for me, I must be missing something.
0
dgooge
Asked:
dgooge
  • 8
  • 7
1 Solution
 
wolfcamelCommented:
with 2003 TS - I have often seen RWW not show the application server - either restarting IIS or even waiting and reconnecting and it shows up - it hasnt happened often at the sites I support in this scenario, so I havent really solved any further than the above.
I dont know if this relates to 2008 but I offer it in hope for you.
0
 
dgoogeAuthor Commented:
Thanks for the suggestion, but I just tried restarting the IIS Admin service and still cannot see the Application Server in RWW.
0
 
wolfcamelCommented:
did you join it to the domain by going  http://ServerName/connectcomputer?
is the logged on users a member of the TS Application Sharing group.?
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
wolfcamelCommented:
On SBS:
HKLM\Software\Microsoft\SmallBusinessServer\RemoteUserProtal\KWLinks\AppTS=1
On the TS:
HKLM\System\CurrentControlSet\Control\Terminal Server\TSEnabled = 1
HKLM\System\CurrentControlSet\Control\Terminal Server\TSAppCompat = 1
0
 
dgoogeAuthor Commented:
You can't do that with Server 2008, you have to join it manually.  Even though you have to join a 2008 Server manually many people have still gotten it to work.  

All users are members of the Remote Web Workplace group.  Is there some other group they should also be a member of?  I don't see a TS Application Sharing group.
0
 
dgoogeAuthor Commented:
Wolf, I have also double and triple checked those registry keys, they are in place.
0
 
wolfcamelCommented:
and also - is the TS on the same subnet as the workstations - ie if you have two netcards in the server the TS should be on the internal network.
0
 
dgoogeAuthor Commented:
Everything is on the same subnet and all machines have only one NIC.

 I have also made sure the TS DNS server was pointed to the SBS server and I have installed the TS Licensing service on the SBS server (Even though the active licensing server has to be on a 2008 machine).  I had seen those suggestions as well.  The TS server seems to be fully accessible from the SBS server and vice-versa.  

I have also verified that I can connect to the remote registry of the 2008 TS from the SBS server.
0
 
wolfcamelCommented:
remote registry service should be running on the TS.
The operatingSystem Active Directory attribute must contain the word "Server" (case-sensitive).

forgive me if you have already stumbled across/and hence tried some of these.
0
 
wolfcamelCommented:
does it appear in the list of servers if you rww as the admin?
0
 
wolfcamelCommented:
i will pop back in tommorrow - time for some sleep here - 1am PERTH AUSTRALIA.
0
 
dgoogeAuthor Commented:
No, that is quite alright, I appreciate any help I can get.  I'm actually increasing the points to 500 because this is a serious PITA and I'm getting tired of dealing with it.  I've verified the remote registry but one question I have about the OS attribute... it has the little registered trademark symbol after Server in Windows Server 2008 Standard.  But it does contain the word Server.  I don't see a way to change that.
0
 
dgoogeAuthor Commented:
Yes, it does appear as a server computer if I log in as admin.  I seem to have been wrong about joining a server wtih the servername/connectcomputer link.  I read somewhere that it did not work with SBS 2003, but I deleted the TS from the domain and did the proper setup and it attached the server to the network.  Unfortunately it still did not solve the problem, even after an IIS restart on the SBS.
0
 
dgoogeAuthor Commented:
Ok, I have no idea why this is but I think I found the issue.  I have been logging into RWW with a domain admin account and have not been able to see the App Server entry.  However logging in as a regular user I can see it.  I assumed it would show up for anyone logging in.  Is there some type of group that controls this?
0
 
wolfcamelCommented:
as an admin it should show up in servers - as a user it should show up as "my company's application server"
By design.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

  • 8
  • 7
Tackle projects and never again get stuck behind a technical roadblock.
Join Now