Solved

How do I change DNS server settings to resolve the company's domain name from a new subnet?

Posted on 2008-10-09
6
279 Views
Last Modified: 2012-08-13
A company I am doing work for wanted the ability to have wireless within their office. I initially tried to set up a Linksys WRT54GL w/ Tomato 1.21 on the existing 192.168.1.x subnet but I never could get it to work out for me. I am connecting the router to a Netopia DSL gateway. I was able to get a wireless computer online and to join the domain after configuring the router as such:

--------------------------
WAN connection type: Static IP
WAN IP: 192.168.1.24
subnet mask: 255.255.255.0
gateway: 192.168.1.254
static DNS 1: 192.168.1.2 (the server)
static DNS 2: 192.168.1.254

Local settings
Router IP: 192.168.2.1
subnet mask 255.255.255.0

DHCP server enabled
192.168.2.100 - 192.168.2.149
WINS: 192.168.1.2 (It wouldn't work until I put this in)
--------------------------

The symptoms are as follows:
Computers on the .1.x subnet can browse the web and the company website. Computers on the .2.x subnet can browse the web but not the company website. They can access it with the IP address but not by domain name. This website isn't hosted there, but the server is set up to be a DNS server in the network. Does it even need to be handling DNS or is that just getting in the way?
0
Comment
Question by:mousemen
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
6 Comments
 
LVL 59

Accepted Solution

by:
Darius Ghassem earned 250 total points
ID: 22679969
You need to put the server's IP address if the server is a DNS sever then the clients should only be getting this address for DNS. If you have two internal DNS servers then list them both you shouldn't have the router as DNS. You should have the actual DNS server's ip address listed when you do an ipconfig /all on the clients.
0
 

Author Comment

by:mousemen
ID: 22680947
Originally I did have the DNS set to the server IP only and I still had this same problem. I tried setting the DSL gateway as the secondary DNS hoping that if an address didn't resolve using the first server that it would resolve it using the second. That's unfortunately not the case. Doesn't this have something to do with the lookup zones settings on the server? Another solution here I think is to figure out a way to have the router work on the .1.x subnet. I'm not sure why I couldn't get that to work in the first place.
0
 
LVL 59

Expert Comment

by:Darius Ghassem
ID: 22681050
The  Netopia DSL gateway and the Linksys are most likely compatiable which each other. A work around is to put a Linksys wired router then put the Linksys wireless connected to this one. How this would work is change the subnet for the  Netopia DSL gateway to 192.168.0.1 then add the Linksys wired router make the IP address 192.168.1.1 then make the wireless router just a AP point by disabling DHCP.

When you had the DNS server listed did you do a ipconfig /flushdns?
0
SharePoint Admin?

Enable Your Employees To Focus On The Core With Intuitive Onscreen Guidance That is With You At The Moment of Need.

 
LVL 8

Assisted Solution

by:MrJemson
MrJemson earned 250 total points
ID: 22684415
First off, I would recommend getting rid of Tomato and installing DD-WRT. This is optional, but based on my experiences, DD-WRT is a much better platform.

From the web interface, disable the WAN interface and turn off DHCP on the LAN side.
Configure the Access Point accordingly, and plug the Netopia router directly into one of the LAN ports on the linksys. I have done this many times on many different platforms with DD-WRT and have had no issues.

It is extremely unlikely that the Netopia and Linksys are not compatible with one another, and there should be no need to buy additional hardware.
0
 
LVL 59

Expert Comment

by:Darius Ghassem
ID: 22686267
I worked with Netopia and have had issues with it giving IP addresses out to clients that connect to a Linksys AP\Router.
0
 

Author Comment

by:mousemen
ID: 23194372
I found that the whole problem in the setup was in how I had it plugged in. When I disabled the WAN port I forgot that this meant I needed to move that cable from the WAN port to one of the four LAN ports. Once I did that the problem was solved.
0

Featured Post

Salesforce Has Never Been Easier

Improve and reinforce salesforce training & adoption using WalkMe's digital adoption platform. Start saving on costly employee training by creating fast intuitive Walk-Thrus for Salesforce. Claim your Free Account Now

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I've written instructions for one router type, but this principle may be useful for others of the same brand and even other brands of router. Problem: I had an issue especially with mobile devices that refused to use DNS information supplied via…
Tired of waiting for your show or movie to load?  Are buffering issues a constant problem with your internet connection?  Check this article out to see if these simple adjustments are the solution for you.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

710 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question