Solved

RRAS not working for units outside firewall

Posted on 2008-10-09
2
496 Views
Last Modified: 2013-11-05
I have a Windows Server 2003 with RRAS setup. Computers inside the ASA5510 firewall, connect to it fine. Computers outside the firewall get Error 800 when they try to connect.

I opened 1723 and GRE.

The RRAS server is 10.0.1.7
: Saved

:

ASA Version 7.0(8) 

!

hostname MoonlightASA

domain-name rmc.local

enable password 8Ry2YjIyt7RRXU24 encrypted

passwd 2KFQnbNIdI.2KYOU encrypted

names

dns-guard

!

interface Ethernet0/0

 nameif outside

 security-level 0

 ip address 12.44.182.14 255.255.255.0 

!

interface Ethernet0/1

 nameif inside

 security-level 100

 ip address 10.0.1.1 255.255.0.0 

!

interface Ethernet0/2

 shutdown

 no nameif

 no security-level

 no ip address

!

interface Management0/0

 nameif management

 security-level 100

 ip address 192.168.1.1 255.255.255.0 

 management-only

!

ftp mode passive

object-group network VPNPool

 network-object 10.10.0.0 255.255.255.0

access-list outside_access_in extended permit udp any host 12.44.182.2 eq domain 

access-list outside_access_in extended permit tcp any host 12.44.182.2 eq smtp 

access-list outside_access_in extended permit udp any host 12.44.182.3 eq domain 

access-list outside_access_in extended permit tcp any host 12.44.182.2 eq pop3 

access-list outside_access_in extended permit tcp any host 12.44.182.2 eq imap4 

access-list outside_access_in extended permit tcp any host 12.44.182.2 eq www 

access-list outside_access_in extended permit tcp any host 12.44.182.2 eq https 

access-list outside_access_in extended permit tcp any host 12.44.182.2 eq 444 

access-list outside_access_in extended permit tcp any host 12.44.182.2 eq 81 

access-list outside_access_in extended permit tcp any host 12.44.182.21 eq smtp 

access-list outside_access_in extended permit tcp any host 12.44.182.21 eq pop3 

access-list outside_access_in extended permit tcp any host 12.44.182.20 eq www 

access-list outside_access_in extended permit tcp any host 12.44.182.20 eq 3389 

access-list outside_access_in extended permit tcp any host 12.44.182.20 eq ftp 

access-list outside_access_in extended permit tcp any host 12.44.182.20 eq ssh 

access-list outside_access_in extended permit tcp any host 12.44.182.22 eq citrix-ica 

access-list outside_access_in extended permit tcp any host 12.44.182.22 eq www 

access-list outside_access_in extended permit tcp any host 12.44.182.22 eq https 

access-list outside_access_in extended permit tcp any host 12.44.182.22 eq 2974 

access-list outside_access_in extended permit udp any host 12.44.182.22 eq 1604 

access-list outside_access_in extended permit tcp any host 12.44.182.22 eq 6129 

access-list outside_access_in extended permit icmp any any 

access-list outside_access_in extended permit tcp any host 12.44.182.21 eq imap4 

access-list outside_access_in extended permit tcp any host 12.44.182.21 eq www 

access-list outside_access_in extended permit tcp any host 12.44.182.21 eq https 

access-list outside_access_in extended permit tcp any host 12.44.182.21 eq 444 

access-list outside_access_in extended permit tcp any host 12.44.182.21 eq 81 

access-list outside_access_in extended permit gre any host 12.44.182.3 

access-list outside_access_in extended permit tcp any eq pptp host 12.44.182.3 

access-list inside_nat0_outbound extended permit ip 10.0.0.0 255.255.0.0 10.10.1.0 255.255.255.0 

access-list Moonlight_splitTunnelAcl standard permit 10.0.0.0 255.255.0.0 

access-list outside_cryptomap_20.20 extended permit ip any object-group VPNPool 

pager lines 24

logging asdm informational

mtu outside 1500

mtu inside 1500

mtu management 1500

ip local pool VPNPool 10.10.1.1-10.10.1.100 mask 255.255.255.0

asdm image disk0:/asdm-508.bin

no asdm history enable

arp timeout 14400

global (outside) 10 12.44.182.15

nat (inside) 0 access-list inside_nat0_outbound

nat (inside) 10 0.0.0.0 0.0.0.0

alias (inside) 10.0.2.55 12.44.182.2 255.255.255.255

alias (inside) 10.0.1.4 12.44.182.20 255.255.255.255

alias (inside) 10.0.1.2 12.44.182.21 255.255.255.255

static (inside,outside) 12.44.182.21 10.0.1.2 netmask 255.255.255.255 

static (inside,outside) 12.44.182.22 10.0.1.11 netmask 255.255.255.255 

static (inside,outside) 12.44.182.20 10.0.1.4 netmask 255.255.255.255 

static (inside,outside) 12.44.182.23 10.0.1.3 netmask 255.255.255.255 

static (inside,outside) 12.44.182.2 10.0.2.55 netmask 255.255.255.255 

static (inside,outside) 12.44.182.3 10.0.1.7 netmask 255.255.255.255 

access-group outside_access_in in interface outside

route outside 0.0.0.0 0.0.0.0 12.44.182.1 1

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00

timeout mgcp-pat 0:05:00 sip 0:30:00 sip_media 0:02:00

timeout uauth 0:05:00 absolute

group-policy Moonlight internal

group-policy Moonlight attributes

 wins-server value 10.0.1.7 10.0.2.55

 dns-server value 10.0.1.7 10.0.2.55

 vpn-tunnel-protocol IPSec 

 split-tunnel-policy tunnelspecified

 split-tunnel-network-list value Moonlight_splitTunnelAcl

 default-domain value rmc.local

 webvpn

username russ password dXTAXkFOZwTBXAYq encrypted privilege 0

username russ attributes

 vpn-group-policy Moonlight

 webvpn

username jreimer password 5tkSXi53LzsqVtJI encrypted privilege 0

username jreimer attributes

 vpn-group-policy Moonlight

 webvpn

http server enable

http 10.0.0.0 255.255.0.0 inside

http 192.168.200.0 255.255.255.0 inside

http 192.168.1.0 255.255.255.0 management

no snmp-server location

no snmp-server contact

snmp-server enable traps snmp authentication linkup linkdown coldstart

sysopt noproxyarp inside

crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac 

crypto ipsec security-association lifetime seconds 28800

crypto ipsec security-association lifetime kilobytes 4608000

crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA

crypto dynamic-map outside_dyn_map 20 set security-association lifetime seconds 28800

crypto dynamic-map outside_dyn_map 20 set security-association lifetime kilobytes 4608000

crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map

crypto map outside_map interface outside

isakmp enable outside

isakmp policy 10 authentication pre-share

isakmp policy 10 encryption 3des

isakmp policy 10 hash sha

isakmp policy 10 group 2

isakmp policy 10 lifetime 86400

isakmp nat-traversal  20

tunnel-group Moonlight type ipsec-ra

tunnel-group Moonlight general-attributes

 address-pool VPNPool

 default-group-policy Moonlight

tunnel-group Moonlight ipsec-attributes

 pre-shared-key *

telnet 10.0.0.0 255.255.0.0 inside

telnet timeout 20

ssh timeout 5

console timeout 0

dhcpd address 192.168.1.2-192.168.1.254 management

dhcpd lease 3600

dhcpd ping_timeout 50

dhcpd enable management

!

class-map inspection_default

 match default-inspection-traffic

!

!

policy-map global_policy

 class inspection_default

  inspect ftp 

  inspect h323 h225 

  inspect h323 ras 

  inspect rsh 

  inspect rtsp 

  inspect esmtp 

  inspect sqlnet 

  inspect skinny 

  inspect sunrpc 

  inspect xdmcp 

  inspect sip 

  inspect netbios 

  inspect tftp 

  inspect icmp 

  inspect dns maximum-length 4096 

  inspect pptp 

!

service-policy global_policy global

Cryptochecksum:13f2a1eb27f63323759d72b2c8e9a33c

: end

Open in new window

0
Comment
Question by:Rhymhoont
2 Comments
 
LVL 79

Accepted Solution

by:
lrmoore earned 500 total points
Comment Utility
>access-list outside_access_in extended permit tcp any eq pptp host 12.44.182.3
This should be

access-list outside_access_in extended permit tcp any host 12.44.182.3 eq pptp

You might also need to enable inspect pptp

policy-map global_policy
 class inspection_default
  inspect pptp
0
 
LVL 1

Author Closing Comment

by:Rhymhoont
Comment Utility
Excellent. Not sure how I missed that. looks obvious now...
0

Featured Post

Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

Join & Write a Comment

This article will cover setting up redundant ISPs for outbound connectivity on an ASA 5510 (although the same should work on the 5520s and up as well).  It’s important to note that this covers outbound connectivity only.  The ASA does not have built…
I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

17 Experts available now in Live!

Get 1:1 Help Now