Set default mail program for all users on Windows 2008 Terminal Server

I'm running a Windows 2008 Terminal Server environment.  We have Office 2003 with Outlook 2003 installed on the terminal server.  We're using TS Remote App and TS Web to publish applications such as Outlook, Word, Adobe Acrobat, and some line of business applications.

The problem we're having is that whenever someone tries to email directly from Word or Acrobat Windows Mail launches, instead of Outlook 2003--even though Outlook is set as the default mail program.  How can I fix this, and fix it for all users on the system?

Cheers...
keefe007Asked:
Who is Participating?
 
Computer101Commented:
PAQed with points refunded (500)

Computer101
EE Admin
0
 
speshalystCommented:
"--even though Outlook is set as the default mail program" -
Does this mean that if you open IE>Tool>Internet Options> Programs(tab) .. Email .. shows Microsoft Outlook ?
0
 
keefe007Author Commented:
Yes, that shows microsoft outlook.

I was able to get it mostly working by going into the "default programs" control panel option and redoing the Outlook one.  Is there an easy way to do this for ALL users on the system?

Also, in MS Word when I click on the email icon on the toolbar it still opens Windows Mail.  When I click "File -> Sent to recipient as attachement" it opens Outlook.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.