Solved

Disable access to change date and time

Posted on 2008-10-09
12
5,112 Views
Last Modified: 2010-08-05
I'm a sys. admin and want throgh some policy or something disable the user from being able to change the time/date settings of a computer. I have found a way to make it disappear from the system tray but it is not the ideal solution. any ideas?
0
Comment
Question by:borgb002
  • 5
  • 4
  • 2
  • +1
12 Comments
 
LVL 6

Expert Comment

by:MrNiss99
ID: 22682163
As long as the user is not in the local administrators group then they shouldn't be able to change date/ time.
0
 

Author Comment

by:borgb002
ID: 22682210
in fact they are....... any work arounds please?
0
 
LVL 8

Expert Comment

by:Point-In-Cyberspace
ID: 22682222
Normal users cannot change date/time on the machine. If users are power users or administrators you can use a local policy that you can apply to local computers or, if there is a domain, a group policy to do this.

Open policy editor and look for:
  Computer config/Windows settings/User rights/Change system time

Here you can set who will be able to change date and time.

0
 

Author Comment

by:borgb002
ID: 22682299
can't find it.... under "Windows Settings" there are only two options:
Scripts
Security settings
0
 
LVL 8

Expert Comment

by:Point-In-Cyberspace
ID: 22682468
My mistake. I'm using nonenglish windows now.

You have to go to:
Computer config/windows settings/Security settings/Local .../User rights/Change system time


0
 

Author Comment

by:borgb002
ID: 22682565
ok found. But it is asking for a user/group in my domain. I was hoping to find:
Allow change date/time [ENABLE or DISABLE]  but unfortunately wasn't like that.

If I add a user or group, what does that mean that I'm restricting or allowing access?
0
Promote certifications in your email signature

Has your company recently won an award or achieved a certification? They'll no doubt want to show it off. Email signature images used to promote certifications & awards can instantly establish credibility with a recipient and provide you with numerous benefits.

 
LVL 5

Expert Comment

by:micalkin
ID: 22686795
Only the Groups/Users listed in the policy are allowed to change the time.
0
 
LVL 6

Expert Comment

by:MrNiss99
ID: 22686885
If there are too many user/ group entries to add to the policy, then just force a time sync with your DC on logon. Then at least it would be in sync upon logon.

Just a thought.

add this to your logon script:

net time \\ntpserver

0
 

Author Comment

by:borgb002
ID: 22687072
micalkin:
I'm doing this from the server ACTIVE DIRECTORY USERS AND COMPUTERS
in the GROUP POLICY OBJECT EDITOR I'm selecting the feature you've mentioned and added a user that obvious is not my user name. I assumed that I was giving access to this user only and automatically inheritince deny permissions to mine; but unfortunately it didnt work that way.

MrNiss99:
I am already doing that... It works but the user still can change the date and time later on.
0
 
LVL 8

Expert Comment

by:Point-In-Cyberspace
ID: 22694450
Let's talk about group policy:

A policy is applied to an object. You have to apply this policy to the object where is contained the COMPUTERS which are used by the users you need to block, because this policy is a computer settings one.
If, for example, computers are in the OU called machines, then you have to apply this policy to that OU.
If they are in a folder you can't apply the policy so you have to create an OU or you may apply the policy to the entire domain. This will apply the policy to the domain controllers too.

In the policy you have to specify which users or users group WILL BE ABLE to cange the date and time, so, in your config, you have to set it to none because all of your users are administrators.


Hope this helps

0
 
LVL 8

Accepted Solution

by:
Point-In-Cyberspace earned 500 total points
ID: 22694456
One more thing: to apply a policy you have to go to the compter that you are using for test and in a command prompt write:
   gpupdate /force

to apply group policy. You have to do this after every policy change, because by default policied are refreshed every hour.

Another way is to restart the test computer.

0
 

Author Comment

by:borgb002
ID: 22694478
Thanks Point-In-Cyberspace

your comment has shed some further light. I'll try it out on computers rather than login names. I had created an OU and applied the policy to that OU, then placed login names under it. Obviously it didnt work out.

I'll try your suggestion ..
0

Featured Post

Will my email signature work in Office 365?

You've built an email signature using raw HTML code in Office 365, but you can't review how it looks with Transport Rules. So you have to test it over and over again before it can be used. Isn't this a bit of a waste of your time? Wouldn't a WYSIWYG editor make it a lot easier?

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Sometimes drives fill up and we don't know why.  If you don't understand the best way to use the tools available, you may end up being stumped as to why your drive says it's not full when you have no space left!  Here's how you can find out...
If you get continual lockouts after changing your Active Directory password, there are several possible reasons.  Two of the most common are using other devices to access your email and stored passwords in the credential manager of windows.
This video will show you how to get GIT to work in Eclipse.   It will walk you through how to install the EGit plugin in eclipse and how to checkout an existing repository.
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

896 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now