Solved

Goldmine error: Unable to open table

Posted on 2008-10-09
5
1,756 Views
Last Modified: 2013-11-15
Were having a problem with our GM database that suddenly started this afternoon.  When starting up GM on a workstation and on the server, were getting this message: "Unable to open table."  The login window shows it stops at the CONTACT2 table (see attached screenshot image)

I went into the SQL Server Enterprise Manager and tried to see if I could see data in the CONTACT2 table and all seems fine.  When I check the properties for the tables, some of them show they were created today at 2:25pm.  I am wondering if anyone was accidentally messing around in the database and did something that is causing the problem. (see attached screenshot image).

Anyone have an idea what is going on and how we can fix the problem?  
error.jpg
SQL-Server.jpg
0
Comment
Question by:rwottowa
  • 2
  • 2
5 Comments
 
LVL 35

Expert Comment

by:David Todd
ID: 22683921
Hi,

How is the application connecting to SQL? Windows Authentication? SQL Authentication?

I'm guessing that if those new tables have jsut been created, then you are lacking the appropriate permissions on those tables.

Can you restore your last SQL backup to a test database, and compare the two databases side-by-side?

Cheers
  David
0
 
LVL 11

Expert Comment

by:stevengraff
ID: 22684089
1. I wonder if someone tried doing "Maintenance" on your GoldMine system. Reindexing is OK, but if they tried doing a rebuild, well, you're not really supposed to do a rebuild of a GoldMine SQL system. That process would, in fact, "create" new tables, which is one of your symptoms.

2. Any catastrophic machine failure recently, or any "event" that would cause the data to become corrupted? Not likely, I think.

3. Did GoldMine continue to work for users who didn't log out?

4. Have you tried bouncing the SQL box? Someone (or something) may have a deathgrip-type lock* on one or more of the tables.

Call me in the morning if #4 doesn't work.
Steven

*Oh, I'm sure there's a more technical term for this!
0
 

Author Comment

by:rwottowa
ID: 22687521
1.      I checked around but couldnt find anything that was done out of the ordinary.
2.      No recent failures.
3.      One user reported it was still working fine for him and he was logged in at the time.  After I restarted the server, he couldnt get in either.
4.      Thats usually my first try with this server.  It is a bit unstable at times and I set up an automatic nightly reboot.

We couldn't wait any longer to fix this problem so I restored the database from our nightly backups.  At least we can access the database again and everything is up and running.
0
 
LVL 11

Accepted Solution

by:
stevengraff earned 500 total points
ID: 22748585
Still working OK?

Without further evidence we can't know for sure, but most likely:

#1 from above...
1. I wonder if someone tried doing "Maintenance" on your GoldMine system. Reindexing is OK, but if they tried doing a rebuild, well, you're not really supposed to do a rebuild of a GoldMine SQL system. That process would, in fact, "create" new tables, which is one of your symptoms.

Best bet is to remove the Maintenance option from users' menu structure in GoldMine, unless they only use GoldMine remotely (i.e. on their notebooks), in which case they do need it.

By any chance were you able to "poll" your user community to see if some well-intended sole may have done Maintenance?

The other possibility is that someone tried adding a new field. During this process the GoldMine interface tells you it needs to do a rebuild. The "best practice" method is to say "no," and add the field manually in SQL's back-end.
0
 

Author Comment

by:rwottowa
ID: 22760780
One user was checking some field properties but she didn't make any changes, as far as she can remember.  Disabling the Maintenance option is a good idea.

It's still running ok so it looks like it was just a one-time issue.
0

Featured Post

Enterprise Mobility and BYOD For Dummies

Like “For Dummies” books, you can read this in whatever order you choose and learn about mobility and BYOD; and how to put a competitive mobile infrastructure in place. Developed for SMBs and large enterprises alike, you will find helpful use cases, planning, and implementation.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Introduction SQL Server Integration Services can read XML files, that’s known by every BI developer.  (If you didn’t, don’t worry, I’m aiming this article at newcomers as well.) But how far can you go?  When does the XML Source component become …
Everyone has problem when going to load data into Data warehouse (EDW). They all need to confirm that data quality is good but they don't no how to proceed. Microsoft has provided new task within SSIS 2008 called "Data Profiler Task". It solve th…
Familiarize people with the process of utilizing SQL Server functions from within Microsoft Access. Microsoft Access is a very powerful client/server development tool. One of the SQL Server objects that you can interact with from within Microsoft Ac…
Via a live example, show how to extract information from SQL Server on Database, Connection and Server properties

777 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question