Solved

2 issues with OWA and Exchange 2003 Frontend server

Posted on 2008-10-09
8
655 Views
Last Modified: 2011-10-19
2 issues I would like to post...
First, When I click the Logoff button once logged into OWA on our Frontend server, it prompts for username and password again. Get "access denied" if canceled or "Log off successful" if I reauthenticate.

Second, when I enable FBA and give it the 10 minutes to take effect (iiisreset command used), I go to the https://server/exchange enter my username and password and it just keeps prompting for username and password. See attachment for the continuous prompting.  If FBA is turned off, I can log in and use the system as normal (except for the log off button problem described above).

Thoughts? I am heading out for the evening but will followup in the morning.
Thanks!
Front-end-OWA.JPG
0
Comment
Question by:SUNYESF
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
  • 2
8 Comments
 
LVL 9

Expert Comment

by:abdulzis
ID: 22684482
Check if the IUSR a/c (for anonymous authentication) is working. Goto properties of default website, security and authentication. Then remove all types of authentication and keep only anonymous. Apply the settings and make sure that when it prompts you to propogate the settings to all virtual directories below, DONOT click yes. we dont want anon auth on all vdirs below.

Then perform iisreset and try browsing the default website & see if you get the under construction page.
0
 
LVL 33

Expert Comment

by:Exchange_Geek
ID: 22685163
0
 

Author Comment

by:SUNYESF
ID: 22686692
Wrong attachment, sorry, here is the correct attachment
OWA-prompting.JPG
0
Does Powershell have you tied up in knots?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 

Author Comment

by:SUNYESF
ID: 22687254
Went thru the steps from msexchange.org doc (delete virtual folders and metabase. Still have the same problem.  Without forms base auth, I can get into OWA.  With FBA Turned on, I get the attachment above.

https:// redirect 403.4 (using owahttps.asp as per Microsoft Exchange 2003 Unleased and msexchange.org)  Get a generic 403 Probable cause, This website requires you to log in.
If I manually enter https://FQDN/ I am can log in with the security lock (without FBA turned on) and everything functions as normal so security isprobably not the root cause.

Logoff button still does not work, must reauthenticate.

Since this box is not in production yet, I can remove excahnge and IIS and start over. however if I do this does anyone have documentation on removing the exchange server (I remember seeing one out there, just can't remember exactly where).
0
 

Accepted Solution

by:
SUNYESF earned 0 total points
ID: 22687675
More information on the logoff button issue...
If I log on to the OWA with either username@domain or domain\username logoff button works.
If I log on to the OWA with just username logoff button prompts for reauthentication (asking for either username@domain or domain\username) and that works by reauthenticating.  

If this is built this way by default, that is fine.  I was just trying to make it easier for our end users to log onto the OWA.
0
 
LVL 9

Expert Comment

by:abdulzis
ID: 22755835
Anyhow its not supposed to prompt for authentication when you log off. That is not by design and you can test in on a Lab machine.
0
 
LVL 33

Expert Comment

by:Exchange_Geek
ID: 22755852
Sorry for the late response.

You could check the same setting on directory settings on Exchange Virtual Directory - do you see the tab filled with \ or Domain Name mentioned at default domain.


image0011171279987656.jpg
0
 

Author Comment

by:SUNYESF
ID: 22757985
It had the NetBIOS domain name in there.  I tried the \, ran the iisreset command.  same problem.

I put in the domain name as xxxx.edu, same problem.  
I was only trying to make it a little easier for my end users to log in.  as of now, we are keeping our instructions to use domain\username or username@domain for log on.  by doing this the end users are not prompted for log off.
If any one has any other comments, I would love to hear from you (especially for the FBA issue Listed above).  My direct supervisor is not so keen on the idea of the FBA and I am still trying to sell him on it.
Thanks everyone.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Utilizing an array to gracefully append to a list of EmailAddresses
This article aims to explain the working of CircularLogArchiver. This tool was designed to solve the buildup of log file in cases where systems do not support circular logging or where circular logging is not enabled
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…
This video discusses moving either the default database or any database to a new volume.

749 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question