Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2492
  • Last Modified:

WatchGuard Firebox IPSec VPN Timeout Issue

I think my VPN might be timing out in a strange manner.  The MUVPN remains connected but after some time, I am unable to access anything on the network unless I reconnect the VPN.  Once I reconnect, everything is fine again.  My developers who are constantly sending data through the VPN have not mentioned anything about it.  My supervisor and I use the VPN but the connection is often left idle.  We are the ones who lose the ability to communicate to the network unless we reconnect the VPN.
0
mansurw02
Asked:
mansurw02
2 Solutions
 
crumberCommented:
We had a similar problem and had the VPN keep alive set with the other IP address.  This eliminated the VPN from going down when left idle for too long.

Hope that helps.
0
 
mansurw02Author Commented:
I am not sure I understand what you mean.  How would I configure a keep alive with an IP address?  I am using WSM 10.2 and MUVPN with IPSec V. 10.  Thanks!
0
 
crumberCommented:
We are using the X10e-W (Firebox X).
I am not sure how that differs from your version; however if you go to the VPN configuration, select the VPN Keep Alive section and add the local Host IP address of the other point to the Echo Host list.
Hope that helps.
0
Lessons on Wi-Fi & Recommendations on KRACK

Simplicity and security can be a difficult  balance for any business to tackle. Join us on December 6th for a look at your company's biggest security gap. We will also address the most recent attack, "KRACK" and provide recommendations on how to secure your Wi-Fi network today!

 
mansurw02Author Commented:
I've got the Firebox X5500e.  I don't see an option like that.  Thanks for helping.
0
 
dpk_walCommented:
As crumber said; you are reaching the timeout value and as a result the VPN gets terminated and you need to reconnect; to overcome this you can create a batch file which would send ICMP packets to the remote network every x seconds; this way the connection would not time out.

You can create a batch file as below [remember to execute it once you get connected to VPN]:
ping <remote-machine-ip-adress> -n 1
sleep 60

Here, sleep is an external utility which you can download from the internet [please evaluate it for security based on your company's policy].

Otherwise you can simply configure a ping with -t option as below:
ping <remote-machine-ip> -t

Thank you.
0
 
mansurw02Author Commented:
It's working fine now.  Thanks for the help!
0
 
BERTLEEMANCommented:
The problem is that the firewall is sending a keep alive packet to the muvpn client on udp port 4500. When there's no exception in your windows firewall (udp 4500) then you are disconnected after 3 minutes. this is only applicable with the muvpn software ver 10.00.... and newer
0
 
visionmn2Commented:
First create a folder in root of C: named Ping (or wherever, whatever)

Then created a batch file png.bat in Notepad or your favorite text editor

Place the following line in the batch file and save where 10.0.0.10 is the IP of a remote resource such as a server:

ping 10.0.0.10 –n 1

Save the batch file

Then create a 2nd file in that same folder called png.vbs (from notepad or text editor). Just copy and pasted the following and change the file path if you are not following this example.

Set WshShell = CreateObject("WScript.Shell")
WshShell.Run chr(34) & "C:\Ping\png.bat" & Chr(34), 0
Set WshShell = Nothing

Save the png file

Set-up a scheduled task in Windows Task Scheduler to run every day starting at 12:01am – and will repeat every 3 minutes or whatever time before it times out until 11:59pm.
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now