Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Exch2k7 OWA IIS & RSA Auth Agent Service Unavailable

Posted on 2008-10-10
1
Medium Priority
?
1,201 Views
Last Modified: 2012-05-05
A couple days after installing RSA Auth Agent 5.3 for IIS w/o enabling or configuring it on my Exch2k7 64bit Win2k3 Stnd Server, all IIS sites including OWA and the default site produce 'Service Unavailable' and I received these events below and my IIS is reporting Service Unavailable for OWA and other related IIS virtual directories.

Event ID's:
Event Type:    Error
Event Source:    W3SVC-WP
Event Category:    None
Event ID:    2268
Date:        10/10/2008
Time:        8:16:12 AM
User:        N/A
Computer:    NYC-EXCH1
Description:
Could not load all ISAPI filters for site/service.  Therefore startup aborted.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 7e 00 00 00               ~...  

-------------------------------------------

Event Type:    Error
Event Source:    W3SVC-WP
Event Category:    None
Event ID:    2214
Date:        10/10/2008
Time:        8:16:12 AM
User:        N/A
Computer:    NYC-EXCH1
Description:
The HTTP Filter DLL C:\Program Files (x86)\RSA Security\RSAWebAgent\WebID\IISWebAgentIF.dll failed to load.  The data is the error.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 7e 00 00 00               ~...  

I tried installing .NET 3.5 SP1 on my Exch2k7 box and I still receive 'service unavailable'.  Previous step was reinstalling the Exch2k7 Client Access role, which didn't help.

ANY IDEAS?

I tried this potential solution and it didn't resolve my issue:
http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_23344735.html#discussion

0
Comment
Question by:lseeman
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
1 Comment
 
LVL 1

Accepted Solution

by:
lseeman earned 0 total points
ID: 22692203
I was able to resolve my specific issue by:

1. Right click on IIS Website folder and choose properties | Services | swtich to isolated mode
2. Under same properties | ISAPIFilters | Remove RSA Filter
3. Switch IIS back to non isolated mode/worker process isolation mode by check mark out

NOTE: This likely resulted from a 32bit RSA Auth Agent instead of 64bit version.
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

There are times when we need to generate a report on the inbox rules, where users have set up forwarding externally in their mailbox. In this article, I will be sharing a script I wrote to generate the report in CSV format.
As much as Microsoft wants to kill off PST file support, just as they tried to do with public folders, there are still times when it is useful or downright necessary to export Exchange mailboxes to PST files. Thankfully, it is still possible to e…
In this video we show how to create a Shared Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Sha…
This video discusses moving either the default database or any database to a new volume.
Suggested Courses

610 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question