Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 428
  • Last Modified:

FTp issue in solaris10

Hi gents,

Am using solaris 10 and my issue is ftp failing as bellow..

ftp home located int to / file system.
Eample: / created in 7 G file system.

once / reaches to 90 % 800M space available on root.. still we unable to do ftp even 30 M file..

is there any seetings/config changes neded?

Regards,
Saran
0
Saranyakkali
Asked:
Saranyakkali
  • 2
  • 2
  • 2
1 Solution
 
RowleyCommented:
How much space have you allocated for minfree? post the output of df -h and fstyp -v /path/to/root/block/diskdevice.
0
 
Brian UtterbackPrinciple Software EngineerCommented:
As Rowley was leading to, there is a parameter on UFS file systems called "minfree" which defaults to 10%. Once this threshold is reached, it is as if the file system was full for users other than root. This is done for two reasons. One is to ensure that root has enough space to allow root to log in and take remedial action. The other is that UFS performance degrades rapidly as it has less free space to work with.

However, with modern large disks, this can result in massive amounts of wasted space. You can use the tunefs command to change the minfree setting on the fly. Luckily minfree happens to be a FS parameter that is easily changed. See the man page for tunefs for details, but it is very simple to run.

By the way, you might consider running a ZFS filesystem instead of UFS. It has no minfree limitation, and is in general much easier to work with.
0
 
SaranyakkaliAuthor Commented:
minfree 1%      maxbpg  2048    optim   time

/dev/md/dsk/d0         7.8G   5.9G   1.8G    77%    /

0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
Brian UtterbackPrinciple Software EngineerCommented:
I would suggest using the truss command on the ftp server during the transfer to capture exactly what error is returned by the write command.
0
 
RowleyCommented:
Also, try putting ftp in debug mode and watch what happens. To do this:

1/ svcadm disable ftp
2/ edit syslog.conf and add the following lines:

daemon.debug                        /var/adm/messages
daemon.info                              /var/adm/messages

Doesn't have to be /var/adm/messages, this is for example only.

3/ svcadm restart system-log
4/ open a duplicate session and tail -f /var/adm/messages if you want...
5/ start ftp manually in another window: /usr/sbin/in.ftpd -sld

You should see detailed debug info which may or may not give you/us some pointers as to what the problem is.
0
 
SaranyakkaliAuthor Commented:
Sorry all, for the late reply.. found the issue with SVM File system..

We recrated the filesystem.. issue solved.. Thankyou all ..
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 2
  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now